diff mbox series

[v2,1/7] package/qemu: enable nios2 support for host-qemu

Message ID 1557075239-30667-2-git-send-email-jugurtha.belkalem@smile.fr
State Accepted
Headers show
Series gitlab Qemu runtime testing | expand

Commit Message

Jugurtha BELKALEM May 5, 2019, 4:53 p.m. UTC
This config enable host eqmu support for nios2 which
allows to test this architecture in gitlab.

Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
---
 package/qemu/Config.in.host | 1 +
 package/qemu/qemu.mk        | 1 +
 2 files changed, 2 insertions(+)

Comments

Thomas Huth May 31, 2019, 6:13 a.m. UTC | #1
Am Sun,  5 May 2019 18:53:53 +0200
schrieb Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>:

> This config enable host eqmu support for nios2 which
> allows to test this architecture in gitlab.

s/eqmu/qemu/

with that fixed:

Reviewed-by: Thomas Huth <huth@tuxfamily.org>
Thomas Petazzoni Aug. 2, 2019, 9:52 p.m. UTC | #2
On Sun,  5 May 2019 18:53:53 +0200
Jugurtha BELKALEM <jugurtha.belkalem@smile.fr> wrote:

> This config enable host eqmu support for nios2 which
> allows to test this architecture in gitlab.
> 
> Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
> ---
>  package/qemu/Config.in.host | 1 +
>  package/qemu/qemu.mk        | 1 +
>  2 files changed, 2 insertions(+)

Applied to master after tweaking a bit the commit log. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qemu/Config.in.host b/package/qemu/Config.in.host
index 8a0df38..160725d 100644
--- a/package/qemu/Config.in.host
+++ b/package/qemu/Config.in.host
@@ -9,6 +9,7 @@  config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
 	default y if BR2_microblazebe
 	default y if BR2_mips
 	default y if BR2_mipsel
+	default y if BR2_nios2
 	default y if BR2_powerpc
 	default y if BR2_powerpc64
 	default y if BR2_powerpc64le
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 19bcafa..e82d372 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -172,6 +172,7 @@  HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman
 #       mipsel          mipsel
 #       mips64          mips64
 #       mips64el        mips64el
+#       nios2           nios2
 #       powerpc         ppc
 #       powerpc64       ppc64
 #       powerpc64le     ppc64 (system) / ppc64le (usermode)