diff mbox series

[v4,17/17] package/liquid-dsp: drop support for fftw-double and fftw-long-double

Message ID 1548078671-63318-17-git-send-email-gwenj@trabucayre.com
State Accepted
Headers show
Series [v4,01/17] package/fftw: prepare for splitting into multiple packages | expand

Commit Message

Gwenhael Goavec-Merou Jan. 21, 2019, 1:51 p.m. UTC
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

liquid-dsp has the following code:
#if HAVE_FFTW3_H && !defined LIQUID_FFTOVERRIDE
#   include <fftw3.h>
#   define FFT_PLAN             fftwf_plan
#   define FFT_CREATE_PLAN      fftwf_plan_dft_1d
#   define FFT_DESTROY_PLAN     fftwf_destroy_plan
#   define FFT_EXECUTE          fftwf_execute
#   define FFT_DIR_FORWARD      FFTW_FORWARD
#   define FFT_DIR_BACKWARD     FFTW_BACKWARD
#   define FFT_METHOD           FFTW_ESTIMATE
#else
#   define FFT_PLAN             fftplan
#   define FFT_CREATE_PLAN      fft_create_plan
#   define FFT_DESTROY_PLAN     fft_destroy_plan
#   define FFT_EXECUTE          fft_execute
#   define FFT_DIR_FORWARD      LIQUID_FFT_FORWARD
#   define FFT_DIR_BACKWARD     LIQUID_FFT_BACKWARD
#   define FFT_METHOD           0
#endif

So, if it uses the external fftw library, it can only use the fftwf
variant, i.e the fftw-single variant. Otherwise, it uses its internal
FFT library.

There is no way for liquid-dsp to use fftw-double or fftw-long-double.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/liquid-dsp/liquid-dsp.mk | 10 ----------
 1 file changed, 10 deletions(-)

Comments

Thomas Petazzoni Feb. 5, 2019, 9:09 p.m. UTC | #1
Hello,

On Mon, 21 Jan 2019 14:51:11 +0100
Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:

> From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> 
> From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> 
> liquid-dsp has the following code:
> #if HAVE_FFTW3_H && !defined LIQUID_FFTOVERRIDE
> #   include <fftw3.h>
> #   define FFT_PLAN             fftwf_plan
> #   define FFT_CREATE_PLAN      fftwf_plan_dft_1d
> #   define FFT_DESTROY_PLAN     fftwf_destroy_plan
> #   define FFT_EXECUTE          fftwf_execute
> #   define FFT_DIR_FORWARD      FFTW_FORWARD
> #   define FFT_DIR_BACKWARD     FFTW_BACKWARD
> #   define FFT_METHOD           FFTW_ESTIMATE
> #else
> #   define FFT_PLAN             fftplan
> #   define FFT_CREATE_PLAN      fft_create_plan
> #   define FFT_DESTROY_PLAN     fft_destroy_plan
> #   define FFT_EXECUTE          fft_execute
> #   define FFT_DIR_FORWARD      LIQUID_FFT_FORWARD
> #   define FFT_DIR_BACKWARD     LIQUID_FFT_BACKWARD
> #   define FFT_METHOD           0
> #endif
> 
> So, if it uses the external fftw library, it can only use the fftwf
> variant, i.e the fftw-single variant. Otherwise, it uses its internal
> FFT library.
> 
> There is no way for liquid-dsp to use fftw-double or fftw-long-double.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/liquid-dsp/liquid-dsp.mk | 10 ----------
>  1 file changed, 10 deletions(-)

Applied to master, thanks. I have applied *before* all other patches,
because it's really a preparation fix that is useful independently from
the rest of the FFTW rework.

Thanks,

Thomas
Baruch Siach Feb. 6, 2019, 5:40 a.m. UTC | #2
Hi Thomas,

On Tue, Feb 05, 2019 at 10:09:40PM +0100, Thomas Petazzoni wrote:
> On Mon, 21 Jan 2019 14:51:11 +0100
> Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:
> 
> > From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> > 
> > From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> > 
> > liquid-dsp has the following code:
> > #if HAVE_FFTW3_H && !defined LIQUID_FFTOVERRIDE
> > #   include <fftw3.h>
> > #   define FFT_PLAN             fftwf_plan
> > #   define FFT_CREATE_PLAN      fftwf_plan_dft_1d
> > #   define FFT_DESTROY_PLAN     fftwf_destroy_plan
> > #   define FFT_EXECUTE          fftwf_execute
> > #   define FFT_DIR_FORWARD      FFTW_FORWARD
> > #   define FFT_DIR_BACKWARD     FFTW_BACKWARD
> > #   define FFT_METHOD           FFTW_ESTIMATE
> > #else
> > #   define FFT_PLAN             fftplan
> > #   define FFT_CREATE_PLAN      fft_create_plan
> > #   define FFT_DESTROY_PLAN     fft_destroy_plan
> > #   define FFT_EXECUTE          fft_execute
> > #   define FFT_DIR_FORWARD      LIQUID_FFT_FORWARD
> > #   define FFT_DIR_BACKWARD     LIQUID_FFT_BACKWARD
> > #   define FFT_METHOD           0
> > #endif
> > 
> > So, if it uses the external fftw library, it can only use the fftwf
> > variant, i.e the fftw-single variant. Otherwise, it uses its internal
> > FFT library.
> > 
> > There is no way for liquid-dsp to use fftw-double or fftw-long-double.
> > 
> > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> > Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> > ---
> >  package/liquid-dsp/liquid-dsp.mk | 10 ----------
> >  1 file changed, 10 deletions(-)
> 
> Applied to master, thanks. I have applied *before* all other patches,
> because it's really a preparation fix that is useful independently from
> the rest of the FFTW rework.

Unfortunately the '#' prefixed lines in the commit log were dropped again.

baruch
Thomas Petazzoni Feb. 6, 2019, 8:36 a.m. UTC | #3
Hello,

On Wed, 6 Feb 2019 07:40:24 +0200
Baruch Siach <baruch@tkos.co.il> wrote:

> > Applied to master, thanks. I have applied *before* all other patches,
> > because it's really a preparation fix that is useful independently from
> > the rest of the FFTW rework.  
> 
> Unfortunately the '#' prefixed lines in the commit log were dropped again.

Yeah, Yann pointed this to me as well. Sadly now it's committed and
pushed, so it's too late. Oh well.

Thomas
diff mbox series

Patch

diff --git a/package/liquid-dsp/liquid-dsp.mk b/package/liquid-dsp/liquid-dsp.mk
index 6aa27a5248..64c403e87f 100644
--- a/package/liquid-dsp/liquid-dsp.mk
+++ b/package/liquid-dsp/liquid-dsp.mk
@@ -40,16 +40,6 @@  ifeq ($(BR2_powerpc)$(BR2_powerpc64)$(BR2_powerpc64le),y)
 LIQUID_DSP_CONF_OPTS += --enable-simdoverride
 endif
 
-ifeq ($(BR2_PACKAGE_FFTW_DOUBLE),y)
-LIQUID_DSP_LDFLAGS += -lfftw3
-LIQUID_DSP_DEPENDENCIES += fftw-double
-endif
-
-ifeq ($(BR2_PACKAGE_FFTW_LONG_DOUBLE),y)
-LIQUID_DSP_LDFLAGS += -lfftw3l
-LIQUID_DSP_DEPENDENCIES += fftw-long-double
-endif
-
 LIQUID_DSP_CONF_OPTS += \
 	CFLAGS="$(LIQUID_DSP_CFLAGS)" \
 	LDFLAGS="$(LIQUID_DSP_LDFLAGS)"