diff mbox series

[1/2] package/assimp: remove redundant ':' sign

Message ID 1525551191-7113-1-git-send-email-jerzy.m.grzegorek@gmail.com
State Rejected
Headers show
Series [1/2] package/assimp: remove redundant ':' sign | expand

Commit Message

Jerzy Grzegorek May 5, 2018, 8:13 p.m. UTC
Signed-off-by: Jerzy Grzegorek <jerzy.m.grzegorek@gmail.com>
---
 package/assimp/assimp.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni May 7, 2018, 2:42 p.m. UTC | #1
Hello,

On Sat,  5 May 2018 22:13:10 +0200, Jerzy Grzegorek wrote:
> Signed-off-by: Jerzy Grzegorek <jerzy.m.grzegorek@gmail.com>
> ---
>  package/assimp/assimp.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/assimp/assimp.mk b/package/assimp/assimp.mk
> index 4d44748..e391145 100644
> --- a/package/assimp/assimp.mk
> +++ b/package/assimp/assimp.mk
> @@ -20,7 +20,7 @@ endif
>  # not passed) in gcc versions 5.x or older. The -Os optimization level
>  # causes a "unable to find a register to spill in class
>  # ‘GENERAL_REGS’" error. -O2 works fine.
> -ifeq ($(BR2_sh):$(BR2_STATIC_LIBS):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:y:)
> +ifeq ($(BR2_sh)$(BR2_STATIC_LIBS):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),yy:)

I don't find the ":" to be really redundant. Yes, this ":" is not
technically needed, but it makes the construct very clear and avoids
any possible confusion.

So I think my preference would be to keep things as-is. I know in other
places we don't put a ":" when we need both options to be "y". But when
we have a case where some options need to be "y", some options need to
be empty, I find having a ":" between each to be clearer.

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/assimp/assimp.mk b/package/assimp/assimp.mk
index 4d44748..e391145 100644
--- a/package/assimp/assimp.mk
+++ b/package/assimp/assimp.mk
@@ -20,7 +20,7 @@  endif
 # not passed) in gcc versions 5.x or older. The -Os optimization level
 # causes a "unable to find a register to spill in class
 # ‘GENERAL_REGS’" error. -O2 works fine.
-ifeq ($(BR2_sh):$(BR2_STATIC_LIBS):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:y:)
+ifeq ($(BR2_sh)$(BR2_STATIC_LIBS):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),yy:)
 ASSIMP_CXXFLAGS += -O2
 endif