diff mbox series

[1/1] python-xlrd: add as host package

Message ID 1508531674-6145-1-git-send-email-lothar.felten@gmail.com
State Accepted
Headers show
Series [1/1] python-xlrd: add as host package | expand

Commit Message

Lothar Felten Oct. 20, 2017, 8:34 p.m. UTC
This patch adds the xlrd module for the host.
Currently there is no buildroot package that depends on this module.

I use it to process excel files, other might find it usefull too.

Signed-off-by: Lothar Felten <lothar.felten@gmail.com>
---
 package/python-xlrd/Config.in.host | 7 +++++++
 package/python-xlrd/python-xlrd.mk | 1 +
 2 files changed, 8 insertions(+)
 create mode 100644 package/python-xlrd/Config.in.host

Comments

Arnout Vandecappelle April 1, 2018, 12:08 p.m. UTC | #1
On 20-10-17 22:34, Lothar Felten wrote:
> This patch adds the xlrd module for the host.
> Currently there is no buildroot package that depends on this module.
> 
> I use it to process excel files, other might find it usefull too.

 Applied to master, thanks. You had forgotten to add it to
package/Config.in.host though.

 Regards,
 Arnout

> 
> Signed-off-by: Lothar Felten <lothar.felten@gmail.com>[snip]
diff mbox series

Patch

diff --git a/package/python-xlrd/Config.in.host b/package/python-xlrd/Config.in.host
new file mode 100644
index 0000000..4935925
--- /dev/null
+++ b/package/python-xlrd/Config.in.host
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_HOST_PYTHON_XLRD
+	bool "host python-xlrd"
+	help
+	  Library for developers to extract data from Microsoft Excel (tm)
+	  spreadsheet files.
+
+	  http://www.python-excel.org/
diff --git a/package/python-xlrd/python-xlrd.mk b/package/python-xlrd/python-xlrd.mk
index e3f078c..5d13638 100644
--- a/package/python-xlrd/python-xlrd.mk
+++ b/package/python-xlrd/python-xlrd.mk
@@ -12,3 +12,4 @@  PYTHON_XLRD_LICENSE = BSD-3-Clause
 PYTHON_XLRD_LICENSE_FILES = xlrd/licences.py
 
 $(eval $(python-package))
+$(eval $(host-python-package))