diff mbox

[v3,2/3] Export LINUX_DIR for post-build scripts

Message ID 1488202681-9744-2-git-send-email-abhimanyu.vishwakarma@imgtec.com
State Superseded
Headers show

Commit Message

Abhimanyu V Feb. 27, 2017, 1:38 p.m. UTC
From: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>

To build fitImage in post-build scripts, we need compressed
kernel binary which is intermediate target, hence doesnt get
copied to output/images folder.

Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
Reviewed-by: Rahul Bedarkar <Rahul.Bedarkar@imgtec.com>
---
 Makefile | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle March 13, 2017, 11:04 p.m. UTC | #1
On 27-02-17 14:38, Abhimanyu V wrote:
> From: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
> 
> To build fitImage in post-build scripts, we need compressed
> kernel binary which is intermediate target, hence doesnt get
> copied to output/images folder.
> 
> Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
> Reviewed-by: Rahul Bedarkar <Rahul.Bedarkar@imgtec.com>
> ---
>  Makefile | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/Makefile b/Makefile
> index 9663d15..5c8a934 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -464,6 +464,7 @@ export STAGING_DIR
>  export HOST_DIR
>  export BINARIES_DIR
>  export BASE_DIR
> +export LINUX_DIR

 I don't really like how we are exporting random variables. You never know if
some package is using it internally and gives it some different meaning.
Therefore, I'd prefer to add it to EXTRA_ENV, which also makes it available to
post-build scripts.

 Regards,
 Arnout

>  
>  ################################################################################
>  #
>
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 9663d15..5c8a934 100644
--- a/Makefile
+++ b/Makefile
@@ -464,6 +464,7 @@  export STAGING_DIR
 export HOST_DIR
 export BINARIES_DIR
 export BASE_DIR
+export LINUX_DIR
 
 ################################################################################
 #