diff mbox

erlang: set ERL_TOP to avoid using user's version

Message ID 1487451671-2066-1-git-send-email-fhunleth@troodon-software.com
State Accepted
Commit 9e90efa52ec3fd2d62b59488a1b347a55d356234
Headers show

Commit Message

Frank Hunleth Feb. 18, 2017, 9:01 p.m. UTC
Explicitly set the ERL_TOP environment variable to override values set
on a user's system. This prevents Erlang's configure scripts from
using source files outside of the ones that Buildroot downloaded.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
---
 package/erlang/erlang.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard Feb. 19, 2017, 10:20 p.m. UTC | #1
>>>>> "Frank" == Frank Hunleth <fhunleth@troodon-software.com> writes:

 > Explicitly set the ERL_TOP environment variable to override values set
 > on a user's system. This prevents Erlang's configure scripts from
 > using source files outside of the ones that Buildroot downloaded.

 > Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/erlang/erlang.mk b/package/erlang/erlang.mk
index 3200c38..364085c 100644
--- a/package/erlang/erlang.mk
+++ b/package/erlang/erlang.mk
@@ -30,6 +30,12 @@  ERLANG_CONF_ENV += erl_xcomp_sysroot=$(STAGING_DIR)
 
 ERLANG_CONF_OPTS = --without-javac
 
+# Force ERL_TOP to the downloaded source directory. This prevents
+# Erlang's configure script from inadvertantly using files from
+# a version of Erlang installed on the host.
+ERLANG_CONF_ENV += ERL_TOP=$(@D)
+HOST_ERLANG_CONF_ENV += ERL_TOP=$(@D)
+
 # erlang uses openssl for all things crypto. Since the host tools (such as
 # rebar) uses crypto, we need to build host-erlang with support for openssl.
 HOST_ERLANG_DEPENDENCIES = host-openssl