diff mbox

[v2] openal: Explicitly enable/disable NEON support

Message ID 1472754894-6903-1-git-send-email-nerv@dawncrow.de
State Changes Requested
Headers show

Commit Message

André Zwing Sept. 1, 2016, 6:34 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/d7ccef77a355ccc23f26d012e8441af931469ae4
http://autobuild.buildroot.net/results/b5777a0ed33f6bb7a5fc0486ea21ecef58615dac

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: André Hentschel <nerv@dawncrow.de>
---
 package/openal/openal.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Sept. 6, 2016, 8:25 p.m. UTC | #1
Hello,

On Thu,  1 Sep 2016 20:34:54 +0200, André Hentschel wrote:
> Fixes:
> http://autobuild.buildroot.net/results/d7ccef77a355ccc23f26d012e8441af931469ae4
> http://autobuild.buildroot.net/results/b5777a0ed33f6bb7a5fc0486ea21ecef58615dac
> 
> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> Signed-off-by: André Hentschel <nerv@dawncrow.de>

What about instead:

  https://github.com/kcat/openal-soft/pull/64

to fix this issue (I tested, it fixes the build failure).

Thomas
André Zwing Sept. 10, 2016, 12:09 p.m. UTC | #2
Am 06.09.2016 um 22:25 schrieb Thomas Petazzoni:
> Hello,
> 
> On Thu,  1 Sep 2016 20:34:54 +0200, André Hentschel wrote:
>> Fixes:
>> http://autobuild.buildroot.net/results/d7ccef77a355ccc23f26d012e8441af931469ae4
>> http://autobuild.buildroot.net/results/b5777a0ed33f6bb7a5fc0486ea21ecef58615dac
>>
>> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> 
> What about instead:
> 
>   https://github.com/kcat/openal-soft/pull/64
> 
> to fix this issue (I tested, it fixes the build failure).
> 
> Thomas
> 

Sorry was on a business trip.
As it is upstream meanwhile (together with a runtime neon check suggested by you) I'm fine with a patch added to the openal package.
It's your work, so be free to do so.
Or do you know about plans of an upcoming openal bugfix release? That'd be easier I guess
Thomas Petazzoni Sept. 11, 2016, 11:55 a.m. UTC | #3
Hello,

On Sat, 10 Sep 2016 14:09:37 +0200, André Hentschel wrote:

> Sorry was on a business trip.
> As it is upstream meanwhile (together with a runtime neon check suggested by you) I'm fine with a patch added to the openal package.
> It's your work, so be free to do so.

If you could send a Buildroot patch adding the upstream fix, it would
be nice.

> Or do you know about plans of an upcoming openal bugfix release?
> That'd be easier I guess

I'm not aware of upstream plans in terms of new releases, I don't know
if they do regular ones or not. In order to avoid seeing build
failures, backporting the upstreaming fix would be a good thing to do
for now.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/openal/openal.mk b/package/openal/openal.mk
index 2916aa6..aac1121 100644
--- a/package/openal/openal.mk
+++ b/package/openal/openal.mk
@@ -50,4 +50,11 @@  ifeq ($(BR2_STATIC_LIBS),y)
 OPENAL_CONF_OPTS += -DLIBTYPE=STATIC
 endif
 
+# Explicitly enable/disable NEON support, see https://github.com/kcat/openal-soft/issues/54
+ifeq ($(BR2_ARM_FPU_NEON)$(BR2_ARM_FPU_NEON_VFPV4),y)
+OPENAL_CONF_OPTS += -DALSOFT_CPUEXT_NEON=ON
+else
+OPENAL_CONF_OPTS += -DALSOFT_CPUEXT_NEON=OFF
+endif
+
 $(eval $(cmake-package))