diff mbox

[v1,1/1] package: Add hid-replay package

Message ID 1467462242-35261-1-git-send-email-andriy.shevchenko@linux.intel.com
State Changes Requested
Headers show

Commit Message

Andy Shevchenko July 2, 2016, 12:24 p.m. UTC
Package provides a tool to record HID events and replay them.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 package/Config.in                |  1 +
 package/hid-replay/Config.in     |  6 ++++++
 package/hid-replay/hid-replay.mk | 12 ++++++++++++
 3 files changed, 19 insertions(+)
 create mode 100644 package/hid-replay/Config.in
 create mode 100644 package/hid-replay/hid-replay.mk

Comments

Thomas Petazzoni July 2, 2016, 1:32 p.m. UTC | #1
Hello,

On Sat,  2 Jul 2016 15:24:02 +0300, Andy Shevchenko wrote:

> diff --git a/package/hid-replay/hid-replay.mk b/package/hid-replay/hid-replay.mk
> new file mode 100644
> index 0000000..0e021de
> --- /dev/null
> +++ b/package/hid-replay/hid-replay.mk
> @@ -0,0 +1,12 @@
> +################################################################################
> +#
> +# hid-replay
> +#
> +################################################################################
> +
> +HID_REPLAY_VERSION = master

This is not good as it leads to non-reproducible builds: depending on
when a user starts the build, he will get a different result because
master might have evolved. Please use either a tag, or a full commit id.

> +HID_REPLAY_SITE = https://github.com/bentiss/hid-replay.git

Please use the github macro.

Also, please add a hash file, since the tarballs provided by github,
and used by our github macro.

Could you take those comments into account and send an updated version?

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 9d668bf..5d0114d 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -80,6 +80,7 @@  menu "Debugging, profiling and benchmark"
 	source "package/fio/Config.in"
 	source "package/gdb/Config.in"
 	source "package/google-breakpad/Config.in"
+	source "package/hid-replay/Config.in"
 	source "package/iozone/Config.in"
 	source "package/kexec/Config.in"
 	source "package/kexec-lite/Config.in"
diff --git a/package/hid-replay/Config.in b/package/hid-replay/Config.in
new file mode 100644
index 0000000..512a626
--- /dev/null
+++ b/package/hid-replay/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_HID_REPLAY
+	bool "hid-replay"
+	help
+	  HID recorder for Linux
+
+	  http://bentiss.github.io/hid-replay-docs/
diff --git a/package/hid-replay/hid-replay.mk b/package/hid-replay/hid-replay.mk
new file mode 100644
index 0000000..0e021de
--- /dev/null
+++ b/package/hid-replay/hid-replay.mk
@@ -0,0 +1,12 @@ 
+################################################################################
+#
+# hid-replay
+#
+################################################################################
+
+HID_REPLAY_VERSION = master
+HID_REPLAY_SITE = https://github.com/bentiss/hid-replay.git
+HID_REPLAY_SITE_METHOD = git
+HID_REPLAY_AUTORECONF = YES
+
+$(eval $(autotools-package))