diff mbox

[v3,2/2] erlang: remove extraneous LIBS=-latomic_ops

Message ID 1456082246-28181-2-git-send-email-fhunleth@troodon-software.com
State Superseded
Headers show

Commit Message

Frank Hunleth Feb. 21, 2016, 7:17 p.m. UTC
As suggested by Thomas Petazzoni, this isn't needed when building with
libatomic_ops.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
---
Changes v2->v3:
  - Pulled LIBS=-libatomic_ops removal into a separate patch

 package/erlang/erlang.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/erlang/erlang.mk b/package/erlang/erlang.mk
index 8257ab4..b1c8e35 100644
--- a/package/erlang/erlang.mk
+++ b/package/erlang/erlang.mk
@@ -34,7 +34,7 @@  ERLANG_CONF_OPTS = --without-javac
 # available. Override this if the user wants libatomic_ops.
 ifeq ($(BR2_PACKAGE_ERLANG_LIBATOMIC_OPS),y)
 ERLANG_DEPENDENCIES += libatomic_ops
-ERLANG_CONF_OPTS += --with-libatomic_ops=$(STAGING_DIR)/usr LIBS=-latomic_ops
+ERLANG_CONF_OPTS += --with-libatomic_ops=$(STAGING_DIR)/usr
 endif
 
 # erlang uses openssl for all things crypto. Since the host tools (such as