diff mbox

[2/2] package/python-web2py: fix permissions

Message ID 1446662767-15730-2-git-send-email-nrubinstein@aldebaran.com
State Accepted
Headers show

Commit Message

=?UTF-8?q?No=C3=A9=20Rubinstein?= Nov. 4, 2015, 6:46 p.m. UTC
The PYTHON_WEB2PY_PERMISSIONS table was using the user and group names
instead of the uid and gid, causing makedevs to retrieve the uid and gid
from the host system.

Signed-off-by: NoƩ Rubinstein <nrubinstein@aldebaran.com>
---
 package/python-web2py/python-web2py.mk | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/python-web2py/python-web2py.mk b/package/python-web2py/python-web2py.mk
index 313114a..db9ed8d 100644
--- a/package/python-web2py/python-web2py.mk
+++ b/package/python-web2py/python-web2py.mk
@@ -32,8 +32,16 @@  define PYTHON_WEB2PY_INSTALL_INIT_SYSTEMD
 		$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/web2py.service
 endef
 
+# www-data user and group are used for web2py. Because these user and group
+# are already set by buildroot, it is not necessary to redefine them.
+# See system/skeleton/etc/passwd
+#   username: www-data    uid: 33
+#   groupname: www-data   gid: 33
+#
+# So, we just need to create the directories used by web2py with the right
+# ownership.
 define PYTHON_WEB2PY_PERMISSIONS
-	/var/www/web2py  r  750  www-data  www-data  -  -  -  -  -
+	/var/www/web2py  r  750  33  33  -  -  -  -  -
 endef
 
 $(eval $(generic-package))