diff mbox

[v2,1/2] trousers: new package

Message ID 1446659225-30438-1-git-send-email-nrubinstein@aldebaran.com
State Accepted
Headers show

Commit Message

=?UTF-8?q?No=C3=A9=20Rubinstein?= Nov. 4, 2015, 5:47 p.m. UTC
Signed-off-by: Al West <al.west@v-nova.com>
Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com>

---

Previously submitted by Al West <al.west@v-nova.com>

Changes since v1:
* Removed upstreamed patch
* Remove configuration option "--disable-usercheck"
* Use upstream hashes
* More verbose package description
* Cosmetic changes
---
 package/Config.in              |  1 +
 package/trousers/Config.in     | 11 +++++++++++
 package/trousers/trousers.hash |  3 +++
 package/trousers/trousers.mk   | 17 +++++++++++++++++
 4 files changed, 32 insertions(+)
 create mode 100644 package/trousers/Config.in
 create mode 100644 package/trousers/trousers.hash
 create mode 100644 package/trousers/trousers.mk

Comments

=?UTF-8?q?No=C3=A9=20Rubinstein?= Nov. 4, 2015, 6:04 p.m. UTC | #1
> * Remove configuration option "--disable-usercheck"

Oops; as the diff shows, I changed my mind on this one, and added a
comment instead.

--
Noé Rubinstein
Thomas Petazzoni Dec. 24, 2015, 7:42 a.m. UTC | #2
Dear Noé Rubinstein,

On Wed,  4 Nov 2015 18:47:04 +0100, Noé Rubinstein wrote:
> Signed-off-by: Al West <al.west@v-nova.com>
> Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com>
> 
> ---

I've applied, but there were a number of remaining issues that had to
be fixed:

    [Thomas:
     - use a 'select' instead of a 'depends on' for openssl
     - select libiconv when locale support is not available, otherwise the
       build fails due to missing iconv.h
     - disable on BR2_STATIC_LIBS configurations as it doesn't build. It
       could be made to build by patching the trousers Makefile.
     - add missing dependency on thread support in the toolchain
     - add Config.in comment about the thread and dynamic library
       dependencies.
     - add missing <pkg>_LICENSE and <pkg>_LICENSE_FILES variables.]

Please monitor autobuild.buildroot.org in the coming days to see if
there are any failures related to this new package.

Thanks a lot!

Thomas
Noé Rubinstein Dec. 24, 2015, 9:21 a.m. UTC | #3
Good morning Thomas,

Thanks a lot for all these fixes and for merging.

2015-12-24 8:42 GMT+01:00 Thomas Petazzoni <
thomas.petazzoni@free-electrons.com>:

>      - select libiconv when locale support is not available, otherwise the
>        build fails due to missing iconv.h
>      - disable on BR2_STATIC_LIBS configurations as it doesn't build. It
>        could be made to build by patching the trousers Makefile.
>      - add missing dependency on thread support in the toolchain
>

Are you running an automatic test set on your host machine to detect these
problems?


> Please monitor autobuild.buildroot.org in the coming days to see if
> there are any failures related to this new package.
>

I will do this.

Thanks again,
Noé.
Thomas Petazzoni Dec. 24, 2015, 10:07 a.m. UTC | #4
Hello,

On Thu, 24 Dec 2015 10:21:00 +0100, Noé RUBINSTEIN wrote:

> >      - select libiconv when locale support is not available, otherwise the
> >        build fails due to missing iconv.h
> >      - disable on BR2_STATIC_LIBS configurations as it doesn't build. It
> >        could be made to build by patching the trousers Makefile.
> >      - add missing dependency on thread support in the toolchain
> >
> 
> Are you running an automatic test set on your host machine to detect these
> problems?

No, I am testing with a bunch of toolchains used by autobuild.b.o.
Since your package had no toolchain dependencies, I tested with
http://autobuild.buildroot.org/toolchains/configs/br-arm-basic.config.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index f0ddf0c..850cb83 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -765,6 +765,7 @@  menu "Crypto"
 	source "package/nettle/Config.in"
 	source "package/openssl/Config.in"
 	source "package/polarssl/Config.in"
+	source "package/trousers/Config.in"
 endmenu
 
 menu "Database"
diff --git a/package/trousers/Config.in b/package/trousers/Config.in
new file mode 100644
index 0000000..a740c00
--- /dev/null
+++ b/package/trousers/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_TROUSERS
+	bool "trousers"
+	depends on BR2_PACKAGE_OPENSSL
+	help
+	  The open-source TCG Software Stack (TSS).
+
+	  This library enables the use of a Trusted Platform Module that
+	  complies with the TPM specification, version 1.2. It implements the
+	  TSS specification, version 1.2.
+
+	  http://trousers.sourceforge.net/
diff --git a/package/trousers/trousers.hash b/package/trousers/trousers.hash
new file mode 100644
index 0000000..997cfa9
--- /dev/null
+++ b/package/trousers/trousers.hash
@@ -0,0 +1,3 @@ 
+# http://sourceforge.net/projects/trousers/files/trousers/0.3.13/
+sha1 d23f1a3df4febffc4174f5cca7d1c54230477bb2 trousers-0.3.13.tar.gz
+md5  ad508f97b406f6e48cd90e85d78e7ca8         trousers-0.3.13.tar.gz
diff --git a/package/trousers/trousers.mk b/package/trousers/trousers.mk
new file mode 100644
index 0000000..86366e9
--- /dev/null
+++ b/package/trousers/trousers.mk
@@ -0,0 +1,17 @@ 
+#############################################################
+#
+# trousers
+#
+##############################################################
+
+TROUSERS_VERSION = 0.3.13
+TROUSERS_SOURCE = trousers-$(TROUSERS_VERSION).tar.gz
+TROUSERS_SITE = http://downloads.sourceforge.net/project/trousers/trousers/$(TROUSERS_VERSION)
+TROUSERS_INSTALL_STAGING = YES
+TROUSERS_DEPENDENCIES = openssl
+
+# The TrouSerS build system attempts to create the tss user and group on the
+# host system. Disable the user checking feature as a workaround.
+TROUSERS_CONF_OPTS += --disable-usercheck
+
+$(eval $(autotools-package))