diff mbox

package/protobuf: autoreconf is now needed

Message ID 1432269020-9421-1-git-send-email-s.martin49@gmail.com
State Accepted
Headers show

Commit Message

Samuel Martin May 22, 2015, 4:30 a.m. UTC
Since its update, the *_SITE points to the git repository, so configure
script is not generated in this tarball.

Fixes:
  http://autobuild.buildroot.org/results/ccb/ccba6d8c73b5e826b86065b77b3fe5077db7b99c/
  http://autobuild.buildroot.org/results/57e/57ea34e9b48293075e10f0dd2331de2785730827/
  and many more...

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
 package/protobuf/protobuf.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Peter Korsgaard May 22, 2015, 5:22 a.m. UTC | #1
>>>>> "Samuel" == Samuel Martin <s.martin49@gmail.com> writes:

 > Since its update, the *_SITE points to the git repository, so configure
 > script is not generated in this tarball.

 > Fixes:
 >   http://autobuild.buildroot.org/results/ccb/ccba6d8c73b5e826b86065b77b3fe5077db7b99c/
 >   http://autobuild.buildroot.org/results/57e/57ea34e9b48293075e10f0dd2331de2785730827/
 >   and many more...

 > Signed-off-by: Samuel Martin <s.martin49@gmail.com>

Committed, thanks.
Peter Korsgaard May 22, 2015, 5:58 a.m. UTC | #2
>>>>> "Samuel" == Samuel Martin <s.martin49@gmail.com> writes:

 > Since its update, the *_SITE points to the git repository, so configure
 > script is not generated in this tarball.

 > Fixes:
 >   http://autobuild.buildroot.org/results/ccb/ccba6d8c73b5e826b86065b77b3fe5077db7b99c/
 >   http://autobuild.buildroot.org/results/57e/57ea34e9b48293075e10f0dd2331de2785730827/
 >   and many more...

 > Signed-off-by: Samuel Martin <s.martin49@gmail.com>
 > ---
 >  package/protobuf/protobuf.mk | 3 +++
 >  1 file changed, 3 insertions(+)

 > diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
 > index b426873..438c0d8 100644
 > --- a/package/protobuf/protobuf.mk
 > +++ b/package/protobuf/protobuf.mk
 > @@ -8,6 +8,9 @@ PROTOBUF_VERSION = v2.5.0
 >  PROTOBUF_SITE = $(call github,google,protobuf,$(PROTOBUF_VERSION))
 >  PROTOBUF_LICENSE = BSD-3c
 >  PROTOBUF_LICENSE_FILES = COPYING.txt
 > +# no configure script
 > +PROTOBUF_AUTORECONF = YES
 > +HOST_PROTOBUF_AUTORECONF = YES

FYI, The HOST_ variable defaults to the value of the target one, so I've
dropped the redundant 2nd line.
Samuel Martin May 22, 2015, 7:23 a.m. UTC | #3
On Fri, May 22, 2015 at 7:58 AM, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Samuel" == Samuel Martin <s.martin49@gmail.com> writes:
>
>  > Since its update, the *_SITE points to the git repository, so configure
>  > script is not generated in this tarball.
>
>  > Fixes:
>  >   http://autobuild.buildroot.org/results/ccb/ccba6d8c73b5e826b86065b77b3fe5077db7b99c/
>  >   http://autobuild.buildroot.org/results/57e/57ea34e9b48293075e10f0dd2331de2785730827/
>  >   and many more...
>
>  > Signed-off-by: Samuel Martin <s.martin49@gmail.com>
>  > ---
>  >  package/protobuf/protobuf.mk | 3 +++
>  >  1 file changed, 3 insertions(+)
>
>  > diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
>  > index b426873..438c0d8 100644
>  > --- a/package/protobuf/protobuf.mk
>  > +++ b/package/protobuf/protobuf.mk
>  > @@ -8,6 +8,9 @@ PROTOBUF_VERSION = v2.5.0
>  >  PROTOBUF_SITE = $(call github,google,protobuf,$(PROTOBUF_VERSION))
>  >  PROTOBUF_LICENSE = BSD-3c
>  >  PROTOBUF_LICENSE_FILES = COPYING.txt
>  > +# no configure script
>  > +PROTOBUF_AUTORECONF = YES
>  > +HOST_PROTOBUF_AUTORECONF = YES
>
> FYI, The HOST_ variable defaults to the value of the target one, so I've
> dropped the redundant 2nd line.

Right, thanks for fixing it. :)

>
> --
> Bye, Peter Korsgaard
diff mbox

Patch

diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
index b426873..438c0d8 100644
--- a/package/protobuf/protobuf.mk
+++ b/package/protobuf/protobuf.mk
@@ -8,6 +8,9 @@  PROTOBUF_VERSION = v2.5.0
 PROTOBUF_SITE = $(call github,google,protobuf,$(PROTOBUF_VERSION))
 PROTOBUF_LICENSE = BSD-3c
 PROTOBUF_LICENSE_FILES = COPYING.txt
+# no configure script
+PROTOBUF_AUTORECONF = YES
+HOST_PROTOBUF_AUTORECONF = YES
 
 # N.B. Need to use host protoc during cross compilation.
 PROTOBUF_DEPENDENCIES = host-protobuf