diff mbox

[1/1] python-pyqt: fix opengl build failure

Message ID 1430924376-26750-1-git-send-email-gwenj@trabucayre.com
State Accepted
Headers show

Commit Message

Gwenhael Goavec-Merou May 6, 2015, 2:59 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

Fix:
http://autobuild.buildroot.net/results/206/2062208c171207428c9121215971e00c52bf306a/

According to configure-ng.py, PyQt_NoOpenGLES must be added to qtdetail when
QT_OPENGL_ES is set.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/python-pyqt/python-pyqt.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni May 6, 2015, 3:14 p.m. UTC | #1
Dear Gwenhael Goavec-Merou,

On Wed,  6 May 2015 16:59:36 +0200, Gwenhael Goavec-Merou wrote:

> +ifeq ($(BR2_PACKAGE_QT_OPENGL_ES),y)
> +PYTHON_PYQT_QTDETAIL_DISABLE_FEATURES += PyQt_NoOpenGLES
> +endif

Wow, this is a lot of negation.

So, when OpenGL ES is available, you need to disable the fact of not
using OpenGL ES.

Interesting :-)

Maybe a comment above this piece of code would be useful, because it's
a bit twisted.

Thomas
Gwenhael Goavec-Merou May 6, 2015, 3:41 p.m. UTC | #2
Yes.
There are something funny in the logic of this disabling the disable of
something to enabling openglES support...
Gwen

On Wed, 6 May 2015 17:14:50 +0200
Thomas Petazzoni <thomas.petazzoni@free-electrons.com> wrote:

> Dear Gwenhael Goavec-Merou,
> 
> On Wed,  6 May 2015 16:59:36 +0200, Gwenhael Goavec-Merou wrote:
> 
> > +ifeq ($(BR2_PACKAGE_QT_OPENGL_ES),y)
> > +PYTHON_PYQT_QTDETAIL_DISABLE_FEATURES += PyQt_NoOpenGLES
> > +endif
> 
> Wow, this is a lot of negation.
> 
> So, when OpenGL ES is available, you need to disable the fact of not
> using OpenGL ES.
> 
> Interesting :-)
> 
> Maybe a comment above this piece of code would be useful, because it's
> a bit twisted.
> 
> Thomas
> -- 
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux, Kernel and Android engineering
> http://free-electrons.com
Thomas Petazzoni May 6, 2015, 7:35 p.m. UTC | #3
Dear Gwenhael Goavec-Merou,

On Wed,  6 May 2015 16:59:36 +0200, Gwenhael Goavec-Merou wrote:
> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> Fix:
> http://autobuild.buildroot.net/results/206/2062208c171207428c9121215971e00c52bf306a/
> 
> According to configure-ng.py, PyQt_NoOpenGLES must be added to qtdetail when
> QT_OPENGL_ES is set.
> 
> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/python-pyqt/python-pyqt.mk | 4 ++++
>  1 file changed, 4 insertions(+)

Applied after adding a comment explaining the weird things happening
with the double negation. Thanks for the investigation and fix!

Thomas
diff mbox

Patch

diff --git a/package/python-pyqt/python-pyqt.mk b/package/python-pyqt/python-pyqt.mk
index 2445567..f10d508 100644
--- a/package/python-pyqt/python-pyqt.mk
+++ b/package/python-pyqt/python-pyqt.mk
@@ -40,6 +40,10 @@  ifeq ($(BR2_PACKAGE_QT_OPENSSL),)
 PYTHON_PYQT_QTDETAIL_DISABLE_FEATURES += PyQt_OpenSSL
 endif
 
+ifeq ($(BR2_PACKAGE_QT_OPENGL_ES),y)
+PYTHON_PYQT_QTDETAIL_DISABLE_FEATURES += PyQt_NoOpenGLES
+endif
+
 # PyQt_qreal_double must be disabled on a number of architectures that
 # use float for qreal.
 ifeq ($(BR2_PACKAGE_PYTHON_PYQT_ARCH_USES_QREAL_FLOAT),y)