diff mbox

[2/2] QEMU: Enable package for MIPS targets

Message ID 1429782657-6283-2-git-send-email-markos.chandras@imgtec.com
State Accepted
Headers show

Commit Message

Markos Chandras April 23, 2015, 9:50 a.m. UTC
Allow QEMU to be installed on MIPS targets. Also introduce a new
symbol (BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET) to hold the
architectures than can build and use QEMU on the target.

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
---
 package/qemu/Config.in | 9 +++++++--
 package/qemu/qemu.mk   | 4 ++--
 2 files changed, 9 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni April 25, 2015, 8:18 a.m. UTC | #1
Dear Markos Chandras,

On Thu, 23 Apr 2015 10:50:57 +0100, Markos Chandras wrote:

> diff --git a/package/qemu/Config.in b/package/qemu/Config.in
> index fff786d3f11f..f537ce67181c 100644
> --- a/package/qemu/Config.in
> +++ b/package/qemu/Config.in
> @@ -1,11 +1,16 @@
> +config BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
> +	bool
> +	# Only tested in these architectures
> +	default y if BR2_i386 || BR2_mips || BR2_mipsel || BR2_x86_64

So not on mips64/mips64el...

> -#       mips64          ?
> -#       mips64el        ?
> +#       mips64          mips64
> +#       mips64el        mips64el

but you update the mips64* information, which would probably indicate
that it works, no?

Anyway, I've applied the patch as is, feel free to send a follow-up
patch adding mips64* as well if that works.

Thanks,

Thomas
Markos Chandras April 27, 2015, 7:50 a.m. UTC | #2
On 04/25/2015 09:18 AM, Thomas Petazzoni wrote:
> Dear Markos Chandras,
> 
> On Thu, 23 Apr 2015 10:50:57 +0100, Markos Chandras wrote:
> 
>> diff --git a/package/qemu/Config.in b/package/qemu/Config.in
>> index fff786d3f11f..f537ce67181c 100644
>> --- a/package/qemu/Config.in
>> +++ b/package/qemu/Config.in
>> @@ -1,11 +1,16 @@
>> +config BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
>> +	bool
>> +	# Only tested in these architectures
>> +	default y if BR2_i386 || BR2_mips || BR2_mipsel || BR2_x86_64
> 
> So not on mips64/mips64el...

No because it does not seem to (cross-)build for mips64.

> 
>> -#       mips64          ?
>> -#       mips64el        ?
>> +#       mips64          mips64
>> +#       mips64el        mips64el
> 
> but you update the mips64* information, which would probably indicate
> that it works, no?

I was not sure what that list is for. I just added the missing targets
there. You can still get a mips64(el) targets on a mips host though.

> 
> Anyway, I've applied the patch as is, feel free to send a follow-up
> patch adding mips64* as well if that works.

Yes we will eventually fix the build problems upstream. Thanks!
diff mbox

Patch

diff --git a/package/qemu/Config.in b/package/qemu/Config.in
index fff786d3f11f..f537ce67181c 100644
--- a/package/qemu/Config.in
+++ b/package/qemu/Config.in
@@ -1,11 +1,16 @@ 
+config BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
+	bool
+	# Only tested in these architectures
+	default y if BR2_i386 || BR2_mips || BR2_mipsel || BR2_x86_64
+
 comment "QEMU requires a toolchain with wchar, threads"
-	depends on BR2_i386 || BR2_x86_64
+	depends on BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
 	depends on BR2_USE_MMU
 	depends on !(BR2_TOOLCHAIN_HAS_THREADS && BR2_USE_WCHAR)
 
 config BR2_PACKAGE_QEMU
 	bool "QEMU"
-	depends on BR2_i386 || BR2_x86_64
+	depends on BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_USE_WCHAR # gettext
 	depends on BR2_USE_MMU # fork()
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index b73127b24748..decfc259d2e3 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -32,8 +32,8 @@  HOST_QEMU_DEPENDENCIES = host-pkgconf host-python host-zlib host-libglib2 host-p
 #       microblaze      microblaze
 #       mips            mips
 #       mipsel          mipsel
-#       mips64          ?
-#       mips64el        ?
+#       mips64          mips64
+#       mips64el        mips64el
 #       powerpc         ppc
 #       sh2a            not supported
 #       sh4             sh4