diff mbox

[2/3] python-pyqt: fix install

Message ID 1429543759-32207-2-git-send-email-gwenj@trabucayre.com
State Accepted
Commit 348be778ff683491e99d00a5c235110fbec05584
Headers show

Commit Message

Gwenhael Goavec-Merou April 20, 2015, 3:29 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

PyQt4 provides two version for some py files: one for python2.x and one for
python3.x. This two versions are installed in TARGET_DIR.
After installing files, python is used to generate all .pyc files, but fails
like :
class ProxyBase(metaclass=ProxyMetaclass):
                             ^
							 SyntaxError: invalid syntax

This patch supdress directory for not targeted python version.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/python-pyqt/python-pyqt.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni April 20, 2015, 3:37 p.m. UTC | #1
Dear Gwenhael Goavec-Merou,

On Mon, 20 Apr 2015 17:29:18 +0200, Gwenhael Goavec-Merou wrote:
> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> PyQt4 provides two version for some py files: one for python2.x and one for
> python3.x. This two versions are installed in TARGET_DIR.
> After installing files, python is used to generate all .pyc files, but fails
> like :
> class ProxyBase(metaclass=ProxyMetaclass):
>                              ^
> 							 SyntaxError: invalid syntax

I did not encounter this issue when testing. With which configuration
do you get this problem?

Thanks,

Thomas
Gwenhael Goavec-Merou April 20, 2015, 3:45 p.m. UTC | #2
Dear Thomas Petazzoni,

On Mon, 20 Apr 2015 17:37:52 +0200
Thomas Petazzoni <thomas.petazzoni@free-electrons.com> wrote:

> Dear Gwenhael Goavec-Merou,
> 
> On Mon, 20 Apr 2015 17:29:18 +0200, Gwenhael Goavec-Merou wrote:
> > From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> > 
> > PyQt4 provides two version for some py files: one for python2.x and one for
> > python3.x. This two versions are installed in TARGET_DIR.
> > After installing files, python is used to generate all .pyc files, but fails
> > like :
> > class ProxyBase(metaclass=ProxyMetaclass):
> >                              ^
> > 							 SyntaxError: invalid syntax
> 
> I did not encounter this issue when testing. With which configuration
> do you get this problem?
> 
I have used the defconfig provided by :
http://autobuild.buildroot.net/results/e2a/e2ab7e2e61aaa5758a3a572ae25a047e802fdcc0/

> Thanks,
> 
> Thomas

Regards,
Gwen
Arnout Vandecappelle April 20, 2015, 9:02 p.m. UTC | #3
On 20/04/15 17:45, gwenhael.goavec wrote:
> Dear Thomas Petazzoni,
> 
> On Mon, 20 Apr 2015 17:37:52 +0200
> Thomas Petazzoni <thomas.petazzoni@free-electrons.com> wrote:
> 
>> Dear Gwenhael Goavec-Merou,
>>
>> On Mon, 20 Apr 2015 17:29:18 +0200, Gwenhael Goavec-Merou wrote:
>>> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
>>>
>>> PyQt4 provides two version for some py files: one for python2.x and one for
>>> python3.x. This two versions are installed in TARGET_DIR.
>>> After installing files, python is used to generate all .pyc files, but fails
>>> like :
>>> class ProxyBase(metaclass=ProxyMetaclass):
>>>                              ^
>>> 							 SyntaxError: invalid syntax
>>
>> I did not encounter this issue when testing. With which configuration
>> do you get this problem?
>>
> I have used the defconfig provided by :
> http://autobuild.buildroot.net/results/e2a/e2ab7e2e61aaa5758a3a572ae25a047e802fdcc0/

 When you submit a patch that fixes an autobuild failure, you should mention
that in the commit log, like:

Fixes:
http://autobuild.buildroot.net/results/e2a/e2ab7e2e61aaa5758a3a572ae25a047e802fdcc0/



 Regards,
 Arnout


> 
>> Thanks,
>>
>> Thomas
> 
> Regards,
> Gwen
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
> 
>
diff mbox

Patch

diff --git a/package/python-pyqt/python-pyqt.mk b/package/python-pyqt/python-pyqt.mk
index 808837e..e7ab3a6 100644
--- a/package/python-pyqt/python-pyqt.mk
+++ b/package/python-pyqt/python-pyqt.mk
@@ -14,8 +14,10 @@  PYTHON_PYQT_DEPENDENCIES = python-sip host-python-sip qt
 
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 PYTHON_PYQT_PYTHON_DIR = python$(PYTHON_VERSION_MAJOR)
+PYTHON_PYQT_RM_PORT_BASE = port_v3
 else ifeq ($(BR2_PACKAGE_PYTHON3),y)
 PYTHON_PYQT_PYTHON_DIR = python$(PYTHON3_VERSION_MAJOR)
+PYTHON_PYQT_RM_PORT_BASE = port_v2
 endif
 
 ifeq ($(BR2_PACKAGE_QT_EMBEDDED),y)
@@ -97,6 +99,7 @@  endef
 define PYTHON_PYQT_INSTALL_TARGET_CMDS
 	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) install
 	touch $(TARGET_DIR)/usr/lib/$(PYTHON_PYQT_PYTHON_DIR)/site-packages/PyQt4/__init__.py
+	$(RM) -rf $(TARGET_DIR)/usr/lib/$(PYTHON_PYQT_PYTHON_DIR)/site-packages/PyQt4/uic/$(PYTHON_PYQT_RM_PORT_BASE)
 	PYTHONPATH="$(PYTHON_PATH)" \
 		$(HOST_DIR)/usr/bin/python -c "import compileall; \
 		compileall.compile_dir('$(TARGET_DIR)/usr/lib/$(PYTHON_PYQT_PYTHON_DIR)/site-packages/PyQt4')"