diff mbox

target-finalize: fix calling ldconfig

Message ID 1429287033-21225-1-git-send-email-yann.morin.1998@free.fr
State Accepted
Headers show

Commit Message

Yann E. MORIN April 17, 2015, 4:10 p.m. UTC
On some systems (e.g. Fedora 20), the build breaks when parsing include
directives in our /etc/ld.so.conf, with error messages as thus:

    /sbin/ldconfig: need absolute file name for configuration file
    when using -r

So, enforce the path to the ld.so.conf file to point to our own, in the
target/ directory.

Reported-by: Al West <al.west@v-nova.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 Makefile | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 18, 2015, 1:57 p.m. UTC | #1
Dear Yann E. MORIN,

On Fri, 17 Apr 2015 18:10:33 +0200, Yann E. MORIN wrote:
> On some systems (e.g. Fedora 20), the build breaks when parsing include
> directives in our /etc/ld.so.conf, with error messages as thus:
> 
>     /sbin/ldconfig: need absolute file name for configuration file
>     when using -r
> 
> So, enforce the path to the ld.so.conf file to point to our own, in the
> target/ directory.
> 
> Reported-by: Al West <al.west@v-nova.com>
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> ---
>  Makefile | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)

Applied, thanks. But I must admit I would prefer a real overhaul of our
ldconfig handling (that takes into account glibc vs. uclibc vs. musl,
etc.).

Thanks,

Thomas
Yann E. MORIN April 18, 2015, 3:28 p.m. UTC | #2
Thomas, All,

On 2015-04-18 15:57 +0200, Thomas Petazzoni spake thusly:
> On Fri, 17 Apr 2015 18:10:33 +0200, Yann E. MORIN wrote:
> > On some systems (e.g. Fedora 20), the build breaks when parsing include
> > directives in our /etc/ld.so.conf, with error messages as thus:
> > 
> >     /sbin/ldconfig: need absolute file name for configuration file
> >     when using -r
> > 
> > So, enforce the path to the ld.so.conf file to point to our own, in the
> > target/ directory.
> > 
> > Reported-by: Al West <al.west@v-nova.com>
> > Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> > ---
> >  Makefile | 6 ++++--
> >  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> Applied, thanks. But I must admit I would prefer a real overhaul of our
> ldconfig handling (that takes into account glibc vs. uclibc vs. musl,
> etc.).

Yes, I do agree. However, that will take quite longer, and we needed a
quick fix

I'll see if I can have tim eto look into that in the coming days, but to
be honest, I can't promise anything...

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 70d6b4a..2e71c80 100644
--- a/Makefile
+++ b/Makefile
@@ -583,9 +583,11 @@  endif
 	mkdir -p $(TARGET_DIR)/var/cache/ldconfig
 	if [ -x "$(TARGET_CROSS)ldconfig" ]; \
 	then \
-		$(TARGET_CROSS)ldconfig -r $(TARGET_DIR); \
+		$(TARGET_CROSS)ldconfig -r $(TARGET_DIR) \
+					-f $(TARGET_DIR)/etc/ld.so.conf; \
 	else \
-		/sbin/ldconfig -r $(TARGET_DIR); \
+		/sbin/ldconfig -r $(TARGET_DIR) \
+			       -f $(TARGET_DIR)/etc/ld.so.conf; \
 	fi
 	( \
 		echo "NAME=Buildroot"; \