diff mbox

[1/2] package/exim: Adjust libnsl detection to include musl

Message ID 1428848507-2117-1-git-send-email-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls April 12, 2015, 2:21 p.m. UTC
Only (e)glibc provides libnsl, uclibc provides only a stub

Fixes compilation using this defconfig

    BR2_arm=y
    BR2_cortex_a7=y
    BR2_STATIC_LIBS=y
    BR2_TOOLCHAIN_EXTERNAL=y
    BR2_PACKAGE_OPENSSL=y
    BR2_PACKAGE_EXIM=y

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/exim/exim.mk |    5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 12, 2015, 4:54 p.m. UTC | #1
Dear Bernd Kuhls,

On Sun, 12 Apr 2015 16:21:46 +0200, Bernd Kuhls wrote:
> Only (e)glibc provides libnsl, uclibc provides only a stub

True, but uClibc provides the functionality, no? Or is the stub
actually not working at runtime? Could you be a bit more specific here?

Thanks,

Thomas
Bernd Kuhls June 30, 2015, 5:45 p.m. UTC | #2
Thomas Petazzoni <thomas.petazzoni-wi1+55ScJUtKEb57/3fJTNBPR1lH4CV8
@public.gmane.org> wrote in news:20150412185443.08512d17@free-electrons.com:

> Dear Bernd Kuhls,
> 
> On Sun, 12 Apr 2015 16:21:46 +0200, Bernd Kuhls wrote:
>> Only (e)glibc provides libnsl, uclibc provides only a stub
> 
> True, but uClibc provides the functionality, no? Or is the stub
> actually not working at runtime? Could you be a bit more specific here?

Hi,

http://git.uclibc.org/uClibc/tree/libnsl/nsl.c

Uclibc provides only stub code, libnsl has no functionality there ;)

Regards, Bernd
Thomas Petazzoni June 30, 2015, 9:08 p.m. UTC | #3
Dear Bernd Kuhls,

On Sun, 12 Apr 2015 16:21:46 +0200, Bernd Kuhls wrote:
> Only (e)glibc provides libnsl, uclibc provides only a stub
> 
> Fixes compilation using this defconfig
> 
>     BR2_arm=y
>     BR2_cortex_a7=y
>     BR2_STATIC_LIBS=y
>     BR2_TOOLCHAIN_EXTERNAL=y
>     BR2_PACKAGE_OPENSSL=y
>     BR2_PACKAGE_EXIM=y
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/exim/exim.mk |    5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Applied after rebasing on master, thanks!

Thomas
diff mbox

Patch

diff --git a/package/exim/exim.mk b/package/exim/exim.mk
index 0a70c42..fcf2be5 100644
--- a/package/exim/exim.mk
+++ b/package/exim/exim.mk
@@ -81,8 +81,9 @@  define EXIM_USE_DEFAULT_CONFIG_FILE_OPENSSL
 endef
 endif
 
-# this specific toolchain lacks libnsl
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12),y)
+# only (e)glibc provides libnsl, remove -lnsl for all other toolchains
+# http://bugs.exim.org/show_bug.cgi?id=1564
+ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),)
 define EXIM_REMOVE_LIBNSL_FROM_MAKEFILE
 	$(SED) 's/-lnsl//g' $(@D)/OS/Makefile-Linux
 endef