diff mbox

[1/1] Add package sl

Message ID 1427879325-12015-1-git-send-email-j.rosenboom@x-ion.de
State Accepted
Headers show

Commit Message

Jens Rosenboom April 1, 2015, 9:08 a.m. UTC
SL (Steam Locomotive) runs across your terminal when you type "sl" as
you meant to type "ls". It's just a joke command, and not useful at all.

Might want to depend on BR2_PACKAGE_NCURSES_WCHAR even in order to get
terminfo for xterm-256color, but I'm not sure whether that should be
just optional.

Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de>
---
 package/Config.in    |  1 +
 package/sl/Config.in |  9 +++++++++
 package/sl/sl.mk     | 20 ++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 100644 package/sl/Config.in
 create mode 100644 package/sl/sl.mk

Comments

Angelo Compagnucci April 1, 2015, 9:26 a.m. UTC | #1
Dear Jens Rosenboom,

2015-04-01 11:08 GMT+02:00 Jens Rosenboom <j.rosenboom@x-ion.de>:
> SL (Steam Locomotive) runs across your terminal when you type "sl" as
> you meant to type "ls". It's just a joke command, and not useful at all.
>
> Might want to depend on BR2_PACKAGE_NCURSES_WCHAR even in order to get
> terminfo for xterm-256color, but I'm not sure whether that should be
> just optional.
>
> Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de>
> ---
>  package/Config.in    |  1 +
>  package/sl/Config.in |  9 +++++++++
>  package/sl/sl.mk     | 20 ++++++++++++++++++++
>  3 files changed, 30 insertions(+)
>  create mode 100644 package/sl/Config.in
>  create mode 100644 package/sl/sl.mk
>
> diff --git a/package/Config.in b/package/Config.in
> index d6a5ad3..08475fe 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -183,6 +183,7 @@ menu "Games"
>         source "package/opentyrian-data/Config.in"
>         source "package/prboom/Config.in"
>         source "package/rubix/Config.in"
> +       source "package/sl/Config.in"
>  endmenu
>
>  menu "Graphic libraries and applications (graphic/text)"
> diff --git a/package/sl/Config.in b/package/sl/Config.in
> new file mode 100644
> index 0000000..e387ea5
> --- /dev/null
> +++ b/package/sl/Config.in
> @@ -0,0 +1,9 @@
> +config BR2_PACKAGE_SL
> +       bool "sl"
> +        # Note(JR): Still need to check proper depends
> +       depends on BR2_PACKAGE_NCURSES
> +       help
> +         SL (Steam Locomotive) runs across your terminal when you type "sl"
> +         as you meant to type "ls". It's just a joke command, and not useful at all.
> +
> +         https://github.com/mtoyoda/sl
> diff --git a/package/sl/sl.mk b/package/sl/sl.mk
> new file mode 100644
> index 0000000..9ad98cb
> --- /dev/null
> +++ b/package/sl/sl.mk
> @@ -0,0 +1,20 @@
> +################################################################################
> +#
> +# sl
> +#
> +################################################################################
> +
> +SL_VERSION = 5.02
> +SL_SITE = $(call github,mtoyoda,sl,$(SL_VERSION))
> +SL_LICENSE = Unclear
> +SL_LICENSE_FILES = LICENSE
> +
> +define SL_BUILD_CMDS
> +       $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)"
> +endef
> +
> +define SL_INSTALL_TARGET_CMDS
> +       $(INSTALL) -D $(@D)/sl $(TARGET_DIR)/usr/bin/sl
> +endef
> +
> +$(eval $(generic-package))
> --

I want it now! Tomorrow will be too late!

> 1.9.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Arnout Vandecappelle April 1, 2015, 9:12 p.m. UTC | #2
Hi Angelo,

On 01/04/15 11:26, Angelo Compagnucci wrote:
> Dear Jens Rosenboom,
> 
> 2015-04-01 11:08 GMT+02:00 Jens Rosenboom <j.rosenboom@x-ion.de>:
>> SL (Steam Locomotive) runs across your terminal when you type "sl" as
>> you meant to type "ls". It's just a joke command, and not useful at all.
>>
>> Might want to depend on BR2_PACKAGE_NCURSES_WCHAR even in order to get
>> terminfo for xterm-256color, but I'm not sure whether that should be
>> just optional.
>>
>> Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de>
[snip]
>> --
> 
> I want it now! Tomorrow will be too late!

 Well, then review the patch and either give some comments and/or add your
Reviewed-by, Tested-by or Acked-by tags.

 Regards,
 Arnout
Thomas Petazzoni April 3, 2015, 2:31 p.m. UTC | #3
Dear Jens Rosenboom,

On Wed,  1 Apr 2015 11:08:45 +0200, Jens Rosenboom wrote:
> SL (Steam Locomotive) runs across your terminal when you type "sl" as
> you meant to type "ls". It's just a joke command, and not useful at all.
> 
> Might want to depend on BR2_PACKAGE_NCURSES_WCHAR even in order to get
> terminfo for xterm-256color, but I'm not sure whether that should be
> just optional.
> 
> Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de>
> ---
>  package/Config.in    |  1 +
>  package/sl/Config.in |  9 +++++++++
>  package/sl/sl.mk     | 20 ++++++++++++++++++++
>  3 files changed, 30 insertions(+)
>  create mode 100644 package/sl/Config.in
>  create mode 100644 package/sl/sl.mk

Thanks, applied, after doing a number of changes:

    [Thomas:
     - Change "depends on BR2_PACKAGE_NCURSES" to "select
       BR2_PACKAGE_NCURSES".
     - Rewrap Config.in help text.
     - Remove comment in help text about the need to check dependencies,
       there's nothing to be done really.
     - Change the license from "Unclear" to "Custom".
     - Use $(TARGET_CONFIGURE_OPTS instead of passing CC and CFLAGS
       explicitly.
     - Pass '-m 0755' when doing the $(INSTALL)
     - Add ncurses to SL_DEPENDENCIES.]

Thomas
Angelo Compagnucci April 3, 2015, 4:42 p.m. UTC | #4
Dear Arnout Vandecappelle,

2015-04-01 23:12 GMT+02:00 Arnout Vandecappelle <arnout@mind.be>:
>  Hi Angelo,
>
> On 01/04/15 11:26, Angelo Compagnucci wrote:
>> Dear Jens Rosenboom,
>>
>> 2015-04-01 11:08 GMT+02:00 Jens Rosenboom <j.rosenboom@x-ion.de>:
>>> SL (Steam Locomotive) runs across your terminal when you type "sl" as
>>> you meant to type "ls". It's just a joke command, and not useful at all.
>>>
>>> Might want to depend on BR2_PACKAGE_NCURSES_WCHAR even in order to get
>>> terminfo for xterm-256color, but I'm not sure whether that should be
>>> just optional.
>>>
>>> Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de>
> [snip]
>>> --
>>
>> I want it now! Tomorrow will be too late!
>
>  Well, then review the patch and either give some comments and/or add your
> Reviewed-by, Tested-by or Acked-by tags.

Honestly I thought it was an April fools! Why add an unuseful command
to buildroot just the first of April after all! Lol!

Sincerely, Angelo

>
>  Regards,
>  Arnout
>
> --
> Arnout Vandecappelle                          arnout at mind be
> Senior Embedded Software Architect            +32-16-286500
> Essensium/Mind                                http://www.mind.be
> G.Geenslaan 9, 3001 Leuven, Belgium           BE 872 984 063 RPR Leuven
> LinkedIn profile: http://www.linkedin.com/in/arnoutvandecappelle
> GPG fingerprint:  7CB5 E4CC 6C2E EFD4 6E3D A754 F963 ECAB 2450 2F1F
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index d6a5ad3..08475fe 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -183,6 +183,7 @@  menu "Games"
 	source "package/opentyrian-data/Config.in"
 	source "package/prboom/Config.in"
 	source "package/rubix/Config.in"
+	source "package/sl/Config.in"
 endmenu
 
 menu "Graphic libraries and applications (graphic/text)"
diff --git a/package/sl/Config.in b/package/sl/Config.in
new file mode 100644
index 0000000..e387ea5
--- /dev/null
+++ b/package/sl/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_SL
+	bool "sl"
+        # Note(JR): Still need to check proper depends
+	depends on BR2_PACKAGE_NCURSES
+	help
+	  SL (Steam Locomotive) runs across your terminal when you type "sl" 
+	  as you meant to type "ls". It's just a joke command, and not useful at all.
+
+	  https://github.com/mtoyoda/sl
diff --git a/package/sl/sl.mk b/package/sl/sl.mk
new file mode 100644
index 0000000..9ad98cb
--- /dev/null
+++ b/package/sl/sl.mk
@@ -0,0 +1,20 @@ 
+################################################################################
+#
+# sl
+#
+################################################################################
+
+SL_VERSION = 5.02
+SL_SITE = $(call github,mtoyoda,sl,$(SL_VERSION))
+SL_LICENSE = Unclear
+SL_LICENSE_FILES = LICENSE
+
+define SL_BUILD_CMDS
+	$(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)"
+endef
+
+define SL_INSTALL_TARGET_CMDS
+	$(INSTALL) -D $(@D)/sl $(TARGET_DIR)/usr/bin/sl
+endef
+
+$(eval $(generic-package))