diff mbox

busybox: remove actions that depend on removed netkit* packages

Message ID 1426061471-8321-1-git-send-email-abrodkin@synopsys.com
State Accepted
Commit f0fb30bc567c91169c5a66f055db731a3c00c7ab
Headers show

Commit Message

Alexey Brodkin March 11, 2015, 8:11 a.m. UTC
Both "netkitbase" and "netkittelnet"  packages were removed by this
commit:
http://git.buildroot.net/buildroot/commit/?id=560fe85bf7fb81956e80848c8bb28d7a6d00a2a2

Now we may safely remove reminders in busybox.mk that depend on
mentioned packages that are no longer in Buildroot.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
---
 package/busybox/busybox.mk | 16 ----------------
 1 file changed, 16 deletions(-)

Comments

Peter Korsgaard March 11, 2015, 4:11 p.m. UTC | #1
>>>>> "Alexey" == Alexey Brodkin <Alexey.Brodkin@synopsys.com> writes:

 > Both "netkitbase" and "netkittelnet"  packages were removed by this
 > commit:
 > http://git.buildroot.net/buildroot/commit/?id=560fe85bf7fb81956e80848c8bb28d7a6d00a2a2

 > Now we may safely remove reminders in busybox.mk that depend on
 > mentioned packages that are no longer in Buildroot.

 > Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
 > Cc: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 61f6a16..a3ac7e7 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -124,20 +124,6 @@  define BUSYBOX_PREFER_STATIC
 endef
 endif
 
-# Disable usage of inetd if netkit-base package is selected
-ifeq ($(BR2_PACKAGE_NETKITBASE),y)
-define BUSYBOX_NETKITBASE
-	$(call KCONFIG_DISABLE_OPT,CONFIG_INETD,$(BUSYBOX_BUILD_CONFIG))
-endef
-endif
-
-# Disable usage of telnetd if netkit-telnetd package is selected
-ifeq ($(BR2_PACKAGE_NETKITTELNET),y)
-define BUSYBOX_NETKITTELNET
-	$(call KCONFIG_DISABLE_OPT,CONFIG_TELNETD,$(BUSYBOX_BUILD_CONFIG))
-endef
-endif
-
 # Disable shadow passwords support if unsupported by the C library
 ifeq ($(BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS),)
 define BUSYBOX_INTERNAL_SHADOW_PASSWORDS
@@ -193,8 +179,6 @@  define BUSYBOX_KCONFIG_FIXUP_CMDS
 	$(BUSYBOX_PREFER_STATIC)
 	$(BUSYBOX_SET_MDEV)
 	$(BUSYBOX_SET_CRYPT_SHA)
-	$(BUSYBOX_NETKITBASE)
-	$(BUSYBOX_NETKITTELNET)
 	$(BUSYBOX_INTERNAL_SHADOW_PASSWORDS)
 	$(BUSYBOX_SET_INIT)
 	$(BUSYBOX_SET_WATCHDOG)