diff mbox

libvips: requires C++ support

Message ID 1423143748-63093-1-git-send-email-Vincent.Riera@imgtec.com
State Superseded
Headers show

Commit Message

Vicente Olivert Riera Feb. 5, 2015, 1:42 p.m. UTC
libvips requires C++ support, otherwise it will fail with an error
message like this one:

error: ../libvips/.libs/libvips.so: No such file or directory

Fixes:

  http://autobuild.buildroot.net/results/cdc7cf5d3501f80c74b70aa09f93b2ad4e2f8602/
  http://autobuild.buildroot.net/results/39173dbcbbd0a243900ea583cec024b51f8b803a/
  http://autobuild.buildroot.net/results/6794705195bcdb636a8e6582ef5a1e153d4d66b3/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/libvips/Config.in |    6 ++++--
 1 files changed, 4 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Feb. 5, 2015, 1:46 p.m. UTC | #1
Dear Vicente Olivert Riera,

On Thu, 5 Feb 2015 13:42:28 +0000, Vicente Olivert Riera wrote:
> libvips requires C++ support, otherwise it will fail with an error
> message like this one:
> 
> error: ../libvips/.libs/libvips.so: No such file or directory
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/cdc7cf5d3501f80c74b70aa09f93b2ad4e2f8602/
>   http://autobuild.buildroot.net/results/39173dbcbbd0a243900ea583cec024b51f8b803a/
>   http://autobuild.buildroot.net/results/6794705195bcdb636a8e6582ef5a1e153d4d66b3/
> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>

This doesn't make sense with the contents of libvips.mk:

ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
LIBVIPS_CONF_OPTS += --enable-cxx
else
LIBVIPS_CONF_OPTS += --disable-cxx
endif

So either we can disable C++, and your patch is not correct. Or
disabling C++ doesn't work, and your patch should be amended to remove
the BR2_INSTALL_LIBSTDCPP condition.

Best regards,

Thomas
Vicente Olivert Riera Feb. 5, 2015, 1:49 p.m. UTC | #2
Hi Thomas,

uhm..., the think if you use "--disable-cxx", the .so library is not
built and then it fails because is not found...

Maybe this is something we should report upstream?

Regards,
--
Vincent

On 05/02/15 14:46, Thomas Petazzoni wrote:
> Dear Vicente Olivert Riera,
> 
> On Thu, 5 Feb 2015 13:42:28 +0000, Vicente Olivert Riera wrote:
>> libvips requires C++ support, otherwise it will fail with an error
>> message like this one:
>>
>> error: ../libvips/.libs/libvips.so: No such file or directory
>>
>> Fixes:
>>
>>   http://autobuild.buildroot.net/results/cdc7cf5d3501f80c74b70aa09f93b2ad4e2f8602/
>>   http://autobuild.buildroot.net/results/39173dbcbbd0a243900ea583cec024b51f8b803a/
>>   http://autobuild.buildroot.net/results/6794705195bcdb636a8e6582ef5a1e153d4d66b3/
>>
>> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> 
> This doesn't make sense with the contents of libvips.mk:
> 
> ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
> LIBVIPS_CONF_OPTS += --enable-cxx
> else
> LIBVIPS_CONF_OPTS += --disable-cxx
> endif
> 
> So either we can disable C++, and your patch is not correct. Or
> disabling C++ doesn't work, and your patch should be amended to remove
> the BR2_INSTALL_LIBSTDCPP condition.
> 
> Best regards,
> 
> Thomas
>
Thomas Petazzoni Feb. 5, 2015, 1:51 p.m. UTC | #3
Dear Vicente Olivert Riera,

On Thu, 5 Feb 2015 14:49:39 +0100, Vicente Olivert Riera wrote:

> uhm..., the think if you use "--disable-cxx", the .so library is not
> built and then it fails because is not found...
> 
> Maybe this is something we should report upstream?

It seems like we should. And in the mean time, your patch looks OK to
me, as long as you amend it to force --enable-cxx in all cases.

I personally don't really care to support libvips without C++, so if
it's broken upstream, let's report it and not support it until they fix
it.

Thanks!

Thomas
Vicente Olivert Riera Feb. 5, 2015, 1:52 p.m. UTC | #4
Ok, I will send an v2 to always use C++ for libvips and also report the
issue upstream.

Thanks.
--
Vincent

On 05/02/15 14:51, Thomas Petazzoni wrote:
> Dear Vicente Olivert Riera,
> 
> On Thu, 5 Feb 2015 14:49:39 +0100, Vicente Olivert Riera wrote:
> 
>> uhm..., the think if you use "--disable-cxx", the .so library is not
>> built and then it fails because is not found...
>>
>> Maybe this is something we should report upstream?
> 
> It seems like we should. And in the mean time, your patch looks OK to
> me, as long as you amend it to force --enable-cxx in all cases.
> 
> I personally don't really care to support libvips without C++, so if
> it's broken upstream, let's report it and not support it until they fix
> it.
> 
> Thanks!
> 
> Thomas
>
diff mbox

Patch

diff --git a/package/libvips/Config.in b/package/libvips/Config.in
index 1a0d35c..8395ffb 100644
--- a/package/libvips/Config.in
+++ b/package/libvips/Config.in
@@ -3,6 +3,7 @@  config BR2_PACKAGE_LIBVIPS
 	depends on BR2_USE_WCHAR # gettext, libglib2
 	depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
 	depends on BR2_USE_MMU # fork()
+	depends on BR2_INSTALL_LIBSTDCPP
 	select BR2_PACKAGE_LIBGLIB2
 	select BR2_PACKAGE_LIBXML2
 	select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
@@ -13,6 +14,7 @@  config BR2_PACKAGE_LIBVIPS
 
 	  http://www.vips.ecs.soton.ac.uk/
 
-comment "libvips needs a toolchain w/ wchar, threads"
+comment "libvips needs a toolchain w/ wchar, threads, C++"
         depends on BR2_USE_MMU
-        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+		!BR2_INSTALL_LIBSTDCPP