diff mbox

[1/1] pkg-cmake: fix host-cmake-package type

Message ID 1421945596-53762-1-git-send-email-ryan.barnett@rockwellcollins.com
State Superseded
Headers show

Commit Message

Ryan Barnett Jan. 22, 2015, 4:53 p.m. UTC
When trying to compile a host-cmake-package type such as host-cdrkit,
an error happens in regards to HOSTCC and HOSTCXX not being found.

  /bin/sh: HOSTCC: command not found
  /bin/sh: HOSTCXX: command not found

This due to the fact that the environment is incorrectly configured by
having the following:

  -DCMAKE_C_COMPILER=""$(HOSTCC)"" -DCMAKE_CXX_COMPILER=""$(HOSTCXX)""

This is due to having too many dollar signs. The fix is to remove the
extra dollar sign.

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
---
 package/pkg-cmake.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Samuel Martin Jan. 22, 2015, 8:10 p.m. UTC | #1
On Thu, Jan 22, 2015 at 5:53 PM, Ryan Barnett
<ryan.barnett@rockwellcollins.com> wrote:
> When trying to compile a host-cmake-package type such as host-cdrkit,
> an error happens in regards to HOSTCC and HOSTCXX not being found.
>
>   /bin/sh: HOSTCC: command not found
>   /bin/sh: HOSTCXX: command not found
>
> This due to the fact that the environment is incorrectly configured by
> having the following:
>
>   -DCMAKE_C_COMPILER=""$(HOSTCC)"" -DCMAKE_CXX_COMPILER=""$(HOSTCXX)""
>
> This is due to having too many dollar signs. The fix is to remove the
> extra dollar sign.
>
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>

Acked-by: Samuel Martin <s.martin49@gmail.com>

Regards,
Yann E. MORIN Jan. 23, 2015, 3:50 p.m. UTC | #2
Ryan, All,

On 2015-01-22 10:53 -0600, Ryan Barnett spake thusly:
> When trying to compile a host-cmake-package type such as host-cdrkit,
> an error happens in regards to HOSTCC and HOSTCXX not being found.
> 
>   /bin/sh: HOSTCC: command not found
>   /bin/sh: HOSTCXX: command not found
> 
> This due to the fact that the environment is incorrectly configured by
> having the following:
> 
>   -DCMAKE_C_COMPILER=""$(HOSTCC)"" -DCMAKE_CXX_COMPILER=""$(HOSTCXX)""

As you may have noticed, the double-quaotes are doubled...

> This is due to having too many dollar signs. The fix is to remove the
> extra dollar sign.
> 
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
> ---
>  package/pkg-cmake.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
> index 1037513..eac244f 100644
> --- a/package/pkg-cmake.mk
> +++ b/package/pkg-cmake.mk
> @@ -27,8 +27,8 @@ CMAKE_HOST_CXX_COMPILER="$(HOST_DIR)/usr/bin/ccache"
>  CMAKE_HOST_C_COMPILER_ARG1="$(HOSTCC_NOCCACHE)"
>  CMAKE_HOST_CXX_COMPILER_ARG1="$(HOSTCXX_NOCCACHE)"
>  else
> -CMAKE_HOST_C_COMPILER="$$(HOSTCC)"
> -CMAKE_HOST_CXX_COMPILER="$$(HOSTCXX)"
> +CMAKE_HOST_C_COMPILER="$(HOSTCC)"
> +CMAKE_HOST_CXX_COMPILER="$(HOSTCXX)"

That's because of here; in Makefile syntax, double-quotes are not
interpreted by make, and are part of the value.

So, you should also drop the double-quotes here.

Regards,
Yann E. MORIN.

>  endif
>  
>  ################################################################################
> -- 
> 1.9.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Samuel Martin Jan. 23, 2015, 4:08 p.m. UTC | #3
Yann, Ryan, all,

On Fri, Jan 23, 2015 at 4:50 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> Ryan, All,
>
> On 2015-01-22 10:53 -0600, Ryan Barnett spake thusly:
>> When trying to compile a host-cmake-package type such as host-cdrkit,
>> an error happens in regards to HOSTCC and HOSTCXX not being found.
>>
>>   /bin/sh: HOSTCC: command not found
>>   /bin/sh: HOSTCXX: command not found
>>
>> This due to the fact that the environment is incorrectly configured by
>> having the following:
>>
>>   -DCMAKE_C_COMPILER=""$(HOSTCC)"" -DCMAKE_CXX_COMPILER=""$(HOSTCXX)""
>
> As you may have noticed, the double-quaotes are doubled...
>
>> This is due to having too many dollar signs. The fix is to remove the
>> extra dollar sign.
>>
>> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
>> ---
>>  package/pkg-cmake.mk | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
>> index 1037513..eac244f 100644
>> --- a/package/pkg-cmake.mk
>> +++ b/package/pkg-cmake.mk
>> @@ -27,8 +27,8 @@ CMAKE_HOST_CXX_COMPILER="$(HOST_DIR)/usr/bin/ccache"
>>  CMAKE_HOST_C_COMPILER_ARG1="$(HOSTCC_NOCCACHE)"
>>  CMAKE_HOST_CXX_COMPILER_ARG1="$(HOSTCXX_NOCCACHE)"
>>  else
>> -CMAKE_HOST_C_COMPILER="$$(HOSTCC)"
>> -CMAKE_HOST_CXX_COMPILER="$$(HOSTCXX)"
>> +CMAKE_HOST_C_COMPILER="$(HOSTCC)"
>> +CMAKE_HOST_CXX_COMPILER="$(HOSTCXX)"
>
> That's because of here; in Makefile syntax, double-quotes are not
> interpreted by make, and are part of the value.
>
> So, you should also drop the double-quotes here.

While you are at cleaning this, adding 1 space before and after "="
will be good.

Regards,
diff mbox

Patch

diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 1037513..eac244f 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -27,8 +27,8 @@  CMAKE_HOST_CXX_COMPILER="$(HOST_DIR)/usr/bin/ccache"
 CMAKE_HOST_C_COMPILER_ARG1="$(HOSTCC_NOCCACHE)"
 CMAKE_HOST_CXX_COMPILER_ARG1="$(HOSTCXX_NOCCACHE)"
 else
-CMAKE_HOST_C_COMPILER="$$(HOSTCC)"
-CMAKE_HOST_CXX_COMPILER="$$(HOSTCXX)"
+CMAKE_HOST_C_COMPILER="$(HOSTCC)"
+CMAKE_HOST_CXX_COMPILER="$(HOSTCXX)"
 endif
 
 ################################################################################