diff mbox

[RFC,v2] python-lxml: add target package variant

Message ID 1421871981-3146-1-git-send-email-yegorslists@googlemail.com
State Superseded
Headers show

Commit Message

Yegor Yefremov Jan. 21, 2015, 8:26 p.m. UTC
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
Changes:
	v2: add working dependencies and provide path to XML libraries configs

 package/Config.in                  |  1 +
 package/python-lxml/Config.in      | 10 ++++++++++
 package/python-lxml/python-lxml.mk |  9 ++++++++-
 3 files changed, 19 insertions(+), 1 deletion(-)
 create mode 100644 package/python-lxml/Config.in

Comments

Yegor Yefremov Jan. 21, 2015, 8:30 p.m. UTC | #1
On Wed, Jan 21, 2015 at 9:26 PM, Yegor Yefremov
<yegorslists@googlemail.com> wrote:
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> ---
> Changes:
>         v2: add working dependencies and provide path to XML libraries configs

This patch has http://patchwork.ozlabs.org/patch/430681/ as dependency.

Yann, does it make sense to integrate this patch into your series?

Regards,
Yegor
Yann E. MORIN Jan. 21, 2015, 11:06 p.m. UTC | #2
Yegor, All,

On 2015-01-21 21:30 +0100, Yegor Yefremov spake thusly:
> On Wed, Jan 21, 2015 at 9:26 PM, Yegor Yefremov
> <yegorslists@googlemail.com> wrote:
> > Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> > ---
> > Changes:
> >         v2: add working dependencies and provide path to XML libraries configs
> 
> This patch has http://patchwork.ozlabs.org/patch/430681/ as dependency.
> 
> Yann, does it make sense to integrate this patch into your series?

Yes, I'll cary it in my series. Thanks! :-)
Yann E. MORIN Jan. 21, 2015, 11:09 p.m. UTC | #3
Yegor, All,

On 2015-01-21 21:26 +0100, Yegor Yefremov spake thusly:
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
[--SNIP--]
> diff --git a/package/python-lxml/python-lxml.mk b/package/python-lxml/python-lxml.mk
> index 758ce87..a7f072f 100644
> --- a/package/python-lxml/python-lxml.mk
> +++ b/package/python-lxml/python-lxml.mk
> @@ -20,6 +20,13 @@ PYTHON_LXML_LICENSE_FILES = \
>  # So, we use setuptools.
>  PYTHON_LXML_SETUP_TYPE = setuptools
>  
> -PYTHON_LXML_DEPENDENCIES = libxml2 libxslt
> +PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib

OK, I did not need zlib for the host variant, so we'll have to
differentiate the host dependencies and the target ones. I'll do
that.

> +# python-lxml needs these scripts in order to properly detect libxml2 and
> +# libxslt compiler and linker flags
> +PYTHON_LXML_BUILD_OPTS = \
> +	--with-xslt-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xslt-config \
> +	--with-xml2-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xml2-config

Well, there's much simpler: $(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot
is exactly what we call $(STAGING_DIR).

Beside, what you wrote would not work with anything else that an
arm-buildroot-linux-gnueabi. ;-)

I'll fix that too.

Thanks! :-)

Regards,
Yann E. MORIN.
Yegor Yefremov Jan. 21, 2015, 11:17 p.m. UTC | #4
On Thu, Jan 22, 2015 at 12:09 AM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> Yegor, All,
>
> On 2015-01-21 21:26 +0100, Yegor Yefremov spake thusly:
>> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> [--SNIP--]
>> diff --git a/package/python-lxml/python-lxml.mk b/package/python-lxml/python-lxml.mk
>> index 758ce87..a7f072f 100644
>> --- a/package/python-lxml/python-lxml.mk
>> +++ b/package/python-lxml/python-lxml.mk
>> @@ -20,6 +20,13 @@ PYTHON_LXML_LICENSE_FILES = \
>>  # So, we use setuptools.
>>  PYTHON_LXML_SETUP_TYPE = setuptools
>>
>> -PYTHON_LXML_DEPENDENCIES = libxml2 libxslt
>> +PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
>
> OK, I did not need zlib for the host variant, so we'll have to
> differentiate the host dependencies and the target ones. I'll do
> that.
>
>> +# python-lxml needs these scripts in order to properly detect libxml2 and
>> +# libxslt compiler and linker flags
>> +PYTHON_LXML_BUILD_OPTS = \
>> +     --with-xslt-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xslt-config \
>> +     --with-xml2-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xml2-config
>
> Well, there's much simpler: $(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot
> is exactly what we call $(STAGING_DIR).
>
> Beside, what you wrote would not work with anything else that an
> arm-buildroot-linux-gnueabi. ;-)

I was to high, I got it compiled at all :-)

> I'll fix that too.

Thanks.

Yegor
Yann E. MORIN Jan. 21, 2015, 11:21 p.m. UTC | #5
Yegor, All,

On 2015-01-22 00:17 +0100, Yegor Yefremov spake thusly:
> On Thu, Jan 22, 2015 at 12:09 AM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> > On 2015-01-21 21:26 +0100, Yegor Yefremov spake thusly:
> >> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> > [--SNIP--]
> >> diff --git a/package/python-lxml/python-lxml.mk b/package/python-lxml/python-lxml.mk
> >> index 758ce87..a7f072f 100644
> >> --- a/package/python-lxml/python-lxml.mk
> >> +++ b/package/python-lxml/python-lxml.mk
> >> @@ -20,6 +20,13 @@ PYTHON_LXML_LICENSE_FILES = \
> >>  # So, we use setuptools.
> >>  PYTHON_LXML_SETUP_TYPE = setuptools
> >>
> >> -PYTHON_LXML_DEPENDENCIES = libxml2 libxslt
> >> +PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
> >
> > OK, I did not need zlib for the host variant, so we'll have to
> > differentiate the host dependencies and the target ones. I'll do
> > that.
> >
> >> +# python-lxml needs these scripts in order to properly detect libxml2 and
> >> +# libxslt compiler and linker flags
> >> +PYTHON_LXML_BUILD_OPTS = \
> >> +     --with-xslt-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xslt-config \
> >> +     --with-xml2-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xml2-config
> >
> > Well, there's much simpler: $(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot
> > is exactly what we call $(STAGING_DIR).
> >
> > Beside, what you wrote would not work with anything else that an
> > arm-buildroot-linux-gnueabi. ;-)
> 
> I was to high, I got it compiled at all :-)

Hehe! I know the feeling! ;-)

Cheers!

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 266de13..366e393 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -519,6 +519,7 @@  menu "external python modules"
 	source "package/python-json-schema-validator/Config.in"
 	source "package/python-keyring/Config.in"
 	source "package/python-libconfig/Config.in"
+	source "package/python-lxml/Config.in"
 	source "package/python-mad/Config.in"
 	source "package/python-markdown/Config.in"
 	source "package/python-markupsafe/Config.in"
diff --git a/package/python-lxml/Config.in b/package/python-lxml/Config.in
new file mode 100644
index 0000000..1ccaa5e
--- /dev/null
+++ b/package/python-lxml/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_PYTHON_LXML
+	bool "python-lxml"
+	select BR2_PACKAGE_LIBXML2
+	select BR2_PACKAGE_LIBXSLT
+	select BR2_PACKAGE_ZLIB
+	help
+	  The lxml XML toolkit is a Pythonic binding for the C libraries
+	  libxml2 and libxslt.
+
+	  http://lxml.de/
diff --git a/package/python-lxml/python-lxml.mk b/package/python-lxml/python-lxml.mk
index 758ce87..a7f072f 100644
--- a/package/python-lxml/python-lxml.mk
+++ b/package/python-lxml/python-lxml.mk
@@ -20,6 +20,13 @@  PYTHON_LXML_LICENSE_FILES = \
 # So, we use setuptools.
 PYTHON_LXML_SETUP_TYPE = setuptools
 
-PYTHON_LXML_DEPENDENCIES = libxml2 libxslt
+PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
 
+# python-lxml needs these scripts in order to properly detect libxml2 and
+# libxslt compiler and linker flags
+PYTHON_LXML_BUILD_OPTS = \
+	--with-xslt-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xslt-config \
+	--with-xml2-config=$(HOST_DIR)/usr/arm-buildroot-linux-gnueabi/sysroot/usr/bin/xml2-config
+
+$(eval $(python-package))
 $(eval $(host-python-package))