diff mbox

[v6,01/15] mesa3d: Give possibility to external backends to enable DRI/Gallium

Message ID 1421451251-23366-2-git-send-email-jezz@sysmic.org
State Superseded
Headers show

Commit Message

Jérôme Pouiller Jan. 16, 2015, 11:33 p.m. UTC
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
 package/mesa3d/mesa3d.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Bernd Kuhls Jan. 17, 2015, 5:02 p.m. UTC | #1
=?UTF-8?q?J=C3=A9r=C3=B4me=20Pouiller?= <jezz-
kPcTzGkeZgAdnm+yROfE0A@public.gmane.org> wrote in news:1421451251-23366-2-
git-send-email-jezz@sysmic.org:

> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
> ---
>  package/mesa3d/mesa3d.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
> index f6f6b0f..e96bba6 100644
> --- a/package/mesa3d/mesa3d.mk
> +++ b/package/mesa3d/mesa3d.mk
> @@ -64,7 +64,7 @@ MESA3D_DRI_DRIVERS-$(BR2
_PACKAGE_MESA3D_DRI_DRIVER_I915)   += i915
>  MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I965)   += i965
>  MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON) += radeon
>  
> -ifeq ($(MESA3D_GALLIUM_DRIVERS-y),)
> +ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER),)
>  MESA3D_CONF_OPTS += \
>       --without-gallium-drivers
>  else
> @@ -73,7 +73,7 @@ MESA3D_CONF_OPTS += \
>       --with-gallium-drivers=$(subst $(space),$(comma),
$(MESA3D_GALLIUM_DRIVERS-y))
>  endif
>  
> -ifeq ($(MESA3D_DRI_DRIVERS-y),)
> +ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),)
>  MESA3D_CONF_OPTS += \
>       --without-dri-drivers --without-dri --disable-dri3
>  else
> -- 
> 1.9.1
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
> Attachment decoded: untitled-1.txt
> 

Hi,

I only looked at this patch alone since I have no freescale hardware to 
test with. Compiling mesa3d with this patch included using this defconfig

BR2_PACKAGE_MESA3D=y
BR2_PACKAGE_MESA3D_GALLIUM_DRIVER=y
BR2_PACKAGE_MESA3D_DRI_DRIVER=y
BR2_PACKAGE_MESA3D_DRIVER=y

does not break despite providing empty values in these configure options

--with-gallium-drivers= 
--with-dri-drivers=

so

Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Regards, Bernd
Gary Bisson April 30, 2015, 8:16 a.m. UTC | #2
Hi all,

On Sat, Jan 17, 2015 at 12:33:57AM +0100, Jérôme Pouiller wrote:
> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
> Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/mesa3d/mesa3d.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
> index f6f6b0f..e96bba6 100644
> --- a/package/mesa3d/mesa3d.mk
> +++ b/package/mesa3d/mesa3d.mk
> @@ -64,7 +64,7 @@ MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I915)   += i915
>  MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I965)   += i965
>  MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON) += radeon
>  
> -ifeq ($(MESA3D_GALLIUM_DRIVERS-y),)
> +ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER),)
>  MESA3D_CONF_OPTS += \
>  	--without-gallium-drivers
>  else
> @@ -73,7 +73,7 @@ MESA3D_CONF_OPTS += \
>  	--with-gallium-drivers=$(subst $(space),$(comma),$(MESA3D_GALLIUM_DRIVERS-y))
>  endif
>  
> -ifeq ($(MESA3D_DRI_DRIVERS-y),)
> +ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),)
>  MESA3D_CONF_OPTS += \
>  	--without-dri-drivers --without-dri --disable-dri3
>  else

As explained in my answer to the cover letter, this series of patch has
been successfully tested on a Nitrogen6x board.
http://lists.busybox.net/pipermail/buildroot/2015-April/124739.html

Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>

Regards,
Gary
Thomas Petazzoni April 30, 2015, 8:26 a.m. UTC | #3
Dear Gary Bisson,

On Thu, 30 Apr 2015 10:16:18 +0200, Gary Bisson wrote:

> As explained in my answer to the cover letter, this series of patch has
> been successfully tested on a Nitrogen6x board.
> http://lists.busybox.net/pipermail/buildroot/2015-April/124739.html
> 
> Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>

Thanks. Could you, or Jérôme provide a more detailed (i.e non-empty)
commit log for this commit? What's happening is not that trivial, but
the commit log is empty.

No need to resend the patch, just provide in a mail a better commit
log, and Peter or I will integrate the new commit log when applying the
patch.

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
index f6f6b0f..e96bba6 100644
--- a/package/mesa3d/mesa3d.mk
+++ b/package/mesa3d/mesa3d.mk
@@ -64,7 +64,7 @@  MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I915)   += i915
 MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I965)   += i965
 MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON) += radeon
 
-ifeq ($(MESA3D_GALLIUM_DRIVERS-y),)
+ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER),)
 MESA3D_CONF_OPTS += \
 	--without-gallium-drivers
 else
@@ -73,7 +73,7 @@  MESA3D_CONF_OPTS += \
 	--with-gallium-drivers=$(subst $(space),$(comma),$(MESA3D_GALLIUM_DRIVERS-y))
 endif
 
-ifeq ($(MESA3D_DRI_DRIVERS-y),)
+ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),)
 MESA3D_CONF_OPTS += \
 	--without-dri-drivers --without-dri --disable-dri3
 else