diff mbox

erlang: bump to version 17.4

Message ID 1418411483-29636-1-git-send-email-fhunleth@troodon-software.com
State Accepted
Commit 41d987dcc186bc3ff46763329247219ca97ddedf
Headers show

Commit Message

Frank Hunleth Dec. 12, 2014, 7:11 p.m. UTC
Erlang/OTP 17.4 is a service release on the 17 track with mostly bug
fixes, but it does contain a number of new features and characteristics
improvements as well.

Some highlights of the release are:

  - eldap: Nearly all TCP options are possible to give in the
    eldap:open/2 call.
  - ssh: Added API functions ptty_alloc/3 and ptty_alloc/4, to allocate a
    pseudo tty.
  - ssl: Handle servers that may send an empty SNI extension to the client.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
---
 package/erlang/erlang.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 13, 2014, 9:06 a.m. UTC | #1
>>>>> "Frank" == Frank Hunleth <fhunleth@troodon-software.com> writes:

 > Erlang/OTP 17.4 is a service release on the 17 track with mostly bug
 > fixes, but it does contain a number of new features and characteristics
 > improvements as well.

 > Some highlights of the release are:

 >   - eldap: Nearly all TCP options are possible to give in the
 >     eldap:open/2 call.
 >   - ssh: Added API functions ptty_alloc/3 and ptty_alloc/4, to allocate a
 >     pseudo tty.
 >   - ssl: Handle servers that may send an empty SNI extension to the client.

 > Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>

Committed, thanks.
Peter Korsgaard Dec. 15, 2014, 6:53 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>> "Frank" == Frank Hunleth <fhunleth@troodon-software.com> writes:
 >> Erlang/OTP 17.4 is a service release on the 17 track with mostly bug
 >> fixes, but it does contain a number of new features and characteristics
 >> improvements as well.

 >> Some highlights of the release are:

 >> - eldap: Nearly all TCP options are possible to give in the
 >> eldap:open/2 call.
 >> - ssh: Added API functions ptty_alloc/3 and ptty_alloc/4, to allocate a
 >> pseudo tty.
 >> - ssl: Handle servers that may send an empty SNI extension to the client.

 >> Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>

 > Committed, thanks.

It seems to cause some build issues on ARM. Care to take a look?

http://autobuild.buildroot.net/?reason=erlang-17.4
Frank Hunleth Dec. 15, 2014, 2:27 p.m. UTC | #3
On Mon, Dec 15, 2014 at 1:53 AM, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:
>
>>>>>> "Frank" == Frank Hunleth <fhunleth@troodon-software.com> writes:
>  >> Erlang/OTP 17.4 is a service release on the 17 track with mostly bug
>  >> fixes, but it does contain a number of new features and characteristics
>  >> improvements as well.
>
>  >> Some highlights of the release are:
>
>  >> - eldap: Nearly all TCP options are possible to give in the
>  >> eldap:open/2 call.
>  >> - ssh: Added API functions ptty_alloc/3 and ptty_alloc/4, to allocate a
>  >> pseudo tty.
>  >> - ssl: Handle servers that may send an empty SNI extension to the client.
>
>  >> Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
>
>  > Committed, thanks.
>
> It seems to cause some build issues on ARM. Care to take a look?
>
> http://autobuild.buildroot.net/?reason=erlang-17.4

Ugh, it worked on my ARM. :( I'll see if I can figure out the issue
when I get a chance later today.

Thanks,
Frank
diff mbox

Patch

diff --git a/package/erlang/erlang.mk b/package/erlang/erlang.mk
index ef0e0a2..045c07f 100644
--- a/package/erlang/erlang.mk
+++ b/package/erlang/erlang.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-ERLANG_VERSION = 17.3
+ERLANG_VERSION = 17.4
 ERLANG_SITE = http://www.erlang.org/download
 ERLANG_SOURCE = otp_src_$(ERLANG_VERSION).tar.gz
 ERLANG_DEPENDENCIES = host-erlang