diff mbox

[v2,1/7] Adding ding-libs

Message ID 1418398967-2183-2-git-send-email-gregd72002@gmail.com
State Accepted
Headers show

Commit Message

Gregory Dymarek Dec. 12, 2014, 3:42 p.m. UTC
Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
---
 package/Config.in                |  1 +
 package/ding-libs/Config.in      |  9 +++++++++
 package/ding-libs/ding-libs.hash |  1 +
 package/ding-libs/ding-libs.mk   | 17 +++++++++++++++++
 4 files changed, 28 insertions(+)
 create mode 100644 package/ding-libs/Config.in
 create mode 100644 package/ding-libs/ding-libs.hash
 create mode 100644 package/ding-libs/ding-libs.mk

Comments

Thomas Petazzoni Dec. 31, 2014, 5:03 p.m. UTC | #1
Dear Gregory Dymarek,

On Fri, 12 Dec 2014 15:42:41 +0000, Gregory Dymarek wrote:
> Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
> ---
>  package/Config.in                |  1 +
>  package/ding-libs/Config.in      |  9 +++++++++
>  package/ding-libs/ding-libs.hash |  1 +
>  package/ding-libs/ding-libs.mk   | 17 +++++++++++++++++
>  4 files changed, 28 insertions(+)
>  create mode 100644 package/ding-libs/Config.in
>  create mode 100644 package/ding-libs/ding-libs.hash
>  create mode 100644 package/ding-libs/ding-libs.mk

Thanks, applied, after doing again a fairly significant amount of fixes:

    [Thomas:
     - Remove unneeded comment in Config.in
     - Remove select if libiconv, not needed
     - Add dependency on wchar, needed when we depend on gettext
     - Improve Config.in help text
     - Fix the format of the hash file to make it actually useful
     - Fix the comment header in the .mk file
     - Remove useless commented line in .mk file
     - Fixup license information: it's not under GPLv3, but under LGPLv3+
       (library) and GPLv3+ (test programs)
     - Add host-pkgconf to the dependencies, remove libiconv from the
       dependencies.
     - Add a comment to explain why autoreconf is needed.
     - Remove usage of $(MAKE1) that does look necessary.]

See
http://git.buildroot.net/buildroot/commit/?id=3af1d306bdc4144e243e453221a7ab5a49b14e56
for the final commit.

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 48be2df..9e3f11b 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -876,6 +876,7 @@  menu "Other"
 	source "package/clapack/Config.in"
 	source "package/classpath/Config.in"
 	source "package/cppcms/Config.in"
+	source "package/ding-libs/Config.in"
 	source "package/eigen/Config.in"
 	source "package/elfutils/Config.in"
 	source "package/fftw/Config.in"
diff --git a/package/ding-libs/Config.in b/package/ding-libs/Config.in
new file mode 100644
index 0000000..7c7a17f
--- /dev/null
+++ b/package/ding-libs/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_DING_LIBS
+	bool "ding-libs"
+#	depends on BR2_TOOLCHAIN_BUILDROOT_LOCALE 
+	select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+	select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
+	help
+	Adds ding-libs 
+	https://git.fedorahosted.org/git/ding-libs.git
+
diff --git a/package/ding-libs/ding-libs.hash b/package/ding-libs/ding-libs.hash
new file mode 100644
index 0000000..cf21585
--- /dev/null
+++ b/package/ding-libs/ding-libs.hash
@@ -0,0 +1 @@ 
+sha256,639984a57d6f936a6551c842712619692febaebf4515033fc929620a241ffa6a
diff --git a/package/ding-libs/ding-libs.mk b/package/ding-libs/ding-libs.mk
new file mode 100644
index 0000000..582b9be
--- /dev/null
+++ b/package/ding-libs/ding-libs.mk
@@ -0,0 +1,17 @@ 
+#############################################################
+#
+# ding-libs
+#
+#############################################################
+DING_LIBS_VERSION = 0_4_0
+DING_LIBS_SOURCE = ding_libs-$(DING_LIBS_VERSION).tar.xz
+DING_LIBS_SITE = https://git.fedorahosted.org/cgit/ding-libs.git/snapshot 
+#DING_LIBS_DEPENDENCIES = BR2_TOOLCHAIN_BUILDROOT_LOCALE
+DING_LIBS_DEPENDENCIES = $(if !$(BR2_ENABLE_LOCALE),libiconv) $(if $(BR2_NEEDS_GETTEXT),gettext) 
+DING_LIBS_AUTORECONF = YES
+DING_LIBS_INSTALL_STAGING = YES
+DING_LIBS_LICENSE = GPLv3
+DING_LIBS_LICENSE_FILES = COPYING
+DING_LIBS_MAKE=$(MAKE1)
+
+$(eval $(autotools-package))