diff mbox

[v2,1/1] mtr: bump to version 0.86 and use github call

Message ID 1418177637-28038-1-git-send-email-vsergeev@kumunetworks.com
State Accepted
Headers show

Commit Message

Ivan Sergeev Dec. 10, 2014, 2:13 a.m. UTC
Signed-off-by: Ivan Sergeev <vsergeev@kumunetworks.com>
---
 package/mtr/mtr.mk | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Vicente Olivert Riera Dec. 10, 2014, 4:37 p.m. UTC | #1
Dear Ivan Sergeev,

just a few things:

On 12/10/2014 02:13 AM, Ivan Sergeev wrote:
>  MTR_CONF_OPTS = --without-gtk --without-glib

The '--without-glib' option doesn't exist in the configure script. You
can remove it.

Also, while you are doing the version bump, why not adding a hash file
as well:

http://buildroot.uclibc.org/downloads/manual/manual.html#adding-packages-hash

Could you please mark the previous versions of this patch as
'superseded' in patchwork?

And finally, could you please state what changes you make between versions?

Best regards,
Thomas Petazzoni Dec. 10, 2014, 6:59 p.m. UTC | #2
Dear Vicente Olivert Riera,

On Wed, 10 Dec 2014 16:37:12 +0000, Vicente Olivert Riera wrote:

> Also, while you are doing the version bump, why not adding a hash file
> as well:
> 
> http://buildroot.uclibc.org/downloads/manual/manual.html#adding-packages-hash

Are you sure it makes sense to have hash files for github downloads?

There were some patches from Maxime Hadjinlian to remove hash files for
github-sourced packages.

Also, when you reply to someone on the list, you should reply both to
the person (as To:) and the list (as Cc:). This will make sure the
person you reply to actually sees the message, and your message is not
mixed in the fairly heavy flow of e-mails that goes through the list.

Thanks!

Thomas
Vicente Olivert Riera Dec. 10, 2014, 7:47 p.m. UTC | #3
Hi Thomas,

yes, it makes sense. If you download a released tarball, it's supposed the hash of that tarball should be always the same.

In fact, I would change the download url to this one:

https://github.com/traviscross/mtr/releases

Cheers,
--
Vicente Olivert Riera
Graduate Software Engineer, MIPS Processor IP
Imagination Technologies Limited
t: +44 (0)113 2429814
www.imgtec.com
Thomas Petazzoni Dec. 10, 2014, 8:52 p.m. UTC | #4
Dear Ivan Sergeev,

On Tue,  9 Dec 2014 18:13:57 -0800, Ivan Sergeev wrote:
> Signed-off-by: Ivan Sergeev <vsergeev@kumunetworks.com>
> ---
>  package/mtr/mtr.mk | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Thanks, I've applied your patch, after removing the --without-glib
option that is no longer useful.

Also, if you have some time to work on mtr, it would be good to get rid
of the ugly:

# uClibc has res_ninit but not res_nmkquery
ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
define MTR_DISABLE_RES_NINIT
        $(SED) 's/#ifdef res_ninit/#if 0/' \
                $(@D)/dns.c
endef
endif

MTR_POST_PATCH_HOOKS += MTR_DISABLE_RES_NINIT

that we have in package/mtr/mtr.mk. To do this, some improvements to
configure.ac are needed to detect if the C library has res_ninit() and
res_nmkquery(). Feel free to work this out with upstream :-)

Thanks!

Thomas Petazzoni
Ivan Sergeev Dec. 12, 2014, 9:43 p.m. UTC | #5
Dear Vicente Olivert Riera,

Thanks, sure. I'll look out for stale configure options and keep things in
sync with patchwork next time around.

Thanks,
~vsergeev
Ivan Sergeev

On Wed, Dec 10, 2014 at 8:37 AM, Vicente Olivert Riera <
Vincent.Riera@imgtec.com> wrote:

> Dear Ivan Sergeev,
>
> just a few things:
>
> On 12/10/2014 02:13 AM, Ivan Sergeev wrote:
> >  MTR_CONF_OPTS = --without-gtk --without-glib
>
> The '--without-glib' option doesn't exist in the configure script. You
> can remove it.
>
> Also, while you are doing the version bump, why not adding a hash file
> as well:
>
>
> http://buildroot.uclibc.org/downloads/manual/manual.html#adding-packages-hash
>
> Could you please mark the previous versions of this patch as
> 'superseded' in patchwork?
>
> And finally, could you please state what changes you make between versions?
>
> Best regards,
> --
> Vicente Olivert Riera
> Graduate Software Engineer, MIPS Platforms
> Imagination Technologies Limited
> t: +44 (0)113 2429814
> www.imgtec.com
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
diff mbox

Patch

diff --git a/package/mtr/mtr.mk b/package/mtr/mtr.mk
index aa4d883..75cadc1 100644
--- a/package/mtr/mtr.mk
+++ b/package/mtr/mtr.mk
@@ -4,8 +4,9 @@ 
 #
 ################################################################################
 
-MTR_VERSION = 0.85
-MTR_SITE = ftp://ftp.bitwizard.nl/mtr
+MTR_VERSION = v0.86
+MTR_SITE = $(call github,traviscross,mtr,$(MTR_VERSION))
+MTR_AUTORECONF = YES
 MTR_CONF_OPTS = --without-gtk --without-glib
 MTR_DEPENDENCIES = host-pkgconf $(if $(BR2_PACKAGE_NCURSES),ncurses)
 MTR_LICENSE = GPLv2