diff mbox

[1/8] Adding janus-gateway and dependencies

Message ID 1418160208-1569-1-git-send-email-gregd72002@gmail.com
State Superseded
Headers show

Commit Message

Gregory Dymarek Dec. 9, 2014, 9:23 p.m. UTC
From: Gregory Dymarek <gregd72002@gmail.com>

Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
---
 package/ding-libs/Config.in    | 14 ++++++++++++++
 package/ding-libs/ding-libs.mk | 16 ++++++++++++++++
 2 files changed, 30 insertions(+)
 create mode 100644 package/ding-libs/Config.in
 create mode 100644 package/ding-libs/ding-libs.mk

Comments

Vicente Olivert Riera Dec. 10, 2014, 5:04 p.m. UTC | #1
Dear Gregory Dymarek,

why not adding a hash file at the same time?

http://buildroot.org/downloads/manual/manual.html#adding-packages-hash

same for the rest of new packages you want to add.

Best regards,
Gregory Dymarek Dec. 10, 2014, 5:23 p.m. UTC | #2
Hi,

Do you need hashes for GIT/SVN checkouts?

Thanks,
Gregory

On 10 December 2014 at 17:04, Vicente Olivert Riera
<Vincent.Riera@imgtec.com> wrote:
> Dear Gregory Dymarek,
>
> why not adding a hash file at the same time?
>
> http://buildroot.org/downloads/manual/manual.html#adding-packages-hash
>
> same for the rest of new packages you want to add.
>
> Best regards,
> --
> Vicente Olivert Riera
> Graduate Software Engineer, MIPS Platforms
> Imagination Technologies Limited
> t: +44 (0)113 2429814
> www.imgtec.com
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Vicente Olivert Riera Dec. 10, 2014, 5:25 p.m. UTC | #3
Dear Gregory Dymarek,

On 12/10/2014 05:23 PM, Gregory Dymarek wrote:
> Do you need hashes for GIT/SVN checkouts?

Well, you are downloading a tarball which should be always the same, no?

Cheers,
Thomas Petazzoni Dec. 10, 2014, 8:38 p.m. UTC | #4
Dear Vicente Olivert Riera,

On Wed, 10 Dec 2014 17:25:28 +0000, Vicente Olivert Riera wrote:

> On 12/10/2014 05:23 PM, Gregory Dymarek wrote:
> > Do you need hashes for GIT/SVN checkouts?
> 
> Well, you are downloading a tarball which should be always the same, no?

No, for git and svn you are not downloading a tarball. We are cloning
the Git repository or checkouting the SVN repository, and then making a
tarball out of it. I don't think we have any guarantee that the tarball
created on the different machines will be the same, due to the file
timestamps.

Best regards,

Thomas
Yann E. MORIN Dec. 10, 2014, 10:19 p.m. UTC | #5
Thomas, All,

On 2014-12-10 21:38 +0100, Thomas Petazzoni spake thusly:
> Dear Vicente Olivert Riera,
> 
> On Wed, 10 Dec 2014 17:25:28 +0000, Vicente Olivert Riera wrote:
> 
> > On 12/10/2014 05:23 PM, Gregory Dymarek wrote:
> > > Do you need hashes for GIT/SVN checkouts?
> > 
> > Well, you are downloading a tarball which should be always the same, no?
> 
> No, for git and svn you are not downloading a tarball. We are cloning
> the Git repository or checkouting the SVN repository, and then making a
> tarball out of it.

But inthis case, we're not doing a git-clone, we;re using a snapshot.
Which should by the way be using the github helper, rather than the
manaul _SITE method.

> I don't think we have any guarantee that the tarball
> created on the different machines will be the same, due to the file
> timestamps.

No we do not.

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/ding-libs/Config.in b/package/ding-libs/Config.in
new file mode 100644
index 0000000..4840c51
--- /dev/null
+++ b/package/ding-libs/Config.in
@@ -0,0 +1,14 @@ 
+config BR2_PACKAGE_DING_LIBS
+	bool "ding-libs"
+	select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+	select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
+	help
+	  DING-LIBS (DING Is Not Glib) are a set of small, useful libraries that SSSD uses and makes available to other projects. They provide:
+	    dhash - A dynamic hash table
+	    ini_config - A library for parsing and managing INI files
+	    path_utils - Manage UNIX paths and subsets of paths
+	    collection - A generic, hierarchical grouping mechanism for complex data sets
+	    ref_array - A dynamically-growing, reference-counted array
+	    libbasicobjects - A set of fundamental object types for C
+
+	  https://git.fedorahosted.org/git/ding-libs.git
diff --git a/package/ding-libs/ding-libs.mk b/package/ding-libs/ding-libs.mk
new file mode 100644
index 0000000..c49a9b7
--- /dev/null
+++ b/package/ding-libs/ding-libs.mk
@@ -0,0 +1,16 @@ 
+#############################################################
+#
+# ding-libs
+#
+#############################################################
+DING_LIBS_VERSION = 0_4_0
+DING_LIBS_SOURCE = ding_libs-$(DING_LIBS_VERSION).tar.xz
+DING_LIBS_SITE = https://git.fedorahosted.org/cgit/ding-libs.git/snapshot 
+DING_LIBS_DEPENDENCIES = $(if !$(BR2_ENABLE_LOCALE),libiconv) $(if $(BR2_NEEDS_GETTEXT),gettext) 
+DING_LIBS_AUTORECONF = YES
+DING_LIBS_INSTALL_STAGING = YES
+DING_LIBS_LICENSE = GPLv3
+DING_LIBS_LICENSE_FILES = COPYING
+DING_LIBS_MAKE=$(MAKE1)
+
+$(eval $(autotools-package))