diff mbox

[v4,05/17] erlang-goldrush: new package.

Message ID 1418135662-773-6-git-send-email-johan.oudinet@gmail.com
State Superseded
Headers show

Commit Message

Johan Oudinet Dec. 9, 2014, 2:34 p.m. UTC
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
---
 package/Config.in                          |  5 +++++
 package/erlang-goldrush/Config.in          |  6 ++++++
 package/erlang-goldrush/erlang-goldrush.mk | 14 ++++++++++++++
 3 files changed, 25 insertions(+)
 create mode 100644 package/erlang-goldrush/Config.in
 create mode 100644 package/erlang-goldrush/erlang-goldrush.mk

Comments

Thomas Petazzoni Jan. 4, 2015, 9:36 p.m. UTC | #1
Dear Johan Oudinet,

On Tue,  9 Dec 2014 15:34:10 +0100, Johan Oudinet wrote:
> Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
> Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
> ---
>  package/Config.in                          |  5 +++++
>  package/erlang-goldrush/Config.in          |  6 ++++++
>  package/erlang-goldrush/erlang-goldrush.mk | 14 ++++++++++++++
>  3 files changed, 25 insertions(+)
>  create mode 100644 package/erlang-goldrush/Config.in
>  create mode 100644 package/erlang-goldrush/erlang-goldrush.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index 600a68d..06c8e04 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -392,6 +392,11 @@ endmenu
>  menu "Interpreter languages and scripting"
>  	source "package/enscript/Config.in"
>  	source "package/erlang/Config.in"
> +if BR2_PACKAGE_ERLANG

So all Erlang packages are not visible unless erlang is enabled. Which
sounds good.

> +menu "Erlang libraries/modules"
> +	source "package/erlang-goldrush/Config.in"
> +endmenu
> +endif
>  	source "package/guile/Config.in"
>  	source "package/haserl/Config.in"
>  	source "package/jamvm/Config.in"
> diff --git a/package/erlang-goldrush/Config.in b/package/erlang-goldrush/Config.in
> new file mode 100644
> index 0000000..685a887
> --- /dev/null
> +++ b/package/erlang-goldrush/Config.in
> @@ -0,0 +1,6 @@
> +config BR2_PACKAGE_ERLANG_GOLDRUSH
> +	bool "erlang-goldrush"
> +	depends on BR2_PACKAGE_ERLANG

So why do we have this dependency again here?

> +	help
> +	  Goldrush is a small Erlang app that provides fast event
> +	  stream processing.
> diff --git a/package/erlang-goldrush/erlang-goldrush.mk b/package/erlang-goldrush/erlang-goldrush.mk
> new file mode 100644
> index 0000000..7537e76
> --- /dev/null
> +++ b/package/erlang-goldrush/erlang-goldrush.mk
> @@ -0,0 +1,14 @@
> +################################################################################
> +#
> +# erlang-goldrush
> +#
> +################################################################################
> +
> +ERLANG_GOLDRUSH_VERSION = 0.1.6
> +ERLANG_GOLDRUSH_SITE = $(call github,DeadZen,goldrush,$(ERLANG_GOLDRUSH_VERSION))
> +ERLANG_GOLDRUSH_LICENSE_FILES = LICENSE

No <pkg>_LICENSE ?

> +ERLANG_GOLDRUSH_DEPENDENCIES = erlang host-erlang-rebar

Why are those dependencies necessary? Aren't they handled by the rebar
infra?

> +ERLANG_GOLDRUSH_INSTALL_STAGING = YES
> +
> +$(eval $(rebar-package))
> +$(eval $(host-rebar-package))

Might be good to say a word in the commit log to explain why a host
variant of this library is needed.

Thanks!

Thomas
Johan Oudinet Jan. 5, 2015, 2:52 p.m. UTC | #2
Thomas, All,

On Sun, Jan 4, 2015 at 10:36 PM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> Dear Johan Oudinet,
>
> On Tue,  9 Dec 2014 15:34:10 +0100, Johan Oudinet wrote:
>> Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
>> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
>> Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
>> ---
>>  package/Config.in                          |  5 +++++
>>  package/erlang-goldrush/Config.in          |  6 ++++++
>>  package/erlang-goldrush/erlang-goldrush.mk | 14 ++++++++++++++
>>  3 files changed, 25 insertions(+)
>>  create mode 100644 package/erlang-goldrush/Config.in
>>  create mode 100644 package/erlang-goldrush/erlang-goldrush.mk
>>
>> diff --git a/package/Config.in b/package/Config.in
>> index 600a68d..06c8e04 100644
>> --- a/package/Config.in
>> +++ b/package/Config.in
>> @@ -392,6 +392,11 @@ endmenu
>>  menu "Interpreter languages and scripting"
>>       source "package/enscript/Config.in"
>>       source "package/erlang/Config.in"
>> +if BR2_PACKAGE_ERLANG
>
> So all Erlang packages are not visible unless erlang is enabled. Which
> sounds good.
>
>> +menu "Erlang libraries/modules"
>> +     source "package/erlang-goldrush/Config.in"
>> +endmenu
>> +endif
>>       source "package/guile/Config.in"
>>       source "package/haserl/Config.in"
>>       source "package/jamvm/Config.in"
>> diff --git a/package/erlang-goldrush/Config.in b/package/erlang-goldrush/Config.in
>> new file mode 100644
>> index 0000000..685a887
>> --- /dev/null
>> +++ b/package/erlang-goldrush/Config.in
>> @@ -0,0 +1,6 @@
>> +config BR2_PACKAGE_ERLANG_GOLDRUSH
>> +     bool "erlang-goldrush"
>> +     depends on BR2_PACKAGE_ERLANG
>
> So why do we have this dependency again here?

Good point. I've removed it. Thanks for noticing it.

>> --- /dev/null
>> +++ b/package/erlang-goldrush/erlang-goldrush.mk
>> @@ -0,0 +1,14 @@
>> +################################################################################
>> +#
>> +# erlang-goldrush
>> +#
>> +################################################################################
>> +
>> +ERLANG_GOLDRUSH_VERSION = 0.1.6
>> +ERLANG_GOLDRUSH_SITE = $(call github,DeadZen,goldrush,$(ERLANG_GOLDRUSH_VERSION))
>> +ERLANG_GOLDRUSH_LICENSE_FILES = LICENSE
>
> No <pkg>_LICENSE ?

It is an ISC license, and the abbreviation is not available within Buildroot.

>
>> +ERLANG_GOLDRUSH_DEPENDENCIES = erlang host-erlang-rebar
>
> Why are those dependencies necessary? Aren't they handled by the rebar
> infra?

Excellent idea. I've just modified pkg-rebar to do that and I'll
remove erlang and host-erlang-rebar from the dependencies of all
erlang packages.

>
>> +ERLANG_GOLDRUSH_INSTALL_STAGING = YES
>> +
>> +$(eval $(rebar-package))
>> +$(eval $(host-rebar-package))
>
> Might be good to say a word in the commit log to explain why a host
> variant of this library is needed.

Ok. So I should not provide an host variant unless some other packages need it?

Thanks for the review.
Thomas Petazzoni Jan. 5, 2015, 4:37 p.m. UTC | #3
Dear Johan Oudinet,

On Mon, 5 Jan 2015 15:52:27 +0100, Johan Oudinet wrote:

> > No <pkg>_LICENSE ?
> 
> It is an ISC license, and the abbreviation is not available within Buildroot.

This doesn't make sense: the <pkg>_LICENSE field is a free-form text
field. You can put whatever you want in this field. Whenever possible,
we prefer to use the SDPX license identifiers
(http://spdx.org/licenses/).

Also:

$ git grep "LICENSE.*ISC"
package/at/at.mk:AT_LICENSE = GPLv2+, GPLv3+, ISC
package/bind/bind.mk:BIND_LICENSE = ISC
package/crda/crda.mk:CRDA_LICENSE = ISC
package/dhcp/dhcp.mk:DHCP_LICENSE = ISC
package/harfbuzz/harfbuzz.mk:HARFBUZZ_LICENSE = MIT, ISC (ucdn library)
package/libass/libass.mk:LIBASS_LICENSE = ISC
package/libconfuse/libconfuse.mk:LIBCONFUSE_LICENSE = ISC
package/libuv/libuv.mk:LIBUV_LICENSE = BSD-2c, BSD-3c, ISC, MIT
package/odhcploc/odhcploc.mk:ODHCPLOC_LICENSE = ISC
package/pure-ftpd/pure-ftpd.mk:PURE_FTPD_LICENSE = ISC
package/python-certifi/python-certifi.mk:PYTHON_CERTIFI_LICENSE = ISC (Python code), MPL-2.0 (cacert.pem)
package/sudo/sudo.mk:SUDO_LICENSE = ISC BSD-3c
package/tmux/tmux.mk:TMUX_LICENSE = ISC
package/wireless-regdb/wireless-regdb.mk:WIRELESS_REGDB_LICENSE = ISC
package/yajl/yajl.mk:YAJL_LICENSE = ISC

> Excellent idea. I've just modified pkg-rebar to do that and I'll
> remove erlang and host-erlang-rebar from the dependencies of all
> erlang packages.

Great.

> > Might be good to say a word in the commit log to explain why a host
> > variant of this library is needed.
> 
> Ok. So I should not provide an host variant unless some other packages need it?

Indeed. Why would we want to have dead/unused code?

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 600a68d..06c8e04 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -392,6 +392,11 @@  endmenu
 menu "Interpreter languages and scripting"
 	source "package/enscript/Config.in"
 	source "package/erlang/Config.in"
+if BR2_PACKAGE_ERLANG
+menu "Erlang libraries/modules"
+	source "package/erlang-goldrush/Config.in"
+endmenu
+endif
 	source "package/guile/Config.in"
 	source "package/haserl/Config.in"
 	source "package/jamvm/Config.in"
diff --git a/package/erlang-goldrush/Config.in b/package/erlang-goldrush/Config.in
new file mode 100644
index 0000000..685a887
--- /dev/null
+++ b/package/erlang-goldrush/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_ERLANG_GOLDRUSH
+	bool "erlang-goldrush"
+	depends on BR2_PACKAGE_ERLANG
+	help
+	  Goldrush is a small Erlang app that provides fast event
+	  stream processing.
diff --git a/package/erlang-goldrush/erlang-goldrush.mk b/package/erlang-goldrush/erlang-goldrush.mk
new file mode 100644
index 0000000..7537e76
--- /dev/null
+++ b/package/erlang-goldrush/erlang-goldrush.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# erlang-goldrush
+#
+################################################################################
+
+ERLANG_GOLDRUSH_VERSION = 0.1.6
+ERLANG_GOLDRUSH_SITE = $(call github,DeadZen,goldrush,$(ERLANG_GOLDRUSH_VERSION))
+ERLANG_GOLDRUSH_LICENSE_FILES = LICENSE
+ERLANG_GOLDRUSH_DEPENDENCIES = erlang host-erlang-rebar
+ERLANG_GOLDRUSH_INSTALL_STAGING = YES
+
+$(eval $(rebar-package))
+$(eval $(host-rebar-package))