diff mbox

[1/1] package/x11r7/xserver_xorg-server: libunwind support is broken on mips64

Message ID 1417299035-17050-1-git-send-email-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls Nov. 29, 2014, 10:10 p.m. UTC
Fixes
http://autobuild.buildroot.net/results/e8f/e8f68163802f31359cee15fa3ca52547e06d1f27/
http://autobuild.buildroot.net/results/994/9947222da8682a358f81f8ac924c12596fd09ee8/
http://autobuild.buildroot.net/results/df9/df92d9b682976b77d9e1e4c39afca52b7512d847/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/x11r7/xserver_xorg-server/xserver_xorg-server.mk |    4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 30, 2014, 8:40 p.m. UTC | #1
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Fixes
 > http://autobuild.buildroot.net/results/e8f/e8f68163802f31359cee15fa3ca52547e06d1f27/
 > http://autobuild.buildroot.net/results/994/9947222da8682a358f81f8ac924c12596fd09ee8/
 > http://autobuild.buildroot.net/results/df9/df92d9b682976b77d9e1e4c39afca52b7512d847/

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 > ---
 >  package/x11r7/xserver_xorg-server/xserver_xorg-server.mk |    4 +++-
 >  1 file changed, 3 insertions(+), 1 deletion(-)

 > diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
 > b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
 > index 4db8b09..cae06e6 100644
 > --- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
 > +++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
 > @@ -144,7 +144,9 @@ ifeq ($(BR2_PACKAGE_FREETYPE),y)
 >  XSERVER_XORG_SERVER_DEPENDENCIES += freetype
 >  endif
 > -ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 > +# libunwind support is broken on mips64
 > +# https://www.libreoffice.org/bugzilla/show_bug.cgi?id=79939

This doesn't have anything to do with libreoffice. That URL is
apparently an alias for bugs.freedesktop.org (the official bugtracker
for xorg), so I've used that as URL instead.


 > +ifeq ($(BR2_PACKAGE_LIBUNWIND)$(BR2_mips64el),y)
 >  XSERVER_XORG_SERVER_DEPENDENCIES += libunwind

That's not good as builds on mips64el WITHOUT libunwind now ends up
pulling in libunwind (and breaking the build).

We need to match on LIBUNWIND and !mips64el, so there needs so be a
seperator in between, like:

ifeq ($(BR2_PACKAGE_LIBUNWIND)-$(BR2_mips64el),y-)

Even if it looks a bit odd.

Committed with those fixes, thanks.
Vicente Olivert Riera Dec. 1, 2014, 10:23 a.m. UTC | #2
Dear Bernd Kuhls, Peter Korsgaard,

On 11/30/2014 08:40 PM, Peter Korsgaard wrote:
>>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:
> 
>  > Fixes
>  > http://autobuild.buildroot.net/results/e8f/e8f68163802f31359cee15fa3ca52547e06d1f27/
>  > http://autobuild.buildroot.net/results/994/9947222da8682a358f81f8ac924c12596fd09ee8/
>  > http://autobuild.buildroot.net/results/df9/df92d9b682976b77d9e1e4c39afca52b7512d847/
> 
>  > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
>  > ---
>  >  package/x11r7/xserver_xorg-server/xserver_xorg-server.mk |    4 +++-
>  >  1 file changed, 3 insertions(+), 1 deletion(-)
> 
>  > diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
>  > b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
>  > index 4db8b09..cae06e6 100644
>  > --- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
>  > +++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
>  > @@ -144,7 +144,9 @@ ifeq ($(BR2_PACKAGE_FREETYPE),y)
>  >  XSERVER_XORG_SERVER_DEPENDENCIES += freetype
>  >  endif
>  > -ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
>  > +# libunwind support is broken on mips64
>  > +# https://www.libreoffice.org/bugzilla/show_bug.cgi?id=79939
> 
> This doesn't have anything to do with libreoffice. That URL is
> apparently an alias for bugs.freedesktop.org (the official bugtracker
> for xorg), so I've used that as URL instead.
> 
> 
>  > +ifeq ($(BR2_PACKAGE_LIBUNWIND)$(BR2_mips64el),y)
>  >  XSERVER_XORG_SERVER_DEPENDENCIES += libunwind
> 
> That's not good as builds on mips64el WITHOUT libunwind now ends up
> pulling in libunwind (and breaking the build).
> 
> We need to match on LIBUNWIND and !mips64el, so there needs so be a
> seperator in between, like:
> 
> ifeq ($(BR2_PACKAGE_LIBUNWIND)-$(BR2_mips64el),y-)
> 
> Even if it looks a bit odd.
> 
> Committed with those fixes, thanks.
> 

as you may see in the bug report, I'm the one who reported the bug.

https://bugs.freedesktop.org/show_bug.cgi?id=79939

Xorg with libunwind support is broken for MIPS64 n32, but MIPS64 n64 is
ok, so disabing libunwind support for mips64el is wrong.

Also, I'm trying to fix the problem in libunwind. I reported the bug and
sent a patch which we are discussing right now:

https://savannah.nongnu.org/bugs/?43695

Cheers,
diff mbox

Patch

diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
index 4db8b09..cae06e6 100644
--- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
@@ -144,7 +144,9 @@  ifeq ($(BR2_PACKAGE_FREETYPE),y)
 XSERVER_XORG_SERVER_DEPENDENCIES += freetype
 endif
 
-ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
+# libunwind support is broken on mips64
+# https://www.libreoffice.org/bugzilla/show_bug.cgi?id=79939
+ifeq ($(BR2_PACKAGE_LIBUNWIND)$(BR2_mips64el),y)
 XSERVER_XORG_SERVER_DEPENDENCIES += libunwind
 else
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-libunwind