diff mbox

[1/1] package/minidlna: fix static linking

Message ID 1417289621-17415-1-git-send-email-bernd.kuhls@t-online.de
State Changes Requested
Headers show

Commit Message

Bernd Kuhls Nov. 29, 2014, 7:33 p.m. UTC
Fixes
http://autobuild.buildroot.net/results/6bd/6bd8c009056beb67092abd6d18064500302dcecb/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
This patch depends on http://patchwork.ozlabs.org/patch/416006/

 package/minidlna/minidlna.mk |    4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN Dec. 7, 2014, 9:12 p.m. UTC | #1
Bernd, All,

On 2014-11-29 20:33 +0100, Bernd Kuhls spake thusly:
> Fixes
> http://autobuild.buildroot.net/results/6bd/6bd8c009056beb67092abd6d18064500302dcecb/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
> This patch depends on http://patchwork.ozlabs.org/patch/416006/
> 
>  package/minidlna/minidlna.mk |    4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/minidlna/minidlna.mk b/package/minidlna/minidlna.mk
> index 3a0ca35..d483e1c 100644
> --- a/package/minidlna/minidlna.mk
> +++ b/package/minidlna/minidlna.mk
> @@ -18,8 +18,10 @@ ifeq ($(BR2_PREFER_STATIC_LIB),y)
>  # the configure script / Makefile forgets to link with some of the dependent
>  # libraries breaking static linking, so help it along
>  MINIDLNA_CONF_ENV = \
> -	LIBS='-lavformat -lavcodec -lavutil -logg \
> +	LIBS='-lavformat -lavcodec -lavutil -logg -lvorbis -lvorbisenc \
> +		$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl) -lexif \
>  		$(if $(BR2_PACKAGE_OPENSSL),-lssl -lcrypto) \
> +		$(if $(BR2_PACKAGE_OPUS),-lswresample -lopus) \

Ofd course, this should be adapted with the previous comment to your
previous patch.

But hold on on it, I'd like Thomas P. to ack my comment before you work
on it...

Regards,
Yann E. MORIN.

>  		-lz -lpthread -lm'
>  else
>  MINIDLNA_CONF_OPTS = \
> -- 
> 1.7.10.4
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox

Patch

diff --git a/package/minidlna/minidlna.mk b/package/minidlna/minidlna.mk
index 3a0ca35..d483e1c 100644
--- a/package/minidlna/minidlna.mk
+++ b/package/minidlna/minidlna.mk
@@ -18,8 +18,10 @@  ifeq ($(BR2_PREFER_STATIC_LIB),y)
 # the configure script / Makefile forgets to link with some of the dependent
 # libraries breaking static linking, so help it along
 MINIDLNA_CONF_ENV = \
-	LIBS='-lavformat -lavcodec -lavutil -logg \
+	LIBS='-lavformat -lavcodec -lavutil -logg -lvorbis -lvorbisenc \
+		$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl) -lexif \
 		$(if $(BR2_PACKAGE_OPENSSL),-lssl -lcrypto) \
+		$(if $(BR2_PACKAGE_OPUS),-lswresample -lopus) \
 		-lz -lpthread -lm'
 else
 MINIDLNA_CONF_OPTS = \