diff mbox

[PATCHv2,62/74] fluxbox: install session file unconditionally

Message ID 1417125452-18705-63-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 82f82117eeebb2694565d26c1d76019823c7c057
Headers show

Commit Message

Thomas Petazzoni Nov. 27, 2014, 9:57 p.m. UTC
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/fluxbox/fluxbox.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox

Patch

diff --git a/package/fluxbox/fluxbox.mk b/package/fluxbox/fluxbox.mk
index 21901d6..a0f9367 100644
--- a/package/fluxbox/fluxbox.mk
+++ b/package/fluxbox/fluxbox.mk
@@ -24,8 +24,8 @@  FLUXBOX_CONF_OPTS += --disable-imlib2
 endif
 
 define FLUXBOX_INSTALL_XSESSION_FILE
-	[ -f $(TARGET_DIR)/root/.xsession ] || $(INSTALL) -m 0755 -D \
-		package/fluxbox/xsession $(TARGET_DIR)/root/.xsession
+	$(INSTALL) -m 0755 -D package/fluxbox/xsession \
+		$(TARGET_DIR)/root/.xsession
 endef
 
 FLUXBOX_POST_INSTALL_TARGET_HOOKS += FLUXBOX_INSTALL_XSESSION_FILE