diff mbox

[PATCHv2,55/74] iucode-tool: install init script unconditionally

Message ID 1417125452-18705-56-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit febe876dcc18938b43fe1012b0acc689176188ac
Headers show

Commit Message

Thomas Petazzoni Nov. 27, 2014, 9:57 p.m. UTC
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/iucode-tool/iucode-tool.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
diff mbox

Patch

diff --git a/package/iucode-tool/iucode-tool.mk b/package/iucode-tool/iucode-tool.mk
index 3124c73..081b086 100644
--- a/package/iucode-tool/iucode-tool.mk
+++ b/package/iucode-tool/iucode-tool.mk
@@ -15,9 +15,8 @@  IUCODE_TOOL_LICENSE = GPLv2+
 IUCODE_TOOL_LICENSE_FILES = COPYING
 
 define IUCODE_TOOL_INSTALL_INIT_SYSV
-	[ -f $(TARGET_DIR)/etc/init.d/S00iucode-tool ] || \
-		$(INSTALL) -D -m 0755 package/iucode-tool/S00iucode-tool \
-			$(TARGET_DIR)/etc/init.d/S00iucode-tool
+	$(INSTALL) -D -m 0755 package/iucode-tool/S00iucode-tool \
+		$(TARGET_DIR)/etc/init.d/S00iucode-tool
 endef
 
 $(eval $(autotools-package))