diff mbox

[PATCHv2,54/74] busybox: install init script unconditionally

Message ID 1417125452-18705-55-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit e31c6b961aff7e5018f8f5c72d938f1ad577c21f
Headers show

Commit Message

Thomas Petazzoni Nov. 27, 2014, 9:57 p.m. UTC
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/dmraid/dmraid.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Danomi Manchego Nov. 27, 2014, 11:13 p.m. UTC | #1
Thomas,

On Thu, Nov 27, 2014 at 4:57 PM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> As discussed, users should use a rootfs overlay or a post-build script
> instead of a custom skeleton to override files installed by Buildroot,
> so there is no point in having conditions when installing init scripts
> or configuration files.
>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  package/dmraid/dmraid.mk | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/package/dmraid/dmraid.mk b/package/dmraid/dmraid.mk
> index 024b9b5..a6ed57f 100644
> --- a/package/dmraid/dmraid.mk
> +++ b/package/dmraid/dmraid.mk

Subject says "busybox", but should be "dmraid"?

Danomi -
diff mbox

Patch

diff --git a/package/dmraid/dmraid.mk b/package/dmraid/dmraid.mk
index 024b9b5..a6ed57f 100644
--- a/package/dmraid/dmraid.mk
+++ b/package/dmraid/dmraid.mk
@@ -18,9 +18,8 @@  DMRAID_LICENSE_FILES = $(DMRAID_SUBDIR)/LICENSE_GPL $(DMRAID_SUBDIR)/LICENSE
 DMRAID_DEPENDENCIES = lvm2
 
 define DMRAID_INSTALL_INIT_SYSV
-	[ -f $(TARGET_DIR)/etc/init.d/S20dmraid ] || \
-		$(INSTALL) -D -m 0755 package/dmraid/S20dmraid \
-			$(TARGET_DIR)/etc/init.d/S20dmraid
+	$(INSTALL) -D -m 0755 package/dmraid/S20dmraid \
+		$(TARGET_DIR)/etc/init.d/S20dmraid
 endef
 
 $(eval $(autotools-package))