diff mbox

[PATCHv2,52/74] aiccu: install init script and config file unconditionally

Message ID 1417125452-18705-53-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit dc82dea73b878432bde1b2b164f4c746036fd772
Headers show

Commit Message

Thomas Petazzoni Nov. 27, 2014, 9:57 p.m. UTC
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/aiccu/aiccu.mk | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff mbox

Patch

diff --git a/package/aiccu/aiccu.mk b/package/aiccu/aiccu.mk
index 4413f86..faa861c 100644
--- a/package/aiccu/aiccu.mk
+++ b/package/aiccu/aiccu.mk
@@ -28,14 +28,12 @@  endef
 define AICCU_INSTALL_TARGET_CMDS
 	$(INSTALL) -D -m 0755 $(@D)/unix-console/aiccu \
 		$(TARGET_DIR)/usr/sbin/aiccu
-	[ -f $(TARGET_DIR)/etc/aiccu.conf ] || \
-		$(INSTALL) -D -m 0644 $(@D)/doc/aiccu.conf \
+	$(INSTALL) -D -m 0644 $(@D)/doc/aiccu.conf \
 		$(TARGET_DIR)/etc/aiccu.conf
 endef
 
 define AICCU_INSTALL_INIT_SYSV
-	[ -f $(TARGET_DIR)/etc/init.d/S50aiccu ] || \
-		$(INSTALL) -D -m 0755 $(@D)/doc/aiccu.init \
+	$(INSTALL) -D -m 0755 $(@D)/doc/aiccu.init \
 		$(TARGET_DIR)/etc/init.d/S50aiccu
 endef