diff mbox

[PATCHv2] grep: fix build failure for musl

Message ID 1415365017-14860-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Headers show

Commit Message

Gustavo Zacarias Nov. 7, 2014, 12:56 p.m. UTC
musl doesn't implement re_match and friends and grep fails to
detect this properly, so force internal regex routines for musl.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/grep/grep.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 7, 2014, 1:33 p.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 > musl doesn't implement re_match and friends and grep fails to
 > detect this properly, so force internal regex routines for musl.

 > Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>

Committed, thanks.
diff mbox

Patch

diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index e07f169..2c2477c 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -9,7 +9,8 @@  GREP_SITE = $(BR2_GNU_MIRROR)/grep
 GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPLv3+
 GREP_LICENSE_FILES = COPYING
-GREP_CONF_OPTS = --disable-perl-regexp --without-included-regex
+GREP_CONF_OPTS = --disable-perl-regexp \
+	$(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
 
 # link with iconv if enabled