diff mbox

grep: fix build failure for musl

Message ID 1415364859-23792-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Commit de903755d79e67dc84fa0715e162b19e94d6c137
Headers show

Commit Message

Gustavo Zacarias Nov. 7, 2014, 12:54 p.m. UTC
musl doesn't implement re_match and friends and coreutils fails to
detect this properly, so force internal regex routines for musl.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/grep/grep.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index e07f169..2c2477c 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -9,7 +9,8 @@  GREP_SITE = $(BR2_GNU_MIRROR)/grep
 GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPLv3+
 GREP_LICENSE_FILES = COPYING
-GREP_CONF_OPTS = --disable-perl-regexp --without-included-regex
+GREP_CONF_OPTS = --disable-perl-regexp \
+	$(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
 
 # link with iconv if enabled