diff mbox

coreutils: fix build failure for musl

Message ID 1415364346-29236-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Commit ef5c3f4e89c91597f1748b8877c1e3dd5c77c28b
Headers show

Commit Message

Gustavo Zacarias Nov. 7, 2014, 12:45 p.m. UTC
musl doesn't implement re_match and friends and coreutils fails to
detect this properly, so force internal regex routines for musl.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/coreutils/coreutils.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 7, 2014, 1:33 p.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 > musl doesn't implement re_match and friends and coreutils fails to
 > detect this properly, so force internal regex routines for musl.

 > Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>

Committed, thanks.
diff mbox

Patch

diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index 41857e2..391d2cd 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -14,7 +14,8 @@  COREUTILS_LICENSE_FILES = COPYING
 COREUTILS_AUTORECONF = YES
 COREUTILS_GETTEXTIZE = YES
 
-COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs
+COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs \
+	$(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
 	ac_cv_func_chown_works=yes \
 	ac_cv_func_euidaccess=no \