diff mbox

package/sysvinit: remove inline comment from root remount

Message ID 1413832724-15564-1-git-send-email-gustavo@zacarias.com.ar
State Superseded
Headers show

Commit Message

Gustavo Zacarias Oct. 20, 2014, 7:18 p.m. UTC
It breaks the root rw remount as explained in bug #7442.
Thanks to joymarquis@hotmail.com for pointing it out.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/sysvinit/inittab | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Oct. 21, 2014, 5:15 p.m. UTC | #1
Gustavo, All,

On 2014-10-20 16:18 -0300, Gustavo Zacarias spake thusly:
> It breaks the root rw remount as explained in bug #7442.
> Thanks to joymarquis@hotmail.com for pointing it out.
> 
> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>

NAK, because that's what is used to decide whether to remount root RW or
not (from system/system.mk ):

    ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
    # Find commented line, if any, and remove leading '#'s
    define SYSTEM_REMOUNT_RW
        $(SED) '/^#.*# REMOUNT_ROOTFS_RW$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
    endef
    else
    # Find uncommented line, if any, and add a leading '#'
    define SYSTEM_REMOUNT_RW
        $(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
    endef
    endif
    TARGET_FINALIZE_HOOKS += SYSTEM_REMOUNT_RW

We must find another solution.

Regards,
Yann E. MORIN.

> ---
>  package/sysvinit/inittab | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/sysvinit/inittab b/package/sysvinit/inittab
> index d3de4a7..fd0d2f0 100644
> --- a/package/sysvinit/inittab
> +++ b/package/sysvinit/inittab
> @@ -5,7 +5,7 @@
>  id:1:initdefault:
>  
>  proc::sysinit:/bin/mount -t proc proc /proc
> -rwmo::sysinit:/bin/mount -o remount,rw / # REMOUNT_ROOTFS_RW
> +rwmo::sysinit:/bin/mount -o remount,rw /
>  dpts::sysinit:/bin/mkdir -p /dev/pts
>  dshm::sysinit:/bin/mkdir -p /dev/shm
>  moun::sysinit:/bin/mount -a
> -- 
> 2.0.4
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Gustavo Zacarias Oct. 21, 2014, 5:25 p.m. UTC | #2
On 10/21/2014 02:15 PM, Yann E. MORIN wrote:

> Gustavo, All,
> 
> On 2014-10-20 16:18 -0300, Gustavo Zacarias spake thusly:
>> It breaks the root rw remount as explained in bug #7442.
>> Thanks to joymarquis@hotmail.com for pointing it out.
>>
>> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
> 
> NAK, because that's what is used to decide whether to remount root RW or
> not (from system/system.mk ):
> 
>     ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
>     # Find commented line, if any, and remove leading '#'s
>     define SYSTEM_REMOUNT_RW
>         $(SED) '/^#.*# REMOUNT_ROOTFS_RW$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
>     endef
>     else
>     # Find uncommented line, if any, and add a leading '#'
>     define SYSTEM_REMOUNT_RW
>         $(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
>     endef
>     endif
>     TARGET_FINALIZE_HOOKS += SYSTEM_REMOUNT_RW
> 
> We must find another solution.

Searching for the comment isn't pretty, i'd just:

rwmo::sysinit:/bin/mount -o remount,rw / (sysvinit)
null::sysinit:/bin/mount -o remount,rw / (skeleton)

And nuke them when the root must be RO by searching for "mount -o
remount,rw /".

But really well done that should all move to an initscript at the S00
order that handles ALL of the filesystems at once in a predictable way
via /etc/fstab, there's no excuse.
Regards.
diff mbox

Patch

diff --git a/package/sysvinit/inittab b/package/sysvinit/inittab
index d3de4a7..fd0d2f0 100644
--- a/package/sysvinit/inittab
+++ b/package/sysvinit/inittab
@@ -5,7 +5,7 @@ 
 id:1:initdefault:
 
 proc::sysinit:/bin/mount -t proc proc /proc
-rwmo::sysinit:/bin/mount -o remount,rw / # REMOUNT_ROOTFS_RW
+rwmo::sysinit:/bin/mount -o remount,rw /
 dpts::sysinit:/bin/mkdir -p /dev/pts
 dshm::sysinit:/bin/mkdir -p /dev/shm
 moun::sysinit:/bin/mount -a