diff mbox

[1/1] package/boost: enable building of boost_log

Message ID 1413811644-28525-1-git-send-email-yannickkiekens@gmail.com
State Accepted
Headers show

Commit Message

Yannick Kiekens Oct. 20, 2014, 1:27 p.m. UTC
Signed-off-by: Yannick Kiekens <yannickkiekens@gmail.com>
---
 package/boost/Config.in | 3 +++
 package/boost/boost.mk  | 4 ++--
 2 files changed, 5 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Oct. 20, 2014, 5:02 p.m. UTC | #1
Yannick, All,

On 2014-10-20 15:27 +0200, Yannick Kiekens spake thusly:
> Signed-off-by: Yannick Kiekens <yannickkiekens@gmail.com>
> ---
>  package/boost/Config.in | 3 +++
>  package/boost/boost.mk  | 4 ++--
>  2 files changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/package/boost/Config.in b/package/boost/Config.in
> index a15b849..5ac1d0e 100644
> --- a/package/boost/Config.in
> +++ b/package/boost/Config.in
> @@ -85,6 +85,9 @@ config BR2_PACKAGE_BOOST_LOCALE
>  comment "boost-locale needs a toolchain w/ wchar"
>  	depends on !BR2_USE_WCHAR
>  
> +config BR2_PACKAGE_BOOST_LOG
> +        bool "boost-log"
> +
>  config BR2_PACKAGE_BOOST_MATH
>  	bool "boost-math"
>  
> diff --git a/package/boost/boost.mk b/package/boost/boost.mk
> index 46a98e8..06969b4 100644
> --- a/package/boost/boost.mk
> +++ b/package/boost/boost.mk
> @@ -25,8 +25,7 @@ HOST_BOOST_FLAGS = --without-icu \
>  
>  # atomic library compile only with upstream version, wait for next release
>  # coroutine breaks on some weak toolchains and it's new for 1.54+
> -# log breaks with some toolchain combinations and it's new for 1.54+

As you remove a comment that warns that log is broken in some cases, it
would be nice if you were to explain why this comment no longer applies.

For example, you could format your commit log as thus (reason totally
made up for the sake of the example, adapt):

    package/boost: enable building of boost_log

    In the current version of boost, boost_log is now considered stable
    and maintained. The failures caused by "some toolchain combinations"
    no longer occur.

    Signed-off-by: [YOU]

    ---
    Tested with these toolchains:
      - uClibc, arm, static only
      - uClibc, x86_64

Note the '---' line: you can add such a line in your commit log, and it
will appear as-is in the mail you send. However, git is smart enough so
that when the maintainer applies the patch, git removes it.

Otherwise, I'm no boost expert, but the patch looks OK.

Regards,
Yann E. MORIN.

> -BOOST_WITHOUT_FLAGS = atomic coroutine log
> +BOOST_WITHOUT_FLAGS = atomic coroutine
>  
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
> @@ -37,6 +36,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH),,graph)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH_PARALLEL),,graph_parallel)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_IOSTREAMS),,iostreams)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOCALE),,locale)
> +BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOG),,log)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MATH),,math)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MPI),,mpi)
>  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PROGRAM_OPTIONS),,program_options)
> -- 
> 1.9.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN Oct. 20, 2014, 5:07 p.m. UTC | #2
Yannick, All,

On 2014-10-20 19:02 +0200, Yann E. MORIN spake thusly:
> On 2014-10-20 15:27 +0200, Yannick Kiekens spake thusly:
[--SNIP--]
> > diff --git a/package/boost/boost.mk b/package/boost/boost.mk
> > index 46a98e8..06969b4 100644
> > --- a/package/boost/boost.mk
> > +++ b/package/boost/boost.mk
> > @@ -25,8 +25,7 @@ HOST_BOOST_FLAGS = --without-icu \
> >  
> >  # atomic library compile only with upstream version, wait for next release
> >  # coroutine breaks on some weak toolchains and it's new for 1.54+
> > -# log breaks with some toolchain combinations and it's new for 1.54+
> 
> As you remove a comment that warns that log is broken in some cases, it
> would be nice if you were to explain why this comment no longer applies.
> 
> For example, you could format your commit log as thus (reason totally
> made up for the sake of the example, adapt):
> 
>     package/boost: enable building of boost_log
> 
>     In the current version of boost, boost_log is now considered stable
>     and maintained. The failures caused by "some toolchain combinations"
>     no longer occur.
> 
>     Signed-off-by: [YOU]
> 
>     ---
>     Tested with these toolchains:
>       - uClibc, arm, static only
>       - uClibc, x86_64
> 
> Note the '---' line: you can add such a line in your commit log, and it
> will appear as-is in the mail you send. However, git is smart enough so
> that when the maintainer applies the patch, git removes it.

Sorry, I meant:
    [...] git removes it, and whatever follows (but keeps the patch, of
    course).

Regards,
Yann E. MORIN.
Yannick Kiekens Oct. 21, 2014, 7:15 a.m. UTC | #3
On Mon, Oct 20, 2014 at 7:07 PM, Yann E. MORIN <yann.morin.1998@free.fr>
wrote:

> Yannick, All,
>
> On 2014-10-20 19:02 +0200, Yann E. MORIN spake thusly:
> > On 2014-10-20 15:27 +0200, Yannick Kiekens spake thusly:
> [--SNIP--]
> > > diff --git a/package/boost/boost.mk b/package/boost/boost.mk
> > > index 46a98e8..06969b4 100644
> > > --- a/package/boost/boost.mk
> > > +++ b/package/boost/boost.mk
> > > @@ -25,8 +25,7 @@ HOST_BOOST_FLAGS = --without-icu \
> > >
> > >  # atomic library compile only with upstream version, wait for next
> release
> > >  # coroutine breaks on some weak toolchains and it's new for 1.54+
> > > -# log breaks with some toolchain combinations and it's new for 1.54+
> >
> > As you remove a comment that warns that log is broken in some cases, it
> > would be nice if you were to explain why this comment no longer applies.
> >
> > For example, you could format your commit log as thus (reason totally
> > made up for the sake of the example, adapt):
> >
> >     package/boost: enable building of boost_log
> >
> >     In the current version of boost, boost_log is now considered stable
> >     and maintained. The failures caused by "some toolchain combinations"
> >     no longer occur.
> >
> >     Signed-off-by: [YOU]
> >
> >     ---
> >     Tested with these toolchains:
> >       - uClibc, arm, static only
> >       - uClibc, x86_64
> >
> > Note the '---' line: you can add such a line in your commit log, and it
> > will appear as-is in the mail you send. However, git is smart enough so
> > that when the maintainer applies the patch, git removes it.
>
> Sorry, I meant:
>     [...] git removes it, and whatever follows (but keeps the patch, of
>     course).
>
> Regards,
> Yann E. MORIN.
>
>

​We use boost_log at work on x86_64 and armv7, we never had trouble with it.
It is possible boost_log 1.56 still does not work on some toolchain
combinations​, as mentioned in git
commit 611dfe6cb55ed72d7df3b7c102f4a723248a4037

​I could reformat the patch to whitelist boost_log on known configurations
Any opnion on that?

Regards,
Yannick Kiekens​
Thomas Petazzoni Oct. 21, 2014, 9:56 a.m. UTC | #4
Dear Yannick Kiekens,

On Tue, 21 Oct 2014 09:15:24 +0200, Yannick Kiekens wrote:

> ​We use boost_log at work on x86_64 and armv7, we never had trouble with it.
> It is possible boost_log 1.56 still does not work on some toolchain
> combinations​, as mentioned in git
> commit 611dfe6cb55ed72d7df3b7c102f4a723248a4037
> 
> ​I could reformat the patch to whitelist boost_log on known configurations
> Any opnion on that?

Can you try looking at
http://autobuild.buildroot.net/results/c26/c26498f1a4e6bcbc3a2dfce6a51fa7d21b72f21f/build-end.log,
which is the issue reported in commit
611dfe6cb55ed72d7df3b7c102f4a723248a4037 ?

Best regards,

Thomas
Thomas Petazzoni March 15, 2015, 4:49 p.m. UTC | #5
Dear Yannick Kiekens,

On Mon, 20 Oct 2014 15:27:24 +0200, Yannick Kiekens wrote:
> Signed-off-by: Yannick Kiekens <yannickkiekens@gmail.com>
> ---
>  package/boost/Config.in | 3 +++
>  package/boost/boost.mk  | 4 ++--
>  2 files changed, 5 insertions(+), 2 deletions(-)

Applied, thanks!

Thomas
diff mbox

Patch

diff --git a/package/boost/Config.in b/package/boost/Config.in
index a15b849..5ac1d0e 100644
--- a/package/boost/Config.in
+++ b/package/boost/Config.in
@@ -85,6 +85,9 @@  config BR2_PACKAGE_BOOST_LOCALE
 comment "boost-locale needs a toolchain w/ wchar"
 	depends on !BR2_USE_WCHAR
 
+config BR2_PACKAGE_BOOST_LOG
+        bool "boost-log"
+
 config BR2_PACKAGE_BOOST_MATH
 	bool "boost-math"
 
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 46a98e8..06969b4 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -25,8 +25,7 @@  HOST_BOOST_FLAGS = --without-icu \
 
 # atomic library compile only with upstream version, wait for next release
 # coroutine breaks on some weak toolchains and it's new for 1.54+
-# log breaks with some toolchain combinations and it's new for 1.54+
-BOOST_WITHOUT_FLAGS = atomic coroutine log
+BOOST_WITHOUT_FLAGS = atomic coroutine
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
@@ -37,6 +36,7 @@  BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH),,graph)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH_PARALLEL),,graph_parallel)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_IOSTREAMS),,iostreams)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOCALE),,locale)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOG),,log)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MATH),,math)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MPI),,mpi)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PROGRAM_OPTIONS),,program_options)