diff mbox

[v3,2/3] gst-ffmpeg: add --pkg-config to internal libav configure options

Message ID 1413142206-30581-2-git-send-email-danomimanchego123@gmail.com
State Superseded
Headers show

Commit Message

Danomi Manchego Oct. 12, 2014, 7:30 p.m. UTC
The internal copy of libav in gst-ffmpeg does not understand the
PKG_CONFIG env variable, so it throws a line like this at the end
of its configuration:

WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found, library detection may fail.

This patch adds the --pkg-config to let libav know where it is.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>

---

This is basically the same problem suffered by ffmpeg, fixed in
commit a9a5a8159937cbc5e472cbd0b144d596b85a3386.
---
 package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Luca Ceresoli Oct. 13, 2014, 1:37 p.m. UTC | #1
Dear Danomi,

Danomi Manchego wrote:
> The internal copy of libav in gst-ffmpeg does not understand the
> PKG_CONFIG env variable, so it throws a line like this at the end
> of its configuration:
>
> WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found, library detection may fail.

I tried to reproduce the issue, but the message didn't show up.
Can you chare a defconfig to reproduce the issue?

Thanks.
Danomi Manchego Oct. 13, 2014, 4:26 p.m. UTC | #2
Luca,

On Mon, Oct 13, 2014 at 9:37 AM, Luca Ceresoli <luca@lucaceresoli.net> wrote:
> Dear Danomi,
>
> Danomi Manchego wrote:
>>
>> The internal copy of libav in gst-ffmpeg does not understand the
>> PKG_CONFIG env variable, so it throws a line like this at the end
>> of its configuration:
>>
>> WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found,
>> library detection may fail.
>
>
> I tried to reproduce the issue, but the message didn't show up.
> Can you chare a defconfig to reproduce the issue?

I've seen this in a few different configurations, so I didn't think
that you needed anything special.  But anyway, here is one possible
defconfig:

    BR2_arm=y
    BR2_cortex_a8=y
    BR2_ARM_FPU_NEON=y
    BR2_ENABLE_DEBUG=y
    BR2_TOOLCHAIN_EXTERNAL=y
    BR2_PACKAGE_GSTREAMER=y
    BR2_PACKAGE_GST_FFMPEG=y
    # BR2_TARGET_ROOTFS_TAR is not set

Look at the very end of the configure step, just before the build step:

    License: GPL version 2 or later
    Creating config.mak and config.h...

    WARNING: xxxx/output/host/usr/bin/arm-none-linux-gnueabi-pkg-config
not found, library detection may fail.
    configure: WARNING: unrecognized options: --disable-doc,
--disable-docs, --disable-documentation, --with-xmlto, --with-fop,
--enable-ipv6
    configure: *** Orc acceleration disabled.  Requires Orc >= 0.4.6,
which was not found.  Slower code paths will be used.

    >>> gst-ffmpeg 0.10.13 Building

Danomi -
Luca Ceresoli Oct. 14, 2014, 8:59 a.m. UTC | #3
Dear Danomi,

Danomi Manchego wrote:
> Luca,
>
> On Mon, Oct 13, 2014 at 9:37 AM, Luca Ceresoli <luca@lucaceresoli.net> wrote:
>> Dear Danomi,
>>
>> Danomi Manchego wrote:
>>>
>>> The internal copy of libav in gst-ffmpeg does not understand the
>>> PKG_CONFIG env variable, so it throws a line like this at the end
>>> of its configuration:
>>>
>>> WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found,
>>> library detection may fail.
>>
>>
>> I tried to reproduce the issue, but the message didn't show up.
>> Can you chare a defconfig to reproduce the issue?
>
> I've seen this in a few different configurations, so I didn't think
> that you needed anything special.  But anyway, here is one possible
> defconfig:
>
>      BR2_arm=y
>      BR2_cortex_a8=y
>      BR2_ARM_FPU_NEON=y
>      BR2_ENABLE_DEBUG=y
>      BR2_TOOLCHAIN_EXTERNAL=y
>      BR2_PACKAGE_GSTREAMER=y
>      BR2_PACKAGE_GST_FFMPEG=y
>      # BR2_TARGET_ROOTFS_TAR is not set
>
> Look at the very end of the configure step, just before the build step:
>
>      License: GPL version 2 or later
>      Creating config.mak and config.h...
>
>      WARNING: xxxx/output/host/usr/bin/arm-none-linux-gnueabi-pkg-config
> not found, library detection may fail.

Reproduced with this config, and disappeared applying your patch.

Tested-by: Luca Ceresoli <luca@lucaceresoli.net>
Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net>
Yann E. MORIN Oct. 17, 2014, 9:24 p.m. UTC | #4
Danomi, All,

On 2014-10-12 15:30 -0400, Danomi Manchego spake thusly:
> The internal copy of libav in gst-ffmpeg does not understand the
> PKG_CONFIG env variable, so it throws a line like this at the end
> of its configuration:
> 
> WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found, library detection may fail.

Instead of fixing just that one package, shouldn't we provide a symlink:
    TUPLE-pkg-config  ->  pkg-config

This way, all packages that expect a cross-pkg-config will work without
customisation.

Thomas, thoughts?

Regards,
Yann E. MORIN.

> This patch adds the --pkg-config to let libav know where it is.
> 
> Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
> 
> ---
> 
> This is basically the same problem suffered by ffmpeg, fixed in
> commit a9a5a8159937cbc5e472cbd0b144d596b85a3386.
> ---
>  package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk b/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
> index af3e880..11f28dc 100644
> --- a/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
> +++ b/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
> @@ -22,7 +22,8 @@ endif
>  
>  GST_FFMPEG_CONF_EXTRA_OPTS = \
>  		--cross-prefix=$(TARGET_CROSS) \
> -		--target-os=linux
> +		--target-os=linux \
> +		--pkg-config='$(PKG_CONFIG_HOST_BINARY)'
>  
>  ifeq ($(BR2_PACKAGE_ZLIB),y)
>  GST_FFMPEG_CONF_EXTRA_OPTS += --enable-zlib
> -- 
> 1.9.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Bernd Kuhls Oct. 17, 2014, 9:39 p.m. UTC | #5
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote in 
news:20141017212453.GI3971@free.fr:

> Instead of fixing just that one package, shouldn't we provide a symlink:
>     TUPLE-pkg-config  ->  pkg-config
> 
> This way, all packages that expect a cross-pkg-config will work without
> customisation.
> 
> Thomas, thoughts?

Hi,

I had the same idea back in January, but Thomas did not like it ;)
http://patchwork.ozlabs.org/patch/312273/

Regards, Bernd
Yann E. MORIN Oct. 17, 2014, 10:46 p.m. UTC | #6
Bernd, All,

On 2014-10-17 23:39 +0200, Bernd Kuhls spake thusly:
> "Yann E. MORIN" <yann.morin.1998@free.fr> wrote in 
> news:20141017212453.GI3971@free.fr:
> 
> > Instead of fixing just that one package, shouldn't we provide a symlink:
> >     TUPLE-pkg-config  ->  pkg-config
> > 
> > This way, all packages that expect a cross-pkg-config will work without
> > customisation.
> > 
> > Thomas, thoughts?
> 
> Hi,
> 
> I had the same idea back in January, but Thomas did not like it ;)
> http://patchwork.ozlabs.org/patch/312273/

Damned! :-)

Regards,
Yann E. MORIN.
Thomas Petazzoni Oct. 18, 2014, 11:51 a.m. UTC | #7
Dear Yann E. MORIN,

On Fri, 17 Oct 2014 23:24:53 +0200, Yann E. MORIN wrote:

> > WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found, library detection may fail.
> 
> Instead of fixing just that one package, shouldn't we provide a symlink:
>     TUPLE-pkg-config  ->  pkg-config
> 
> This way, all packages that expect a cross-pkg-config will work without
> customisation.
> 
> Thomas, thoughts?

I don't have a very strong opinion here. How many packages expect
TUPLE-pkg-config instead of pkg-config? I'm not sure it's really the
majority, and if it's not, I prefer to keep handling this on a
per-package basis rather than adding a symlink.

Thomas
Arnout Vandecappelle Oct. 18, 2014, 1:14 p.m. UTC | #8
On 18/10/14 13:51, Thomas Petazzoni wrote:
> Dear Yann E. MORIN,
> 
> On Fri, 17 Oct 2014 23:24:53 +0200, Yann E. MORIN wrote:
> 
>>> WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found, library detection may fail.
>>
>> Instead of fixing just that one package, shouldn't we provide a symlink:
>>     TUPLE-pkg-config  ->  pkg-config
>>
>> This way, all packages that expect a cross-pkg-config will work without
>> customisation.
>>
>> Thomas, thoughts?
> 
> I don't have a very strong opinion here. How many packages expect
> TUPLE-pkg-config instead of pkg-config? I'm not sure it's really the
> majority, and if it's not, I prefer to keep handling this on a
> per-package basis rather than adding a symlink.

 Actually, even if it is just two packages that use it, I think it is worthwhile
to add the symlink. It is one less thing to solve when adding a package.

 Regards,
 Arnout
diff mbox

Patch

diff --git a/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk b/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
index af3e880..11f28dc 100644
--- a/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
+++ b/package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
@@ -22,7 +22,8 @@  endif
 
 GST_FFMPEG_CONF_EXTRA_OPTS = \
 		--cross-prefix=$(TARGET_CROSS) \
-		--target-os=linux
+		--target-os=linux \
+		--pkg-config='$(PKG_CONFIG_HOST_BINARY)'
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 GST_FFMPEG_CONF_EXTRA_OPTS += --enable-zlib