diff mbox

[1/1] protobuf: bump version to 2.6.0

Message ID 1412214757-3948-1-git-send-email-matthew.weber@rockwellcollins.com
State Superseded
Headers show

Commit Message

Matt Weber Oct. 2, 2014, 1:52 a.m. UTC
* Adds powerpc architecture support
* Changes to the new github upstream site
* Updates the license filename

Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
---
 package/protobuf/Config.in   |    7 +++----
 package/protobuf/protobuf.mk |    6 +++---
 2 files changed, 6 insertions(+), 7 deletions(-)

Comments

Peter Korsgaard Oct. 2, 2014, 6:01 p.m. UTC | #1
>>>>> "Matt" == Matt Weber <matthew.weber@rockwellcollins.com> writes:

 > * Adds powerpc architecture support
 > * Changes to the new github upstream site
 > * Updates the license filename

 > Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
 > ---

 >  PROTOBUF_LICENSE = BSD-3c
 > -PROTOBUF_LICENSE_FILES = COPYING.txt
 > +PROTOBUF_LICENSE_FILES = LICENSE

Huh?

make protobuf-legal-info
cat: /home/peko/source/buildroot/output/build/protobuf-2.6.0/LICENSE: No such file or directory

I see there's still a COPYING.txt
Matt Weber Oct. 2, 2014, 6:06 p.m. UTC | #2
Peter,

On Thu, Oct 2, 2014 at 1:01 PM, Peter Korsgaard <jacmet@uclibc.org> wrote:
>>>>>> "Matt" == Matt Weber <matthew.weber@rockwellcollins.com> writes:
>
>  > * Adds powerpc architecture support
>  > * Changes to the new github upstream site
>  > * Updates the license filename
>
>  > Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
>  > ---
>
>  >  PROTOBUF_LICENSE = BSD-3c
>  > -PROTOBUF_LICENSE_FILES = COPYING.txt
>  > +PROTOBUF_LICENSE_FILES = LICENSE
>
> Huh?

Oh sorry, I looked at the latest in there repo instead of their tag
for 2.6.0 (so 2.7 will have that).  I'll update and resubmit.

>
> make protobuf-legal-info
> cat: /home/peko/source/buildroot/output/build/protobuf-2.6.0/LICENSE: No such file or directory
>
> I see there's still a COPYING.txt
>
> --
> Bye, Peter Korsgaard
diff mbox

Patch

diff --git a/package/protobuf/Config.in b/package/protobuf/Config.in
index 6015b13..e45ed14 100644
--- a/package/protobuf/Config.in
+++ b/package/protobuf/Config.in
@@ -3,17 +3,16 @@  config BR2_PACKAGE_PROTOBUF
 	depends on BR2_INSTALL_LIBSTDCPP
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	# See src/google/protobuf/stubs/platform_macros.h for supported archs.
-	# PowerPC doesn't actually work.
-	depends on BR2_arm || BR2_i386 || BR2_mipsel || BR2_x86_64
+	depends on BR2_arm || BR2_i386 || BR2_mipsel || BR2_x86_64 || BR2_powerpc
 	# host-protobuf only builds on certain architectures
 	depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
 	help
 	  Protocol buffers are Google's language-neutral, platform-neutral,
 	  extensible mechanism for serializing structured data.
 
-	  http://code.google.com/p/protobuf/
+	  https://github.com/google/protobuf/
 
 comment "protobuf needs a toolchain w/ C++, threads"
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
-	depends on BR2_arm || BR2_i386 || BR2_mipsel || BR2_x86_64
+	depends on BR2_arm || BR2_i386 || BR2_mipsel || BR2_x86_64 || BR2_powerpc
 	depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
index f5e11df..761b315 100644
--- a/package/protobuf/protobuf.mk
+++ b/package/protobuf/protobuf.mk
@@ -4,10 +4,10 @@ 
 #
 ################################################################################
 
-PROTOBUF_VERSION = 2.5.0
-PROTOBUF_SITE = http://protobuf.googlecode.com/files
+PROTOBUF_VERSION = 2.6.0
+PROTOBUF_SITE = https://github.com/google/protobuf/releases/download/v$(PROTOBUF_VERSION)/
 PROTOBUF_LICENSE = BSD-3c
-PROTOBUF_LICENSE_FILES = COPYING.txt
+PROTOBUF_LICENSE_FILES = LICENSE
 
 # N.B. Need to use host protoc during cross compilation.
 PROTOBUF_DEPENDENCIES = host-protobuf