diff mbox

[4/6] python-configshell-fb: new package

Message ID 1410953999-16520-5-git-send-email-cvubrugier@fastmail.fm
State Superseded
Headers show

Commit Message

Christophe Vu-Brugier Sept. 17, 2014, 11:39 a.m. UTC
configshell-fb is a Python library that provides a framework for
building simple but nice CLI-based applications.

Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm>
---
 package/Config.in                                      |  1 +
 package/python-configshell-fb/Config.in                | 11 +++++++++++
 package/python-configshell-fb/python-configshell-fb.mk | 14 ++++++++++++++
 3 files changed, 26 insertions(+)
 create mode 100644 package/python-configshell-fb/Config.in
 create mode 100644 package/python-configshell-fb/python-configshell-fb.mk

Comments

Thomas Petazzoni Sept. 17, 2014, 12:03 p.m. UTC | #1
Dear Christophe Vu-Brugier,

On Wed, 17 Sep 2014 13:39:57 +0200, Christophe Vu-Brugier wrote:

> diff --git a/package/python-configshell-fb/Config.in b/package/python-configshell-fb/Config.in
> new file mode 100644
> index 0000000..05de585
> --- /dev/null
> +++ b/package/python-configshell-fb/Config.in
> @@ -0,0 +1,11 @@
> +config BR2_PACKAGE_PYTHON_CONFIGSHELL_FB
> +	bool "python-configshell-fb"
> +	depends on BR2_PACKAGE_PYTHON

Ok, I just read the README file for this package, and it explains that
the setup.py script runs 2to3 to convert the package source code to
Python 3 if needed. Most likely our installation of 2to3 is broken.

The patch anyway looks good to me, so:

Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 7447036..096d8c6 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -473,6 +473,7 @@  menu "external python modules"
 	source "package/python-bottle/Config.in"
 	source "package/python-cffi/Config.in"
 	source "package/python-configobj/Config.in"
+	source "package/python-configshell-fb/Config.in"
 	source "package/python-crc16/Config.in"
 	source "package/python-daemon/Config.in"
 	source "package/python-dialog/Config.in"
diff --git a/package/python-configshell-fb/Config.in b/package/python-configshell-fb/Config.in
new file mode 100644
index 0000000..05de585
--- /dev/null
+++ b/package/python-configshell-fb/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_PYTHON_CONFIGSHELL_FB
+	bool "python-configshell-fb"
+	depends on BR2_PACKAGE_PYTHON
+	select BR2_PACKAGE_PYTHON_PYPARSING
+	select BR2_PACKAGE_PYTHON_READLINE
+	select BR2_PACKAGE_PYTHON_URWID
+	help
+	  configshell-fb is a Python library that provides a framework
+	  for building simple but nice CLI-based applications.
+
+	  https://github.com/agrover/configshell-fb
diff --git a/package/python-configshell-fb/python-configshell-fb.mk b/package/python-configshell-fb/python-configshell-fb.mk
new file mode 100644
index 0000000..64b27fe
--- /dev/null
+++ b/package/python-configshell-fb/python-configshell-fb.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-configshell-fb
+#
+################################################################################
+
+PYTHON_CONFIGSHELL_FB_VERSION = v1.1.fb14
+PYTHON_CONFIGSHELL_FB_SITE = $(call github,agrover,configshell-fb,$(PYTHON_CONFIGSHELL_FB_VERSION))
+PYTHON_CONFIGSHELL_FB_LICENSE = Apache-2.0
+PYTHON_CONFIGSHELL_FB_LICENSE_FILES = COPYING
+PYTHON_CONFIGSHELL_FB_SETUP_TYPE = setuptools
+PYTHON_CONFIGSHELL_FB_DEPENDENCIES = python-pyparsing python-urwid
+
+$(eval $(python-package))