diff mbox

sqlcipher: fix static linking

Message ID 1410897150-24431-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Commit 58a41c2f68001b3ef25356cd3f1a79b9e46e7157
Headers show

Commit Message

Gustavo Zacarias Sept. 16, 2014, 7:52 p.m. UTC
It uses openssl which for buildroot mandates libz, but doesn't link
against it so it fails. Fixes:
http://autobuild.buildroot.net/results/514/5145617f7c3cece933c845da3c9836d80d062bb6/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/sqlcipher/sqlcipher.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Sept. 16, 2014, 9:07 p.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 > It uses openssl which for buildroot mandates libz, but doesn't link
 > against it so it fails. Fixes:
 > http://autobuild.buildroot.net/results/514/5145617f7c3cece933c845da3c9836d80d062bb6/

 > Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>

Committed, thanks.
diff mbox

Patch

diff --git a/package/sqlcipher/sqlcipher.mk b/package/sqlcipher/sqlcipher.mk
index bae59bb..7c93620 100644
--- a/package/sqlcipher/sqlcipher.mk
+++ b/package/sqlcipher/sqlcipher.mk
@@ -19,7 +19,7 @@  SQLCIPHER_CONF_OPT = \
 	--localstatedir=/var
 
 SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
-SQLCIPHER_LDFLAGS += -lcrypto
+SQLCIPHER_LDFLAGS += -lcrypto -lz
 
 ifneq ($(BR2_LARGEFILE),y)
 # the sqlite configure script fails to define SQLITE_DISABLE_LFS when