diff mbox

[1/2] nftables: fix build in static scenarios

Message ID 1408196148-15128-1-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 34e3857d9855197bb52a4056ad1f2a95a67d08f8
Headers show

Commit Message

Thomas Petazzoni Aug. 16, 2014, 1:35 p.m. UTC
When linking against readline, it forgets to link against ncurses,
which is needed by readline. Fix this by passing LIBS="-lcurses" to
the configure script.

Fixes:

  http://autobuild.buildroot.org/results/98b/98b707ffdeeb1cda94b7c1019ef29cf5fd7db8bf/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/nftables/nftables.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Aug. 17, 2014, 7:12 a.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > When linking against readline, it forgets to link against ncurses,
 > which is needed by readline. Fix this by passing LIBS="-lcurses" to
 > the configure script.

 > Fixes:

 >   http://autobuild.buildroot.org/results/98b/98b707ffdeeb1cda94b7c1019ef29cf5fd7db8bf/

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/nftables/nftables.mk b/package/nftables/nftables.mk
index b25e8f2..b3abbc0 100644
--- a/package/nftables/nftables.mk
+++ b/package/nftables/nftables.mk
@@ -12,6 +12,8 @@  NFTABLES_DEPENDENCIES = gmp libmnl libnftnl readline host-bison host-flex \
 NFTABLES_LICENSE = GPLv2
 NFTABLES_LICENSE_FILES = COPYING
 
-NFTABLES_CONF_ENV = ac_cv_prog_CONFIG_PDF=no
+NFTABLES_CONF_ENV = \
+	ac_cv_prog_CONFIG_PDF=no \
+	LIBS="-lncurses"
 
 $(eval $(autotools-package))