diff mbox

qt5: Add an option to select default platform

Message ID 1404466571-27586-1-git-send-email-jezz@sysmic.org
State Superseded
Headers show

Commit Message

Jérôme Pouiller July 4, 2014, 9:36 a.m. UTC
Whithout this path, default platform is automaticaly set (generally
set to "eglfs" as defined in
qt5base/mkspecs/devices/common/linux_device_pre.conf:1). This choice
is not always what the user would like. Thus, user have to manually
appends "-platform <BACKEND>" to command line when running any qt5
application.

This patch allows user to choose default platform explicitly.

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
 package/qt5/qt5base/Config.in  | 43 ++++++++++++++++++++++++++++++++++++++++++
 package/qt5/qt5base/qt5base.mk |  6 ++++++
 2 files changed, 49 insertions(+)

Comments

Thomas Petazzoni July 4, 2014, 11:02 a.m. UTC | #1
Dear Jérôme Pouiller,

On Fri,  4 Jul 2014 11:36:11 +0200, Jérôme Pouiller wrote:

> +choice
> +	prompt "default graphical platform"
> +	default BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
> +	help
> +	  Notice you may choose platform at runtime using -platform (-platform
> +	  help to get list of compiled platforms).
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
> +	bool "minimal"

Maybe some help text would be appropriate here...

> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_OFFSCREEN
> +	bool "offscreen"

... and here, to describe what those platforms are.

Are they actually useful in practice? What do they do?

> +QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL),-qpa minimalb)

is "minimalb" intended here, as opposed to "minimal"?

Thanks!

Thomas
Arnout Vandecappelle July 4, 2014, 8:03 p.m. UTC | #2
On 04/07/14 11:36, Jérôme Pouiller wrote:
> Whithout this path, default platform is automaticaly set (generally
> set to "eglfs" as defined in
> qt5base/mkspecs/devices/common/linux_device_pre.conf:1). This choice
> is not always what the user would like. Thus, user have to manually
> appends "-platform <BACKEND>" to command line when running any qt5
> application.
> 
> This patch allows user to choose default platform explicitly.
> 
> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
> ---
>  package/qt5/qt5base/Config.in  | 43 ++++++++++++++++++++++++++++++++++++++++++
>  package/qt5/qt5base/qt5base.mk |  6 ++++++
>  2 files changed, 49 insertions(+)
> 
> diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
> index 70ddcd3..5fa7c02 100644
> --- a/package/qt5/qt5base/Config.in
> +++ b/package/qt5/qt5base/Config.in
> @@ -144,6 +144,49 @@ config BR2_PACKAGE_QT5BASE_EGLFS
>  comment "eglfs backend available if OpenGLES and EGL are enabled"
>  	depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES
>  
> +choice
> +	prompt "default graphical platform"
> +	default BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL

 I wonder if it is really worthwhile to make this a choice. That means that
whenever a new platform is added (wayland, vnc, ...) we have to update the
choice. And one could imagine a user implementing their own QPA plugin...

 So I would propose to make this a string, default to empty, and when it's empty
don't pass the -qpa option.

 Help text could be something like

	  Choose the default platform abstraction to use for graphical
	  application. If this is empty, the default for your architecture
	  will be used (usually this is eglfs).

	  You can get a list of supported platform by running a Qt application
	  with the option "-platform help" on your target. You can choose a
	  different platform at runtime with the -platform option.



 Regards,
 Arnout

> +	help
> +	  Notice you may choose platform at runtime using -platform (-platform
> +	  help to get list of compiled platforms).
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
> +	bool "minimal"
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_OFFSCREEN
> +	bool "offscreen"
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_LINUXFB
> +	bool "linuxfb"
> +	depends on BR2_PACKAGE_QT5BASE_LINUXFB
> +
> +comment 'linuxfb needs linuxfb support enabled'
> +	depends on !BR2_PACKAGE_QT5BASE_LINUXFB
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_DIRECTFB
> +	bool "directfb"
> +	depends on BR2_PACKAGE_QT5BASE_DIRECTFB
> +
> +comment 'directfb needs directfb support enabled'
> +	depends on !BR2_PACKAGE_QT5BASE_DIRECTFB
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_XCB
> +	bool "xcb"
> +	depends on BR2_PACKAGE_QT5BASE_XCB
> +
> +comment 'xcb needs X.org XCB support enabled'
> +	depends on !BR2_PACKAGE_QT5BASE_XCB
> +
> +config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_EGLFS
> +	bool "eglfs"
> +	depends on BR2_PACKAGE_QT5BASE_EGLFS
> +
> +comment 'eglfs needs eglfs support enabled'
> +	depends on !BR2_PACKAGE_QT5BASE_EGLFS
> +
> +endchoice
> +
>  config BR2_PACKAGE_QT5BASE_PRINTSUPPORT
>  	bool "print support module"
>  	select BR2_PACKAGE_QT5BASE_WIDGETS
> diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
> index 618251e..9018ff8 100644
> --- a/package/qt5/qt5base/qt5base.mk
> +++ b/package/qt5/qt5base/qt5base.mk
> @@ -96,6 +96,12 @@ else
>  QT5BASE_CONFIGURE_OPTS += -no-xcb
>  endif
>  
> +QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL),-qpa minimalb)
> +QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_OFFSCREEN),-qpa offscreen)
> +QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_LINUXFB),-qpa linuxfb)
> +QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_XCB),-qpa xcb)
> +QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_EGLFS),-qpa eglfs)
> +
>  ifeq ($(BR2_PACKAGE_QT5BASE_EGLFS),y)
>  QT5BASE_CONFIGURE_OPTS += -opengl es2 -eglfs
>  QT5BASE_DEPENDENCIES   += libgles libegl
>
Jérôme Pouiller July 7, 2014, 7:58 a.m. UTC | #3
Hello Arnout,

On Friday 04 July 2014 22:03:09 Arnout Vandecappelle wrote:
> On 04/07/14 11:36, Jérôme Pouiller wrote:
> > Whithout this path, default platform is automaticaly set (generally
> > set to "eglfs" as defined in
> > qt5base/mkspecs/devices/common/linux_device_pre.conf:1). This choice
> > is not always what the user would like. Thus, user have to manually
> > appends "-platform <BACKEND>" to command line when running any qt5
> > application.
> > 
> > This patch allows user to choose default platform explicitly.
> > 
> > Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
> > ---
> > 
> >  package/qt5/qt5base/Config.in  | 43
> >  ++++++++++++++++++++++++++++++++++++++++++
> >  package/qt5/qt5base/qt5base.mk |  6 ++++++
> >  2 files changed, 49 insertions(+)
> > 
> > diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
> > index 70ddcd3..5fa7c02 100644
> > --- a/package/qt5/qt5base/Config.in
> > +++ b/package/qt5/qt5base/Config.in
> > @@ -144,6 +144,49 @@ config BR2_PACKAGE_QT5BASE_EGLFS
> > 
> >  comment "eglfs backend available if OpenGLES and EGL are enabled"
> >  
> >  	depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES
> > 
> > +choice
> > +	prompt "default graphical platform"
> > +	default BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
> 
>  I wonder if it is really worthwhile to make this a choice. That means that
> whenever a new platform is added (wayland, vnc, ...) we have to update the
> choice. And one could imagine a user implementing their own QPA plugin...
> 
>  So I would propose to make this a string, default to empty, and when it's
> empty don't pass the -qpa option.
I have no opinion on that. If nobody has any arguments against, I am going to 
implement this idea.
Yann E. MORIN July 15, 2014, 8:30 p.m. UTC | #4
Jérôme, All,

On 2014-07-07 09:58 +0200, Jérôme Pouiller spake thusly:
> On Friday 04 July 2014 22:03:09 Arnout Vandecappelle wrote:
> > On 04/07/14 11:36, Jérôme Pouiller wrote:
> > > Whithout this path, default platform is automaticaly set (generally
> > > set to "eglfs" as defined in
> > > qt5base/mkspecs/devices/common/linux_device_pre.conf:1). This choice
> > > is not always what the user would like. Thus, user have to manually
> > > appends "-platform <BACKEND>" to command line when running any qt5
> > > application.
> > > 
> > > This patch allows user to choose default platform explicitly.
> > > 
> > > Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
> > > ---
> > > 
> > >  package/qt5/qt5base/Config.in  | 43
> > >  ++++++++++++++++++++++++++++++++++++++++++
> > >  package/qt5/qt5base/qt5base.mk |  6 ++++++
> > >  2 files changed, 49 insertions(+)
> > > 
> > > diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
> > > index 70ddcd3..5fa7c02 100644
> > > --- a/package/qt5/qt5base/Config.in
> > > +++ b/package/qt5/qt5base/Config.in
> > > @@ -144,6 +144,49 @@ config BR2_PACKAGE_QT5BASE_EGLFS
> > > 
> > >  comment "eglfs backend available if OpenGLES and EGL are enabled"
> > >  
> > >  	depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES
> > > 
> > > +choice
> > > +	prompt "default graphical platform"
> > > +	default BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
> > 
> >  I wonder if it is really worthwhile to make this a choice. That means that
> > whenever a new platform is added (wayland, vnc, ...) we have to update the
> > choice. And one could imagine a user implementing their own QPA plugin...
> > 
> >  So I would propose to make this a string, default to empty, and when it's
> > empty don't pass the -qpa option.
> I have no opinion on that. If nobody has any arguments against, I am going to 
> implement this idea.

Yes, I concur with Arnout: that would be a better solution.

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 70ddcd3..5fa7c02 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -144,6 +144,49 @@  config BR2_PACKAGE_QT5BASE_EGLFS
 comment "eglfs backend available if OpenGLES and EGL are enabled"
 	depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES
 
+choice
+	prompt "default graphical platform"
+	default BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
+	help
+	  Notice you may choose platform at runtime using -platform (-platform
+	  help to get list of compiled platforms).
+
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL
+	bool "minimal"
+
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_OFFSCREEN
+	bool "offscreen"
+
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_LINUXFB
+	bool "linuxfb"
+	depends on BR2_PACKAGE_QT5BASE_LINUXFB
+
+comment 'linuxfb needs linuxfb support enabled'
+	depends on !BR2_PACKAGE_QT5BASE_LINUXFB
+
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_DIRECTFB
+	bool "directfb"
+	depends on BR2_PACKAGE_QT5BASE_DIRECTFB
+
+comment 'directfb needs directfb support enabled'
+	depends on !BR2_PACKAGE_QT5BASE_DIRECTFB
+
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_XCB
+	bool "xcb"
+	depends on BR2_PACKAGE_QT5BASE_XCB
+
+comment 'xcb needs X.org XCB support enabled'
+	depends on !BR2_PACKAGE_QT5BASE_XCB
+
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA_EGLFS
+	bool "eglfs"
+	depends on BR2_PACKAGE_QT5BASE_EGLFS
+
+comment 'eglfs needs eglfs support enabled'
+	depends on !BR2_PACKAGE_QT5BASE_EGLFS
+
+endchoice
+
 config BR2_PACKAGE_QT5BASE_PRINTSUPPORT
 	bool "print support module"
 	select BR2_PACKAGE_QT5BASE_WIDGETS
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 618251e..9018ff8 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -96,6 +96,12 @@  else
 QT5BASE_CONFIGURE_OPTS += -no-xcb
 endif
 
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_MINIMAL),-qpa minimalb)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_OFFSCREEN),-qpa offscreen)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_LINUXFB),-qpa linuxfb)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_XCB),-qpa xcb)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DEFAULT_QPA_EGLFS),-qpa eglfs)
+
 ifeq ($(BR2_PACKAGE_QT5BASE_EGLFS),y)
 QT5BASE_CONFIGURE_OPTS += -opengl es2 -eglfs
 QT5BASE_DEPENDENCIES   += libgles libegl