diff mbox

wget: Depends on libuuid

Message ID 1404206129-27696-1-git-send-email-a.potashev@geoscan.aero
State Superseded
Headers show

Commit Message

Alexander Potashev July 1, 2014, 9:15 a.m. UTC
Signed-off-by: Alexander Potashev <a.potashev@geoscan.aero>
---
 package/wget/Config.in | 2 ++
 1 file changed, 2 insertions(+)

Comments

Baruch Siach July 1, 2014, 9:32 a.m. UTC | #1
Hi Alexander,

On Tue, Jul 01, 2014 at 01:15:29PM +0400, Alexander Potashev wrote:
> Signed-off-by: Alexander Potashev <a.potashev@geoscan.aero>
> ---
>  package/wget/Config.in | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/wget/Config.in b/package/wget/Config.in
> index 26a2019..fc7ee26 100644
> --- a/package/wget/Config.in
> +++ b/package/wget/Config.in
> @@ -3,6 +3,8 @@ config BR2_PACKAGE_WGET
>  	# fork()
>  	depends on BR2_USE_MMU
>  	depends on BR2_USE_WCHAR
> +	select BR2_PACKAGE_UTIL_LINUX
> +	select BR2_PACKAGE_UTIL_LINUX_LIBUUID

Care to explain why this is needed?

Also, you forgot to copy here the BR2_LARGEFILE dependency of util-linux.

baruch

>  	help
>  	  Network utility to retrieve files from http, https and ftp.
Thomas Petazzoni July 1, 2014, 9:35 a.m. UTC | #2
Dear Alexander Potashev,

On Tue,  1 Jul 2014 13:15:29 +0400, Alexander Potashev wrote:
> Signed-off-by: Alexander Potashev <a.potashev@geoscan.aero>
> ---
>  package/wget/Config.in | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/wget/Config.in b/package/wget/Config.in
> index 26a2019..fc7ee26 100644
> --- a/package/wget/Config.in
> +++ b/package/wget/Config.in
> @@ -3,6 +3,8 @@ config BR2_PACKAGE_WGET
>  	# fork()
>  	depends on BR2_USE_MMU
>  	depends on BR2_USE_WCHAR
> +	select BR2_PACKAGE_UTIL_LINUX
> +	select BR2_PACKAGE_UTIL_LINUX_LIBUUID
>  	help
>  	  Network utility to retrieve files from http, https and ftp.

I don't think libuuid is a mandatory dependency of wget, and if it was,
your patch would not be sufficient, because it does not add
'util-linux' to WGET_DEPENDENCIES.

However, it indeed seems to be a possible optional dependency of wget,
in which case what you want is the following addition in wget.mk:

ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
WGET_DEPENDENCIES += util-linux
endif

Best regards,

Thomas
Baruch Siach July 1, 2014, 10:07 a.m. UTC | #3
Hi Alexander,
On Tue, Jul 01, 2014 at 01:55:35PM +0400, Alexander Potashev wrote:
> В письме от 1 июля 2014 11:35:49 пользователь Thomas Petazzoni написал:
> > However, it indeed seems to be a possible optional dependency of wget,
> > in which case what you want is the following addition in wget.mk:
> > 
> > ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
> > WGET_DEPENDENCIES += util-linux
> > endif
> 
> Looks good, although one could argue if keeping *_DEPENDENCIES up-to-date is 
> important when we also have dependency assurance in Config.in.

No. These are two different levels of dependencies. Config.in 'select' 
determines which packages are to be built. You need this for mandatory 
dependencies. The per package $(PKG)_DEPENDENCIES determines the ORDER of the 
build. $(PKG)_DEPENDENCIES should list both mandatory AND optional 
dependencies to get a reproducible result.

baruch
Alexander Potashev July 1, 2014, 10:08 a.m. UTC | #4
Hello Thomas,

В письме от 1 июля 2014 11:35:49 пользователь Thomas Petazzoni написал:
> I don't think libuuid is a mandatory dependency of wget, and if it was,
> your patch would not be sufficient, because it does not add
> 'util-linux' to WGET_DEPENDENCIES.

I was wrong: it is an optional dependency. I had a problem running wget 
because it found libuuid.so dangling somewhere in my Buildroot working copy 
but it was not installed onto the target. So it was a typical Buildroot non-
clean rebuild problem, not a bug.

Sorry for the noise.

> However, it indeed seems to be a possible optional dependency of wget,
> in which case what you want is the following addition in wget.mk:
> 
> ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
> WGET_DEPENDENCIES += util-linux
> endif

Looks good, although one could argue if keeping *_DEPENDENCIES up-to-date is 
important when we also have dependency assurance in Config.in.
Alexander Potashev July 1, 2014, 10:12 a.m. UTC | #5
Hi Baruch,

В письме от 1 июля 2014 13:07:27 Вы написали:
> On Tue, Jul 01, 2014 at 01:55:35PM +0400, Alexander Potashev wrote:
> > Looks good, although one could argue if keeping *_DEPENDENCIES up-to-date
> > is important when we also have dependency assurance in Config.in.
> 
> No. These are two different levels of dependencies. Config.in 'select'
> determines which packages are to be built. You need this for mandatory
> dependencies. The per package $(PKG)_DEPENDENCIES determines the ORDER of
> the build. $(PKG)_DEPENDENCIES should list both mandatory AND optional
> dependencies to get a reproducible result.

Thanks for clarification! Now I see the change suggested by Thomas is 
important.
Peter Korsgaard July 1, 2014, 11:29 a.m. UTC | #6
>>>>> "Alexander" == Alexander Potashev <a.potashev@geoscan.aero> writes:

 > Hi Baruch,
 > В письме от 1 июля 2014 13:07:27 Вы написали:
 >> On Tue, Jul 01, 2014 at 01:55:35PM +0400, Alexander Potashev wrote:
 >> > Looks good, although one could argue if keeping *_DEPENDENCIES up-to-date
 >> > is important when we also have dependency assurance in Config.in.
 >> 
 >> No. These are two different levels of dependencies. Config.in 'select'
 >> determines which packages are to be built. You need this for mandatory
 >> dependencies. The per package $(PKG)_DEPENDENCIES determines the ORDER of
 >> the build. $(PKG)_DEPENDENCIES should list both mandatory AND optional
 >> dependencies to get a reproducible result.

 > Thanks for clarification! Now I see the change suggested by Thomas is 
 > important.

Great, I've committed a patch adding the optional libuuid
depency. Thanks.
diff mbox

Patch

diff --git a/package/wget/Config.in b/package/wget/Config.in
index 26a2019..fc7ee26 100644
--- a/package/wget/Config.in
+++ b/package/wget/Config.in
@@ -3,6 +3,8 @@  config BR2_PACKAGE_WGET
 	# fork()
 	depends on BR2_USE_MMU
 	depends on BR2_USE_WCHAR
+	select BR2_PACKAGE_UTIL_LINUX
+	select BR2_PACKAGE_UTIL_LINUX_LIBUUID
 	help
 	  Network utility to retrieve files from http, https and ftp.