diff mbox

[v8,13/28] sdl: Add new dependency libglu for opengl support

Message ID 1400342276-10303-14-git-send-email-bernd.kuhls@t-online.de
State Superseded
Headers show

Commit Message

Bernd Kuhls May 17, 2014, 3:57 p.m. UTC
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/sdl/sdl.mk |    5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN May 17, 2014, 8 p.m. UTC | #1
Bernd, All,

On 2014-05-17 17:57 +0200, Bernd Kuhls spake thusly:
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/sdl/sdl.mk |    5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
> index 8d0e5bd..e8ee0c0 100644
> --- a/package/sdl/sdl.mk
> +++ b/package/sdl/sdl.mk
> @@ -62,9 +62,12 @@ SDL_DEPENDENCIES += alsa-lib
>  endif
>  
>  ifeq ($(BR2_PACKAGE_MESA3D),y)
> -SDL_DEPENDENCIES += mesa3d
> +SDL_DEPENDENCIES += libglu mesa3d
> +SDL_CONF_OPT += --enable-video-opengl
>  endif
>  
> +SDL_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)

It looks like this should be in a separate patch. If it is needed here,
then please expand the commit log with the reason libiconv is now a
dependency of sdl.

Regards,
Yann E. MORIN.

>  SDL_CONF_OPT += --enable-pulseaudio=no \
>  		--disable-arts \
>  		--disable-esd \
> -- 
> 1.7.10.4
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox

Patch

diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index 8d0e5bd..e8ee0c0 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -62,9 +62,12 @@  SDL_DEPENDENCIES += alsa-lib
 endif
 
 ifeq ($(BR2_PACKAGE_MESA3D),y)
-SDL_DEPENDENCIES += mesa3d
+SDL_DEPENDENCIES += libglu mesa3d
+SDL_CONF_OPT += --enable-video-opengl
 endif
 
+SDL_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
 SDL_CONF_OPT += --enable-pulseaudio=no \
 		--disable-arts \
 		--disable-esd \