diff mbox

luajit: fix a runtime error

Message ID 1400174275-13838-1-git-send-email-francois.perrad@gadz.org
State Accepted
Commit 23f7d8ece77bcb504d1b6f33a89ff0a8a32301a1
Headers show

Commit Message

Francois Perrad May 15, 2014, 5:17 p.m. UTC
this patch fixes :
    luajit: error while loading shared libraries: libluajit-5.1.so.2: cannot open shared object file: No such file or directory

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/luajit/luajit-06-install-so.patch | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 package/luajit/luajit-06-install-so.patch

Comments

Peter Korsgaard May 16, 2014, 2:10 p.m. UTC | #1
>>>>> "Francois" == Francois Perrad <fperrad@gmail.com> writes:

 > this patch fixes :
 >     luajit: error while loading shared libraries: libluajit-5.1.so.2: cannot open shared object file: No such file or directory

 > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>

Committed, thanks.
diff mbox

Patch

diff --git a/package/luajit/luajit-06-install-so.patch b/package/luajit/luajit-06-install-so.patch
new file mode 100644
index 0000000..738ec07
--- /dev/null
+++ b/package/luajit/luajit-06-install-so.patch
@@ -0,0 +1,22 @@ 
+fix the following runtime error :
+    luajit: error while loading shared libraries: libluajit-5.1.so.2: cannot open shared object file: No such file or directory
+
+by creating two symbolic links:
+    libluajit-5.1.so -> libluajit-5.1.so.2.0.3
+    libluajit-5.1.so.2 -> libluajit-5.1.so.2.0.3
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -56,7 +56,7 @@
+ INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL_ANAME)
+ INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
+ INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
+-INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
++INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT).$(MAJVER)
+ INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
+ INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
+ INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)