diff mbox

[v2,03/24] armadillo: new package

Message ID 1398208556-4195-4-git-send-email-s.martin49@gmail.com
State Accepted
Headers show

Commit Message

Samuel Martin April 22, 2014, 11:15 p.m. UTC
Armadillo is a C++ linear algebra library.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>

---
changes v1 -> v2:
- rebase
- add comment when toolchain has not C++
---
 package/Config.in              |  1 +
 package/armadillo/Config.in    | 12 ++++++++++++
 package/armadillo/armadillo.mk | 15 +++++++++++++++
 3 files changed, 28 insertions(+)
 create mode 100644 package/armadillo/Config.in
 create mode 100644 package/armadillo/armadillo.mk

Comments

Yann E. MORIN May 3, 2014, 5:08 p.m. UTC | #1
Samuel, All,

On 2014-04-23 01:15 +0200, Samuel Martin spake thusly:
> Armadillo is a C++ linear algebra library.
> 
> Signed-off-by: Samuel Martin <s.martin49@gmail.com>

This should come _after_ you add the clapack package, since it is a
dependency of armadillo.

Some other comments below...

[--SNIP--]
> diff --git a/package/Config.in b/package/Config.in
> index 07fd166..4475b07 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -766,6 +766,7 @@ source "package/zyre/Config.in"
>  endmenu
>  
>  menu "Other"
> +source "package/armadillo/Config.in"
>  source "package/apr/Config.in"
>  source "package/apr-util/Config.in"
>  source "package/argp-standalone/Config.in"

Alphabetical order, please.

[--SNIP--]
> diff --git a/package/armadillo/armadillo.mk b/package/armadillo/armadillo.mk
> new file mode 100644
> index 0000000..b2cfdfc
> --- /dev/null
> +++ b/package/armadillo/armadillo.mk
> @@ -0,0 +1,15 @@
> +################################################################################
> +#
> +# armadillo
> +#
> +################################################################################
> +
> +ARMADILLO_VERSION_MAJOR = 4.000
> +ARMADILLO_VERSION = $(ARMADILLO_VERSION_MAJOR).4

There's now 4.300 availble. If 4.000 is a requirement, there's now
4.000.5.

With the patch re-ordering, plus the alphabetical sort, you can add my
reviewed tag (not added here, so patchwork does not catch it.)

Regards,
Yann E. MORIN.
Samuel Martin May 3, 2014, 7:50 p.m. UTC | #2
Yann, all,

On Sat, May 3, 2014 at 7:08 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> Samuel, All,
>
> On 2014-04-23 01:15 +0200, Samuel Martin spake thusly:
>> Armadillo is a C++ linear algebra library.
>>
>> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
>
> This should come _after_ you add the clapack package, since it is a
> dependency of armadillo.

Ah! right! i rebased it too much :-/

>
> Some other comments below...
>
> [--SNIP--]
>> diff --git a/package/Config.in b/package/Config.in
>> index 07fd166..4475b07 100644
>> --- a/package/Config.in
>> +++ b/package/Config.in
>> @@ -766,6 +766,7 @@ source "package/zyre/Config.in"
>>  endmenu
>>
>>  menu "Other"
>> +source "package/armadillo/Config.in"
>>  source "package/apr/Config.in"
>>  source "package/apr-util/Config.in"
>>  source "package/argp-standalone/Config.in"
>
> Alphabetical order, please.
good catch!

>
> [--SNIP--]
>> diff --git a/package/armadillo/armadillo.mk b/package/armadillo/armadillo.mk
>> new file mode 100644
>> index 0000000..b2cfdfc
>> --- /dev/null
>> +++ b/package/armadillo/armadillo.mk
>> @@ -0,0 +1,15 @@
>> +################################################################################
>> +#
>> +# armadillo
>> +#
>> +################################################################################
>> +
>> +ARMADILLO_VERSION_MAJOR = 4.000
>> +ARMADILLO_VERSION = $(ARMADILLO_VERSION_MAJOR).4
>
> There's now 4.300 availble. If 4.000 is a requirement, there's now
> 4.000.5.
Yep, i think bumping packages is often easier than getting them
integrated, so i keep it for later (the same is true for opencv,
numpy, and maybe others ;-])

>
> With the patch re-ordering, plus the alphabetical sort, you can add my
> reviewed tag (not added here, so patchwork does not catch it.)
>

Thanks,

> Regards,
> Yann E. MORIN.
>
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
Peter Korsgaard May 4, 2014, 9:18 p.m. UTC | #3
>>>>> "Samuel" == Samuel Martin <s.martin49@gmail.com> writes:

 > Armadillo is a C++ linear algebra library.
 > Signed-off-by: Samuel Martin <s.martin49@gmail.com>

 > ---
 > changes v1 -> v2:
 > - rebase
 > - add comment when toolchain has not C++
 > ---
 >  package/Config.in              |  1 +
 >  package/armadillo/Config.in    | 12 ++++++++++++
 >  package/armadillo/armadillo.mk | 15 +++++++++++++++
 >  3 files changed, 28 insertions(+)
 >  create mode 100644 package/armadillo/Config.in
 >  create mode 100644 package/armadillo/armadillo.mk

 > diff --git a/package/Config.in b/package/Config.in
 > index 07fd166..4475b07 100644
 > --- a/package/Config.in
 > +++ b/package/Config.in
 > @@ -766,6 +766,7 @@ source "package/zyre/Config.in"
 >  endmenu
 
 >  menu "Other"
 > +source "package/armadillo/Config.in"
 >  source "package/apr/Config.in"
 >  source "package/apr-util/Config.in"
 >  source "package/argp-standalone/Config.in"
 > diff --git a/package/armadillo/Config.in b/package/armadillo/Config.in
 > new file mode 100644
 > index 0000000..8d7e9f3
 > --- /dev/null
 > +++ b/package/armadillo/Config.in
 > @@ -0,0 +1,12 @@
 > +comment "armadillo needs a toolchain w/ C++"
 > +	depends on !BR2_INSTALL_LIBSTDCPP

As clapack needs largefile, then so does armadillo.

Committed with this and Yann's ordering comment fixed, thanks.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 07fd166..4475b07 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -766,6 +766,7 @@  source "package/zyre/Config.in"
 endmenu
 
 menu "Other"
+source "package/armadillo/Config.in"
 source "package/apr/Config.in"
 source "package/apr-util/Config.in"
 source "package/argp-standalone/Config.in"
diff --git a/package/armadillo/Config.in b/package/armadillo/Config.in
new file mode 100644
index 0000000..8d7e9f3
--- /dev/null
+++ b/package/armadillo/Config.in
@@ -0,0 +1,12 @@ 
+comment "armadillo needs a toolchain w/ C++"
+	depends on !BR2_INSTALL_LIBSTDCPP
+
+config BR2_PACKAGE_ARMADILLO
+	bool "armadillo"
+	depends on BR2_INSTALL_LIBSTDCPP
+	select BR2_PACKAGE_CLAPACK
+	help
+	  Armadillo: An Open Source C++ Linear Algebra Library for
+	  Fast Prototyping and Computationally Intensive Experiments.
+
+	  http://arma.sourceforge.net/
diff --git a/package/armadillo/armadillo.mk b/package/armadillo/armadillo.mk
new file mode 100644
index 0000000..b2cfdfc
--- /dev/null
+++ b/package/armadillo/armadillo.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# armadillo
+#
+################################################################################
+
+ARMADILLO_VERSION_MAJOR = 4.000
+ARMADILLO_VERSION = $(ARMADILLO_VERSION_MAJOR).4
+ARMADILLO_SITE = http://downloads.sourceforge.net/project/arma/
+ARMADILLO_DEPENDENCIES = clapack
+ARMADILLO_INSTALL_STAGING = YES
+ARMADILLO_LICENSE = MPLv2.0
+ARMADILLO_LICENSE_FILES = LICENSE.txt
+
+$(eval $(cmake-package))