diff mbox

[1/1] zeromq: disable test_fork

Message ID 1398192173-5081-1-git-send-email-jerzy.grzegorek@trzebnica.net
State Superseded
Headers show

Commit Message

Jerzy Grzegorek April 22, 2014, 6:42 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/439/439df2ad4482d08f295dbc40b2e88bf9167a7794/

Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>
---
 package/zeromq/zeromq-01-disable-test_fork.patch |   22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 package/zeromq/zeromq-01-disable-test_fork.patch

Comments

Thomas Petazzoni April 22, 2014, 9:37 p.m. UTC | #1
Dear Jerzy Grzegorek,

On Tue, 22 Apr 2014 20:42:52 +0200, Jerzy Grzegorek wrote:

> diff --git a/package/zeromq/zeromq-01-disable-test_fork.patch b/package/zeromq/zeromq-01-disable-test_fork.patch
> new file mode 100644
> index 0000000..48a76ab
> --- /dev/null
> +++ b/package/zeromq/zeromq-01-disable-test_fork.patch
> @@ -0,0 +1,22 @@
> +Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>

Even though this patch is quite trivial, we need a patch description
anyway.

> +
> +--- a/tests/Makefile.am	2014-04-18 15:24:35.000000000 +0200
> ++++ b/tests/Makefile.am	2014-04-22 11:31:08.000000000 +0200
> +@@ -46,8 +46,7 @@ if !ON_MINGW
> + noinst_PROGRAMS += test_shutdown_stress \
> +                    test_pair_ipc \
> +                    test_reqrep_ipc \
> +-                   test_timeo \
> +-                   test_fork
> ++                   test_timeo
> + endif
> + 
> + test_system_SOURCES = test_system.cpp
> +@@ -93,7 +92,6 @@ test_shutdown_stress_SOURCES = test_shut
> + test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
> + test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
> + test_timeo_SOURCES = test_timeo.cpp
> +-test_fork_SOURCES = test_fork.cpp
> + endif
> + 
> + #  Run the test cases

I would actually prefer a patch that adds an AC_CHECK_FUNCS([fork])
test to configure.ac, and uses that to build test_fork or not. In this
case, the patch could be submitted upstream.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/zeromq/zeromq-01-disable-test_fork.patch b/package/zeromq/zeromq-01-disable-test_fork.patch
new file mode 100644
index 0000000..48a76ab
--- /dev/null
+++ b/package/zeromq/zeromq-01-disable-test_fork.patch
@@ -0,0 +1,22 @@ 
+Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>
+
+--- a/tests/Makefile.am	2014-04-18 15:24:35.000000000 +0200
++++ b/tests/Makefile.am	2014-04-22 11:31:08.000000000 +0200
+@@ -46,8 +46,7 @@ if !ON_MINGW
+ noinst_PROGRAMS += test_shutdown_stress \
+                    test_pair_ipc \
+                    test_reqrep_ipc \
+-                   test_timeo \
+-                   test_fork
++                   test_timeo
+ endif
+ 
+ test_system_SOURCES = test_system.cpp
+@@ -93,7 +92,6 @@ test_shutdown_stress_SOURCES = test_shut
+ test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
+ test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
+ test_timeo_SOURCES = test_timeo.cpp
+-test_fork_SOURCES = test_fork.cpp
+ endif
+ 
+ #  Run the test cases